Encore une fausse manip...

27 réponses [Dernière contribution]
pyrotrisquel
Hors ligne
A rejoint: 06/22/2017

bonjour à toutes tous

mon erreur est que j'ai utilisé par mégarde l'application "disques et partitions" de gnome (je crois ?), en supprimant le dossier de base de Sparky...
Je voulais le faire sur la cle que je venais de mettre, erreur de débile, je sais bien que je suis le chef...
d'habitude, j'utilise gparted, là non, d'où l'erreur, mais de toute manière, c'est bien de ma faute...

Resterait-il une solution pour récupérer les partitions ?
Meme gparted ne les reconnait pas... ça sent pas bon...

j'ai tenté de "reprendre" lamain avec "Boot-repair" & "Grub-customizer" mais l'aide est refusé pour GC, probleme de reconnaissance (immage jointe) et BR ne propose pas de réparation....

merci pour l'aide à venir

bonne soirée à toutes et tous

ps; en plus, sur une des partoches, il y avait des documents très importants.... snif

Fichier attachéTaille
pb grub-customizer.png12.98 Ko
Magic Banana

I am a member!

En ligne
A rejoint: 07/24/2010

Depuis un système live, installe donc TestDisk et essaie de suivre ces étapes : https://www.cgsecurity.org/wiki/TestDisk_Etape_par_Etape

Comme écrit en bas de la page avec un lien, si tu ne parviens pas à retrouver les partitions perdues, il y a aussi PhotoRec (fourni par le même paquet « testsdisk » dans le dépôt Trisquel) qui permet de récupérer des fichiers. Et, on ne le répète jamais assez, il faut réaliser des sauvegardes fréquentes (par exemple avec Back In Time, par défaut dans Trisquel 9).

pyrotrisquel
Hors ligne
A rejoint: 06/22/2017

Bonjour Magic Banana et merci pour ton aide

je vais voir ton lien avec Testdisk et je te tiens au courant

pour les sauvegardes, tout à fait de ton avis, mais "ma" sauvegarde est juste pour sda1 oùj'ai mon systeme... Il faudra que j'organise cela autrement....
encore merci et bonne journée

testdisk a tout bien reconnnu & enregistré avec "Write" mais ensuite, après redémarrage, petit souci pour démarrer....
Gparted reconnait bien les partoches... (merci Magic Banana pour le coup de main...) mais il y a sur /dev/sda1 un petit logo de "risque" ?

merci pour ton aide

Et de toute maniere, grace à toi, j'ai déjà retrouver mes autres partoches..., je pourrais faire la restau image de Clonezilla mais au cas où, autant récupérer la config initiale...
Merci car le plus important est déjà retrouvé.... Ouf !!! Chapeau bas MB !!!

pb gparted.png
Magic Banana

I am a member!

En ligne
A rejoint: 07/24/2010

"ma" sauvegarde est juste pour sda1 oùj'ai mon systeme...

Sauvegarder le système n’est pas vraiment utile : un système, ça se réinstalle, alors que tes documents personnels…

Gparted reconnait bien les partoches... (merci Magic Banana pour le coup de main...) mais il y a sur /dev/sda1 un petit logo de "risque" ?

Je ne sais pas ce que signifie cette icône. Un clic droit sur la ligne te permet peut-être d'accéder à une explication. Une corruption du système de fichiers peut-être ? Étant donné la boulette, il semble bon de réinstaller Trisquel, après avoir mis à l’abri les données des utilisateurs.

pyrotrisquel
Hors ligne
A rejoint: 06/22/2017

salut à toi Magic Banana
et merci pour le suivi de l'affaire...

pour ce qui est des sauvegardes..., chacun ses choix... mais mon choix premier est que je n'ai aucune mémoire, donc je prefere sauver mon systeme....
De plus, grace à toi et à TestDisk, j'ai recupere tous mes docs importants, que j'enregistre de temps en temps sur disque dur !

je te joins une photo de mon gparted "à jour", j'ai une partoche vide dedans, c'est normal !. Puis-je tenter de mettre une partoche EFI pour essayer de rebooter dessus, ou bien il est aussi simple de restaurer une image ?

encore et toujours merci

gparted-16.16.png
Magic Banana

I am a member!

En ligne
A rejoint: 07/24/2010

je te joins une photo de mon gparted "à jour"

Plus d’icône « danger ». Il s’agissait probablement d'une corruption du système de fichiers qui a été corrigée (peut-être automatiquement) avec fsck.

Puis-je tenter de mettre une partoche EFI pour essayer de rebooter dessus, ou bien il est aussi simple de restaurer une image ?

C’est toi qui vois. Comme je te l’écrivais, peut-être à tort, je n’aurais personnellement pas une grande confiance en un système où des partitions ont été supprimées puis récupérées. C’est pourquoi je suggérais une nouvelle installation. Mais si tu as une image de tout, restaurer cela semble parfait. Je ne crée jamais de telles images et n’est donc aucune expérience en la matière.

pyrotrisquel
Hors ligne
A rejoint: 06/22/2017

ok et merci pour toute ton aide
je viendrai dire ce qu'il en est après le test de restauration système.
encore tous mes remerciements
bonne fin de journée

pyrotrisquel
Hors ligne
A rejoint: 06/22/2017

bonjour
Donc j'ai restauré mon image, tout s'est bien passé avec une petite erreur de boot après restauration, logique...
Un petit coup de "Boot-Repair" et ça roule...
Merci pour ton aide et bonne fin de journée

pyrotrisquel
Hors ligne
A rejoint: 06/22/2017

Bonjour Magic Banana

je me permets des petites questions qui me dérangent quelque peu...
Tu disais qu'il valait mieux, profiter d'un nettoyage pour remettre un système nickel, j'ai dit que non car cela fonctionnait....
Oui mais...
Pas longtemps...
Donc rideau ce matin avec un bug "ingérable pour les foufous comme moi", donc j'ai vidé mon DD, remis une version de sparky 7 mini, j'ai mis à jour, tout ok, j'ai essayé de réduire en 2 la partition systeme (en ext4) et RE rideau....

Donc je me tourne vers toi pour te demander s'il y des solutions plus habiles que le formatage perpétuel...

1 - J'arrive à démarrer en utilisant le boot sur SuperGrub2 puis je choisi "gnu-linux", ça marche...
Un des soucis pour ce mauvais départ: il est noté "problème Locked-NVram détecté" ?
Mais je sais bien que si j'arrive à démarrer avec SuperGrub2, c'est juste du à une erreur dans le grub, mais quoi ?

2 - Ma partition systeme fait 400Go, j'aurai souhaité la diminuer pour la séparer en 2: 100 & 300 Go. C'est du Ext4 mais Gparted refuse de la diminuer, je ne saisis pas non plus ce problème...

3 - Sur mon ancien systeme, le "vieux" d'il y a 3 jours, j'utilisais Lifeguard pour gérer les déconnexions, mais maintenant, je n'arrive pas à ce que cette appli décolle à chaque démarrage. Elle ne se lance pas du tout...

Grand merci pour toi si tu peux répondre à ces questions, bien sur toutes mes excuses. Il n'y a pas le feu et encore merci

bonne soirée

Magic Banana

I am a member!

En ligne
A rejoint: 07/24/2010

Puisque tu pars sur une nouvelle installation, tu peux tout simplement supprimer (par exemple depuis GParted) les partitions des systèmes que tu ne veux plus et des données que tu as sauvegardées juste avant. Peut-être qu’il s’agit là de toutes les partitions. Ainsi tu laisses à l’installeur de l’espace libre. Soit tu le laisse réaliser l’installation par défaut soit tu définis ce que tu veux (avec le type d’installation « Autre chose » pour Trisquel).

Si ce que tu appelles la « partition système » est la partition racine et que /home est séparée (ce qui permet notamment de changer le système en gardant le /home du système remplacé), alors 100 Go (a fortiori 300 GB) est certainement exagéré. Tu peux choisir 40 Go pour être vraiment tranquille. Ainsi tu gagnes de la place pour /home.

Je ne connais pas Lifeguard, qui n’est pas dans le dépôt. S’il s’agit d’un service lancé à l’init, c’est « systemctl enable » qui l’ajoute. Si c’est au démarrage de la session, vois les « Applications au démarrage » (dans les « Ajustements » sur GNOME, mais je crois que l’environnement de bureau MATE de Trisquel a un utilitaire dédié).

pyrotrisquel
Hors ligne
A rejoint: 06/22/2017

salut MB

hier, j'ai tout supprimé, j'ai fait l'install avec formater tout le disque et l'installer dessus....

mais par exemple, ce qui m'empeche de booter dessus, voilà ce qui apparait à l'écran:

gnu grub version 2.04-20 - minimal bash-like line editing is supported . for the first word, tab lisis possible command completions...

Mise en connexion hasardeuse et très lente et tous les soucis rencontres au sujet 8 !

merci pour ton aide

bonne journée

Magic Banana

I am a member!

En ligne
A rejoint: 07/24/2010

Je ne te comprends pas bien. Tu écris être « empêch[é] de booter dessus » puis montre un message du chargeur de démarrage qui ne semble pas être une erreur. Puis tu mentionnes une « mise en connexion hasardeuse et très lente ». Je suppose que tu parles de ta connexion réseau. Mais si tu ne parviens pas à démarrer le système, comment peux-tu tester sa connexion réseau ?

Essaie de décrire plus clairement ce qu’il se passe (quand exactement es-tu « empêché » de démarrer sur le nouveau système, qu’entends-tu pas « connexion hasardeuse », etc.). Aussi : est-on en train de parler de Trisquel ou d’un autre système ? L’as-tu déjà installé par le passé sur cette même machine ? Je demande, car l’installeur graphique de Trisquel (aussi celui d’Ubuntu) supporte mal le matériel récent (mais son installeur textuel devrait fonctionner).

pyrotrisquel
Hors ligne
A rejoint: 06/22/2017

salut et mille excuses Magic Banana, j'écris comme un sauvage et rien n'est compréhensible...
Je reprends...
- hier, j'ai tout supprimé, j'ai fait l'install avec formater tout le disque et l'installer dessus....
=> Hier, j'ai vider totalement le disque dur et j'ai effectué une installation sur le disque entier !

- mais par exemple, ce qui m'empeche de booter dessus, voilà ce qui apparait à l'écran:
gnu grub version 2.04-20 - minimal bash-like line editing is supported . for the first word, tab lisis possible command completions...
=> L'installation finie, tout est ok mais lors du premier redémarrage, impossible de booter sur le disque dur, un message apparaît:
"gnu grub version 2.04-20 - minimal bash-like line editing is supported . for the first word, tab lisis possible command completions"

- Mise en connexion hasardeuse et très lente et tous les soucis rencontres au sujet 8 !
=> pour démarrer je devais utiliser ma clé usb avec mes images dessus et booter sur "SuperGrub2" pour réussir à rentrer sur le système que je venais d'installer Il est vrai aussi qu'à l'ouverture du système installé, la connexion "réseau" mettait beaucoup de temps à arriver...

Et je refaisais un petit passage par ici car le souci premier vient de mon ISO. Il a du etre mal installé, ou copié, car je l'ai remis en testant sur une autre clé, et là tout fonctionne...
Je teste Sparky 7 en mini et/ou en normal...

Merci pour ta résistance et ton aide

bonne journée

pyrotrisquel
Hors ligne
A rejoint: 06/22/2017

bonjour Magic Banana et les autres

je suis desole de donner des news aussi rapidement mais... Rien ne change chez moi...
Je souhaite que tu veuilles bien m'aider sur cette gaffe...
Mais bien sur si d autres sont presents je n'oserai dire non....

explication rapide
ma version partait en vrac de plus en plus, surement de ma faute, -connexion coupee-vpn coupe-blocage dans les dossiers-etc...- j'ai donc voulu faire une restauration systeme avec une image clonezilla deja utilisee et qui etait ok. Le probleme est qu'apres la restau, souci de grub... donc boot-repair mais rien n'y fait

je suis donc dans la panade...

merci pour l aide a venir

bonne journee a toutes et tous

partoches.png
Fichier attachéTaille
Boot-Info-19.10.21-20211018_2212.txt 14.55 Ko
Magic Banana

I am a member!

En ligne
A rejoint: 07/24/2010

ma version partait en vrac de plus en plus...

Le plus simple et probablement le plus rapide est de sauvegarder les données des utilisateurs, peut-être la liste des applications installées ( https://trisquel.info/en/wiki/cloning-system-or-how-make-copy-installed-packages-one-computer-another ) et de réinstaller depuis une ISO.

Tu peux néanmoins déjà tester le disque dur et la RAM et, s’il y a une défaillance, en changer :

  • Pour le disque, tu peux installer GNOME Disques avec le gestionnaire de paquets (le paquet s’appelle « gnome-disk-utility »), le lancer, sélectionner le disque suspect à gauche de la fenêtre et, dans le menu dont l’icône représente trois segments empilés, cliquer sur « Données SMART et auto-tests… (Ctrl+S) ». Une nouvelle fenêtre s’affiche, avec les données SMART et la possibilité de « Démarrer l’auto-test », d’un clic sur le bouton éponyme.
  • Pour la RAM, installe le paquet nommé « memtest86+ », redémarre et, au menu de GNU GRUB, plutôt que de démarrer Trisquel, lance « Memory Test » (ou quelque chose du genre) avec la flèche du bas puis Entrée. L’écran, avec un fond bleu, t’indique le test de la RAM qui est en cours : MemTest86+ écrit dans la RAM différents motifs puis lit au même endroit et voit s’il s’agit bien de ce qu’il a écrit. Laisse le test tourner pendant une bonne nuit. Si, au matin, le fond de l’écran est devenu rouge, c’est que la RAM est défaillante.
pyrotrisquel
Hors ligne
A rejoint: 06/22/2017

Salut MB et grand merci (encore et encore...) pour ton aide !
Je vais verifier tout cela, tester et je te tiens au courant
bonne journée

J'ai fait l'auto test, il n'y a qu'une erreur, disque dur reconnu sain...

Y a-t-il moyen de reprendre la main au boot ou dois-je remplacer le systeme ?

merci

Magic Banana

I am a member!

En ligne
A rejoint: 07/24/2010

Y a-t-il moyen de reprendre la main au boot ou dois-je remplacer le systeme ?

Je ne suis pas sûr de comprendre. Te réfères-tu à l’exécution de memtest86+ ? Si tu ne parviens pas à démarrer un système installé, tu peux utiliser une ISO qui contient cet outil. Sinon, tu peux démarrer le système live de Trisquel, sauvegarder les données des utilisateurs, installer Trisquel 9, redémarrer sur le système installé, y installer memtest86+ et redémarrer de nouveau pour lancer le test depuis le menu de GRUB.

pyrotrisquel
Hors ligne
A rejoint: 06/22/2017

salut MB

tu commences à me connaître..., donc c'est fait !
J'ai formaté ma partition et tout revient... à petits pas !

Je n'ai pas installé Trisquel 9 mini car j'avais eu de sérieux soucis avec mon casque bluetooth, mon vpn et ma connexion...
Pourtant, la version 9 en mini est tout mignonne ! J'adore vraiment cette version, au moins en live, mais bloqué sur quelques soucis d'application !

Je sais bien que je suis c.., mais je déteste attendre ! Mais je suis bien d’accord que c'est totalement idiot, surtout pour un newbie comme moi ! :(

grand merci à toi pour ton aide

pyrotrisquel
Hors ligne
A rejoint: 06/22/2017

salut Magic Banana (et les autres...)

Quelques petits questions restent d'actualité...

1 - Après tests sur un autre pc, impossible d'installer la version 9 de Trisquel ? La version live fonctionne nickel mais elle ne veut pas s'installer... Quand l'installation arrive à la fin, un message d'excuse arrive pour prévenir qu'il y a un souci grub "et/ou" efi... Tenter plusieurs fois, avec plusieurs choix de bios.... Impossible ?

2 - Ton lien sur la sauvegarde des applis est nickel (c'est ça qu'est-ce-qui me faut...) mais à savoir: les applis sauvées on les intègre en + ou en remplacement ? Pour la restauration, on doit le faire avec une version live ? Je n'ai pas réussi autrement ?

3 - Peut-on remplacer le nom des partoches qui sont devenues: /mnt/f52711e6-a138-4638-83d6-186d285s9ee3...

Oui je sais bien que dès que je fais quelque chose sur un pc, il en découle une pluie de questions...., mais c'est juste parce que j'aime l'eau !

Merci pour l'aide à venir

bonne soirée

Magic Banana

I am a member!

En ligne
A rejoint: 07/24/2010
  1. Il est possible que l’installateur graphique utilisé par Trisquel n’arrive pas à ses fins sur un ordinateur récent. C’est le cas sur mon dernier portable. Essaie l’installateur textuel, qui, sauf erreur, peut-être démarré depuis la même ISO (dans le menu juste après le démarrage sur l’ISO).
  2. En plus (le système installé par défaut ne va pas être supprimé). Tu crées le fichier depuis le « Gestionnaire de paquets Synaptic » sur le système dont tu veux la liste des paquets installer. Tu lis ce fichier depuis le « Gestionnaire de paquets Synaptic » sur le système fraîchement installé où tu veux ces mêmes paquets.
  3. Je crois que tu te réfères aux points de montage des systèmes de fichiers de ton disque dur sur le système live. Si oui, les noms n’importent pas beaucoup, puisqu’il s’agit d’un système live et non du système que tu utilises au quotidien.
pyrotrisquel
Hors ligne
A rejoint: 06/22/2017

merci pour ton aide

1 - Le pc a environ 5 ans ! J'essaierai l'installation textuel ! Oui je crois que c'est proposé au départ
2 - OK et dans ce cas, nickel
3 - et non, c'est bien sur mon système et pas sur le live ! Ce n'est pas dramatique non plus...

grands mercis encore et toujours

bonne soirée

Magic Banana

I am a member!

En ligne
A rejoint: 07/24/2010

3 - et non, c'est bien sur mon système et pas sur le live !

Bizarre. Que contient le fichier /etc/fstab ? C’est là que sont définis les points de montage.

pyrotrisquel
Hors ligne
A rejoint: 06/22/2017

moi j'ai /etc/fstab.d, dedans 1 fichier nommé "live":
aufs / aufs rw 0 0
tmpfs /tmp tmpfs nosuid,nodev 0 0

*********
J'ai peut-être trouvé "tout seul" le moyen de contourner le nom de la partoche....
En utilisant "Disques" de Gnome, en sélectionnant la partition, puis en dessous, dans "Contenu", j'ai remplacé par sda3...
A première vue, c'est nickel !
Mais de toute façon, merci à toi...
Maintenant, /etc/fstab donne toujours le fichier "live", il est noté dedans les mêmes choses:
aufs / aufs rw 0 0
tmpfs /tmp tmpfs nosuid,nodev 0 0
*********

partoches.png partition renommée.png
Magic Banana

I am a member!

En ligne
A rejoint: 07/24/2010

/mnt est normalement dédié aux montages temporaires. Que contient /dev/sda3 ? Des dossiers portant les noms des utilisateurs qui serait le /home d’une installation antérieure ? Si oui, /dev/sda3 ne devrait-il pas être monté en /home (après le déplacement des fichiers dans /home, sur la partition racine, dans /dev/sda3) ?

pyrotrisquel
Hors ligne
A rejoint: 06/22/2017

salut Magic Banana

dans /dev/sda3, je n'ai que des docs perso, comptes, photos, docs vacances, etc

Moi ce que j'ai vu c'est --au moins--- que c'était plus simple pour suivre des docs avec "lien" sda3...

Tout mon systeme linux est dans /dev/sda2

merci pour ton suivi

bonne soirée (ou nuit, c'est selon...)

Magic Banana

I am a member!

En ligne
A rejoint: 07/24/2010

dans /dev/sda3, je n'ai que des docs perso, comptes, photos, docs vacances, etc

Tes fichiers personnels sont censés se trouver dans ton dossier personnel (mais tu fais bien comme tu veux).

Moi ce que j'ai vu c'est --au moins--- que c'était plus simple pour suivre des docs avec "lien" sda3...

J’imagine que ton gestionnaire de fichiers doit permettre l’ajout de « signets » (peut-être appelés « marque-pages » ou « favoris »). En tout cas celui de GNOME le permet.

pyrotrisquel
Hors ligne
A rejoint: 06/22/2017

salut MB

donc pour mes docs, etc..., technique de windows..., rangés de coté, tu peux plus facilement les retrouver en cas de problème...
Non que je sois "négatif" avec les systèmes linux, mais newbie comme je suis, vaut mieux que je "me" protège... de mon moi-même !

non je n’ai pas dans cette version mini de Sparky, version 6 en LXDE, de choix pour créer des raccourcis..., mais je le sais et c'est noté... donc je m'en occuperais...

merci encore et toujours de ton aide et de ton suivi

bonne fin de journée à toi

pyrotrisquel
Hors ligne
A rejoint: 06/22/2017

salut

Je voulais dire que suite au message que tu as mis sur les "soucis" de l'installateur graphique de Trisquel 9, mini ou pas, je l'ai testé sur le pc !

Test sur un pc sur lequel j'installe le système en entier, tout est fait, créé par le système, dont le formatage...

Même config Bios, Disque dur en GPT avec UEFI pour l'installation !

- Trisquel 9: tout débute bien mais fini en rideau avec le message d'excuse... Blocage vers la fin ou à la fin !

- Sparky 6: Tout s'est déroulé normalement

Je ne fais pas de pub pour Sparky, mais je voulais tester pour "voir"... Je crois même avoir "quitté" Trisquel pour ce problème...

bonne journée à toutes et tous