graphics card for trisquel - Nvidia GeForce GTX 1050 ti and Nouveau

6 réponses [Dernière contribution]
Hors ligne
A rejoint: 08/16/2017

Hey guys,

I'm new to Linux in general, and I installed Trisquel 7 about 2 months ago after researching a lot about free software. My desktop pc is new and I bought the best kind of graphics card I thought I could have (i would play overwatch at the time, and I still want to set up dualboot in the future so that I can play again... I don't wanna infect my Trisquel with non free software). The guy at the store sold me a Nvidia Geforce GTX 1050 ti. I was on Windows 10 at the time, and now I'm on Trisquel7.

My Trisquel7 had no sound right after installation... I went to the store for some tips and the store guy solved it by installing the Nvidia driver for me on Trisquel7 as a maintenance courtesy service on my PC. After the installation I eventually bumped into the "login loop problem", where you put your password in the login and it doesnt really login...

I re installed the system 3 times after that. Cus I would always install Nvidia's driver and it would end up with that problem.

Now my system is once again re installed, but this time I realized that the login problem is solved by purging nvidia:

$ sudo apt-get purge nvidia*

Yesterday I found out about Nouveau ( But it seems that Nvidia hates open source software, never mind free software, which undermines Nouveau. (


I tried to install Nouveau, but it won't run. I did all the steps:

--> $ sudo apt install xserver-xorg-video-nouveau
---> editted xorg.conf

$ tail xorg.conf:

Section "Device"
Identifier "n"
Driver "nouveau"


$sudo reboot

---> The system does login and works under the configuration, but it's not really running the Nvidia card it seems.


I followed tips on this post too

$ sudo apt-get install nouveau-kernel-source
returns → E: Unable to locate package nouveau-kernel-source (guess it's outdated)


By reading this post (, it sounds like maybe my card won't run without proprietary blobs, nvidia's signed firmware...


Here are some outputs for some commands:

$ lspci
00:00.0 Host bridge: Intel Corporation Sky Lake Host Bridge/DRAM Registers (rev 07)
00:01.0 PCI bridge: Intel Corporation Sky Lake PCIe Controller (x16) (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Sky Lake Integrated Graphics (rev 06)
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA controller [AHCI mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #5 (rev f1)
00:1d.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #9 (rev f1)
00:1d.1 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #10 (rev f1)
00:1d.2 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #11 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
01:00.0 VGA compatible controller: NVIDIA Corporation Device 1c82 (rev a1)
01:00.1 Audio device: NVIDIA Corporation Device 0fb9 (rev a1)
02:00.0 Network controller: Qualcomm Atheros AR9287 Wireless Network Adapter (PCI-Express) (rev 01)
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 09)
05:00.0 PCI bridge: ASMedia Technology Inc. ASM1083/1085 PCIe to PCI Bridge (rev 04)

$ dmesg | grep -i chipset
[ 0.713640] nouveau E[ DEVICE][0000:01:00.0] unknown chipset, 0x137000a1

$ sudo lshw -c video
*-display UNCLAIMED
description: VGA compatible controller
product: NVIDIA Corporation
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller cap_list
configuration: latency=0
resources: memory:f6000000-f6ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:f7000000-f707ffff
*-display UNCLAIMED
description: VGA compatible controller
product: Sky Lake Integrated Graphics
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 06
width: 64 bits
clock: 33MHz
capabilities: pciexpress msi pm vga_controller bus_master cap_list
configuration: latency=0
resources: memory:f5000000-f5ffffff memory:d0000000-dfffffff ioport:f000(size=64)


----> both devices listed above in the last command don't even mention the word “driver” after “configuration:”. It only says: “configuration: latency=0”

Will I really need to change my graphics card? Is there any other way around this? Am I missing something? Thanks a lot in advance...

Hors ligne
A rejoint: 04/05/2012

Since you mention sound issues related to Nvidia, I guess you use HDMI/DisplayPort for both video and sound.

There should be another socket from integrated Intel graphics, which you can plug your monitor in. That way you wouldn't depend on Nvidia at all.

You seem to have an Intel audio device which might work. Maybe you can connect the audio output from the motherboard instead of using the video output if sound is the only problem. However if you use Nvidia for video you will have no 3D acceleration.

Magic Banana

I am a member!

I am a translator!

En ligne
A rejoint: 07/24/2010

Since your Intel processor integrates a graphical chipset that the (libre) kernel well supports, the best would be to physically remove the nVidia card and use the Intel integrated graphics. You would not only gain performances but also save energy.

If you don't, "nouveau" should be running. There is no need to install anything or to edit /etc/X11/xorg.conf. So if I were you, I would (re)move that configuration file:
$ sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak
Then reboot (you actually only need to restart the X server but well) and show us /var/log/Xorg.0.log (attaching it to your post) so that we can check whether "nouveau" really is handling the graphics. To improve the support, install a more recent kernel (that will include more recent drivers) following the instructions on

Hors ligne
A rejoint: 07/19/2015

If you need high graphics performance but without non-free, you should buy gtx770 with 4gb, also any Nvidia Kepler gen will work.

Hors ligne
A rejoint: 08/16/2017

Guys, thanks a lot for your help... Gonna try things here and will come back with the results... =)

Hors ligne
A rejoint: 08/16/2017

--Kernel updated (lts version)

-- Xorg.0.log cant be attached. But here are the contents of it:

$ sudo tail /var/log/Xorg.0.log
[ 34.667] (II) XKB: reuse xkmfile /var/lib/xkb/server-3BFAD2E4AD09E36FF6F5D822BA76E026D29CFCA1.xkm
[ 34.670] (II) XKB: reuse xkmfile /var/lib/xkb/server-3BFAD2E4AD09E36FF6F5D822BA76E026D29CFCA1.xkm
[ 34.672] (II) XKB: reuse xkmfile /var/lib/xkb/server-3BFAD2E4AD09E36FF6F5D822BA76E026D29CFCA1.xkm
[ 34.674] (II) XKB: reuse xkmfile /var/lib/xkb/server-3BFAD2E4AD09E36FF6F5D822BA76E026D29CFCA1.xkm
[ 34.677] (II) XKB: reuse xkmfile /var/lib/xkb/server-3BFAD2E4AD09E36FF6F5D822BA76E026D29CFCA1.xkm
[ 34.680] (II) XKB: reuse xkmfile /var/lib/xkb/server-3BFAD2E4AD09E36FF6F5D822BA76E026D29CFCA1.xkm
[ 34.682] (II) XKB: reuse xkmfile /var/lib/xkb/server-3BFAD2E4AD09E36FF6F5D822BA76E026D29CFCA1.xkm
[ 34.684] (II) XKB: reuse xkmfile /var/lib/xkb/server-3BFAD2E4AD09E36FF6F5D822BA76E026D29CFCA1.xkm
[ 34.687] (II) XKB: reuse xkmfile /var/lib/xkb/server-3BFAD2E4AD09E36FF6F5D822BA76E026D29CFCA1.xkm
[ 34.689] (II) XKB: reuse xkmfile /var/lib/xkb/server-3BFAD2E4AD09E36FF6F5D822BA76E026D29CFCA1.xkm

once again. Thanks.

Hors ligne
A rejoint: 08/16/2017

sound is working now!!!!!!!!!!!!!!!!! Thank you!!!!!!!!!!!!!!!!! \o/