grub-update issue in new Trisquel 9 makes system unbootable after update, how do I fix?

4 réponses [Dernière contribution]
red_liberty
Hors ligne
A rejoint: 12/15/2019

After both upgrading (8.0 to 9.0) and reinstalling Trisquel and Trisquel Mini 32-bit on my libreboot T60 I get a black screen with a blinking underscore in the top left corner. Had to do an emergency system backup and cannot reinstall because of this issue.

I narrowed down the problem to grub-update which happens when the new linux kernel is installed. Basically it means I can't update my system after installing Trisquel 9. See image for more info. I have no idea how to mitigate or fix this without disabling full disk encryption, which I need as it's a laptop I use on the go in case it gets stolen.

See image.

Fichier attachéTaille
IMG_6998.cleaned.jpg1.53 Mo
red_liberty
Hors ligne
A rejoint: 12/15/2019

*restart after updating my system, not update my system

diopon
Hors ligne
A rejoint: 10/15/2018

Hello red_liberty,

I had the same problem on my HP Compaq nx7300 32 bit laptop. I tried out the Trisquel-mini version too. I just solved it. I don't think it is a grub problem. I tried it a few times with a new installing Trisquel 9 and upgrading from Trisquel 8 to 9. Without success.

I think it is an lightdm or X issue.

These are the steps I did and it worked for me:

1. A fresh install of Trisquel 9.
2. Don't run a system upgrade after the installation!
3. I install the xfce4 environment. I prefer it. sudo apt install xfce4 (Maybe this step is not necessary).
4. Install lightdm-gtk-greeter-settings. sudo apt install lightdm-gtk-greeter-settings. This will change a little bit your login screen.
5. Now run a system update. sudo apt update && sudo apt upgrade
6. Reboot your system.

I hope it will work for you too.

Diopon

red_liberty
Hors ligne
A rejoint: 12/15/2019

Resolved! I installed lightdm-gtk-greeter-settings in Trisquel 9 and updated and it seems to have allowed me to restart safely. Still seeing the grub-update error message but at least this way I can boot. Thanks!

strypey
Hors ligne
A rejoint: 05/14/2015

Has this issue been fixed in Trisquel 9 yet? It may be related to the problem I am having in Trisquel 8, where I can get as far as entering the disk encryption password, but it won't proceed to the login screen.

See:
https://trisquel.info/en/forum/x60-hanging-after-entering-disk-encryption-password