Instalar la última versión de Emacs en Trisquel GNU/LInux 8

15 réponses [Dernière contribution]
arnoldfiarn
Hors ligne
A rejoint: 08/06/2012

¿Alguien sabe qué debo hacer para contar con Emacs 26.3 en mi SO? Me interesa poder usar unos paquetes pero no aparecen en mi versión actual que es la 24.5.1.

arnoldfiarn
Hors ligne
A rejoint: 08/06/2012

Ya logré instalar, por medio del código fuente, Emacs 26.2 después de instalar un montón de paquetes que ya ni me acuerdo. Ahora quiero instalar paquetes pero veo que me salen los mismos, incluso ahora tengo este mensaje de cada vez que intento instalar algún paquete obtengo los mensajes que adjunto en como imagen:

Selección_079.png
farliz
Hors ligne
A rejoint: 05/24/2015

Prueba con:

gpg --homedir ~/.emacs.d/elpa/gnupg --receive-keys 066DAFCB81E42C40

Mas informacion:

https://elpa.gnu.org/packages/gnu-elpa-keyring-update.html

Nos comentas,

saludos

arnoldfiarn
Hors ligne
A rejoint: 08/06/2012

Sí vi esa orden, al usarla obtengo:

gpg: Invalid option "--receive-keys"

Por ahí vi que a otra persona le sirvió este código:

gpg --homedir ~/.emacs.d/elpa/gnupg --keyserver hkp://keys.gnupg.net --recv-keys 066DAFCB81E42C40

Lo usé y no me arrojó error, l usar la orden

package-refresh-contents

No me arrojó más errores, luego intenté instalar el tema kaolin pero es el mismo resultado.

¿Cómo tienes tu .emacs?

farliz
Hors ligne
A rejoint: 05/24/2015

Creo que debes agregar otros repositorios de paquetes de emacs.

(require 'package)

(add-to-list 'package-archives
'("melpa" . "https://melpa.org/packages/")
'("marmalade" . "http://marmalade-repo.org/packages/"))

Con ese código en init.el o .emacs se agregan

Podrias revisar además el video 15 de unos que hice hace algún tiempo.

https://github.com/farliz/emacs-academia/blob/master/contenido.md

saludos

Screenshot_2020-06-10_14-02-05.png
farliz
Hors ligne
A rejoint: 05/24/2015

Vi que ya lo tienes en .emacs pero está comentado.

arnoldfiarn
Hors ligne
A rejoint: 08/06/2012

Seguí buscando y en un caso vi que borraron el archivo .emacs.d y el error desaparecía. Sin embargo al hacerlo yo hora todo empeoró. Mi instalación de auctex dejó de existir y ahora tendré que instalar otra vez.

Veo que no aparece en la lista de paquetes como se observa en la imagen que adjunto.

Selección_080.png
arnoldfiarn
Hors ligne
A rejoint: 08/06/2012

Después de instalar auctex desde el código fuente y configurar mi archivo .emacs con estas órdenes:

(add-to-list 'load-path "~/.emacs.d/site-lisp/auctex")
(load "auctex.el" nil t t)
(load "preview-latex.el" nil t t)

Logré obtener acceso a más paquetes como se observa en la figura adjunta, sin embargo sigue ese mensaje sobre la llave pública, ¿a qué se deberá?

Selección_081.png
farliz
Hors ligne
A rejoint: 05/24/2015

Seria buena idea intentar usar el paquete use-package

te dejo la configuracion que debe ir en init.el dentro de .emacs.d

Use package permite instalar y configurar paquetes de formar mas ordenada y portable. Es decir que puedes ejecutar el init.el en otra instalación de emacs y se instalarán los paquetes que tengas configurados.

Dentro de .emacs.d se descargan los paquetes, si borras ese directorio se borran con todos los paquetes que has instalado.

(package-initialize)

(require 'package)

(add-to-list 'package-archives
'("melpa" . "https://melpa.org/packages/")
'("marmalade" . "http://marmalade−repo.org/packages/"))

;; (let ((default−directory "~/.emacs.d/elpa/"))
;; (normal−top−level−add−subdirs−to−load−path))

(unless (package-installed-p 'use-package)
(package-refresh-contents)
(package-install 'use−package))

(use-package tex
:ensure auctex
:init
(add-hook 'LaTeX-mode-hook
(lambda ()
(reftex-mode 1)
(flyspell-mode 1)
(auto-fill-mode 1))))

Fichier attachéTaille
sample.pdf 10.28 Ko
arnoldfiarn
Hors ligne
A rejoint: 08/06/2012

Intenté configurar un tema de Kaolin y ahora no me reconoce auctex, qué problema, te paso mi contenido de .emacs, no entiendo dónde está mi error:

(package-initialize)

(add-to-list 'load-path "~/.emacs.d/site-lisp/auctex")
(load "auctex.el" nil t t)
(load "preview-latex.el" nil t t)

;; Realzado de la línea donde se encuentra al cursor
(global-hl-line-mode 1)
;; Parser automático
(setq TeX-auto-save t) ;
(setq TeX-parse-self t) ; habilita el análisis en carga
;; Establece documentos maestros
(setq-default TeX-master nil)

Algo más, otra vez los paquetes están como antes, no veo la multitud desde donde instalé `kaolin-themes`

;; (add-hook 'LaTeX-mode-hook 'visual-line-mode)

;; Reftex
(add-hook 'LaTeX-mode-hook 'turn-on-reftex) ; Activa reftex con AucTeX
(setq reftex-plug-into-AUCTeX t) ; Conectar AUCTex con RefTeX
(setq TeX-PDF-mode t) ; Activa el modo pdf

;; ;; Fold por defecto
(add-hook 'LaTeX-mode-hook (lambda ()(TeX-fold-mode 1)))

;; ;; LaTeX extra para tener doblado de secciones como Org
(add-hook 'LaTeX-mode-hook #'latex-extra-mode)

(require 'package)

(add-to-list 'package-archives
'("melpa" . "https://melpa.org/packages/")
'("marmalade" . "http://marmalade-repo.org/packages/"))

Algo más, dejó de aparecerme los paquetes nuevos, está como antes, apenas pude instalar `kaolin-themes`, no sé a qué se debe.

farliz
Hors ligne
A rejoint: 05/24/2015

Creo que debes ir configurando poco a poco los paquetes, así podrás averiguar cual es el que da el problema.

Con el siguiente codigo deberias tener instalado Auctext y el tema Kaolin

1. Configurar repositorios

(package-initialize)
(require 'package)
(add-to-list 'package-archives
'("melpa" . "https://melpa.org/packages/")
'("marmalade" . "http://marmalade−repo.org/packages/"))

;; (let ((default−directory "~/.emacs.d/elpa/"))
;; (normal−top−level−add−subdirs−to−load−path))

2. Instalar use-package

(unless (package-installed-p 'use-package)
(package-refresh-contents)
(package-install 'use−package))

3. Instalar Auctex

(use-package tex
:ensure auctex
:init
(add-hook 'LaTeX-mode-hook
(lambda ()
(reftex-mode 1)
(flyspell-mode 1)
(auto-fill-mode 1))))

3. Instalar kaolin-themes

(use-package kaolin-themes
:ensure t)

Screenshot_2020-06-10_16-43-00.png
arnoldfiarn
Hors ligne
A rejoint: 08/06/2012

AUCTeX ya lo configuré así:

-----------------------------------------------------------
;; Load Auctex to Emacs
(add-to-list 'load-path "~/.emacs.d/site-lisp/auctex")
(load "auctex.el" nil t t)
(load "preview-latex.el" nil t t)
------------------------------------------------------------

¿No entraría en conflicto con el código?

-----------------------------------------------------------
3. Instalar Auctex

(use-package tex
:ensure auctex
:init
(add-hook 'LaTeX-mode-hook
(lambda ()
(reftex-mode 1)
(flyspell-mode 1)
(auto-fill-mode 1))))
--------------------------------------------------------------

Se ve bastante diferente. Igual veo el caso de kaolin-themes, el código de configuración es muy diferente al que muestras.

arnoldfiarn
Hors ligne
A rejoint: 08/06/2012

Logré instalar kaolin-theme, pero veo que no resalta de manera diferente lo que hace AUCTeX, además no me deja ver el código comentado, lo que es un gran incoveniente.

farliz
Hors ligne
A rejoint: 05/24/2015

Hay varias maneras de configurar emacs, yo te presenté una alternativa por lo del error que te salía. Si te ha funcionado como lo tienes, dejalo así, la idea es que funcione como tu quieres. No es bueno tener dos segmentos de código para configurar lo mismo.

Lo de use-package como mencioné, era para hacer un poco mas reusable la configuración.

Hay un grupo muy activo sobre emacs en español en Telegram, lo dejo por si usas esa aplicación.

https://t.me/emacs_es

arnoldfiarn
Hors ligne
A rejoint: 08/06/2012

Lo interesante es que ya puedo instalar paquetes pero me sigue mostrando el mensaje sobre la llave pública.

arnoldfiarn
Hors ligne
A rejoint: 08/06/2012

Ya lo solucioné con la recomendación de @MiguelPinia

Hice lo siguiente:

1. Establece «package-check-signature» a nil, ej. «M-: (setq package-check-signature nil) ENTER»
2. Descarga «gnu-elpa-keyring-update» y ejecútalo, «M-x package-install ENTER gnu-elpa-keyring-update ENTER»