Je veux m'investir dans la documentation !!

11 réponses [Dernière contribution]
Mark
Hors ligne
A rejoint: 04/14/2012

Bonsoir tout le monde !

En lisant pas mal d'articles sur le web, je me suis décidé, je VEUX aider le logiciel libre.

Mes points fort sont la création d'images 2D et la documentation. Je souhaite donc faire de la documentation en Français. Mais une documentation qui soit très complète et très facile d'accès (*.pdf).

L’ennui c'est que je ne suis pas bon en Anglais donc...Vous me comprenez !! Lire des articles en Anglais et les retranscrire en Français c'est assez difficile de même que pour la communication par mail par exemple.

En fait, j'aimerais faire de la documentation essentiellement sur Trisquel, GIMP, Libre Office, Scribus et sur la philosophie du logiciel libre. Après quoi je pense attaquer Blender, Inkscape, Emacs AUCTeX, Ardour, VLC Media Player et quelques autres logiciels dont certains jeux libre.

Je ne sais pas si vous voyez ce que je cherche à faire, mais je cherche à réaliser une documentation sur les logiciels les plus utile et les plus performant du monde libre. Tout ça dans le but de montrer au gens que TOUT les outils dont ils ont besoins sont aussi dans notre monde libre et qu'il n'ont plus besoin d'utiliser les logiciels scandaleux des privateurs.

Je ne sais pas par où commencer, je dois d'abord connaître sur le bout des doigts les logiciels que je souhaite présenter. Je suis super motivé et je n'arrête plus de proposer des solutions alternative (comme LibreOffice pour remplacer Microsoft Office, etc...). J'ai même acheté un livre sur GIMP 2.8 de plus de 600 pages (très complet) à 45€ pour apprendre tout sur GIMP. L’ennui c'est que Trisquel utilise le 2.6. =(.

Voilà, je suis très enthousiaste !! J'espère obtenir vos conseils, votre aide et votre soutient.
Mark.

Magic Banana

I am a member!

Hors ligne
A rejoint: 07/24/2010

Je te recommanderais de contribuer aux documentations des projets respectifs plutôt que de tenter de travailler solo. C'est plus simple (tu ne pars pas de rien) et plus sympathique car collaboratif. Pour ce qui est du point central où trouver les documentations des divers logiciel, il s'appelle Wikipédia. ;-)

Il y a aussi ce site qui pourrait te plaire : http://fr.flossmanuals.net

Pour le format, j'ai tendance à penser que HTML est encore plus facile d'accès que PDF. Il y a mieux : les deux. Encore mieux si tu ajoutes EPUB (comme sur la plate-forme "Floss Manuals").

Veille à ce que tu écrives soit libre. Le logiciel libre a besoin d'une documentation libre. Il y en a plusieurs. Si tu as le choix (donc si tu pars de rien), la GNU FDL est probablement le meilleur choix.

Tu peux utiliser un PPA pour installer GIMP 2.8 :
$ sudo add-apt-repository ppa:otto-kesselgulasch/gimp
$ sudo apt-get update && sudo apt-get install gimp

Mark
Hors ligne
A rejoint: 04/14/2012

J'ai essayé d'installé GIMP 2.8 avec les lignes de commande que tu me montre, de même, j'ai suivit le tutoriel d'un de tes précédents message.

Mais ça ne marche pas, ma version reste toujours en 2.6 et le terminal me dit que ma version est la dernière disponible.

Faut-il désinstaller complètement GIMP 2.6 avant de tenter l'installation de GIMP 2.8 ?
Je ne sais pas si GIMP 2.8 va sortir avec Trisquel lors de sa prochaine sortie mais ça serait vachement bien. =)

Pour la documentation je compte bien la laisser libre pour tous ;) !

Magic Banana

I am a member!

Hors ligne
A rejoint: 07/24/2010

Il est étrange que le PPA ne fonctionne pas. J'ai bien peur que GIMP 2.8 ne soit pas non plus dans la prochaine Trisquel 6.0 LTS. En effet, les paquets sont, sauf exception rarissime, directement copiés des dépôts libres de la version correspondante d'Ubuntu (12.04 Precise Pangolin)... et GIMP y est en version 2.6.12 (rien dans les mises à jour ou les backports qui concerne GIMP).

Tu peux aussi compiler GIMP 2.8 depuis les sources. Il te faut alors installer les paquets nécessaires (compilateur & co.) et suivre les indications du fichier INSTALL (dans les sources)... en anglais. J'y ai jeté un coup d'œil et je te le recommande pas à moins que tu ais déjà pas mal d'expérience dans la construction de logiciel.

Magic Banana

I am a member!

Hors ligne
A rejoint: 07/24/2010

Au fait, tu devrais supprimer le fichier qui a du être créer lorsque tu as installé le PPA :
$ sudo rm /etc/apt/sources.list.d/otto-kesselgulasch-gimp-oneiric.list

Mark
Hors ligne
A rejoint: 04/14/2012

Oh ! Merci beaucoup.

J'ai entré la commande dans une Terminal, tapé mon mot de passe et la console n'a rien affiché ensuite. Je suppose que le fichier à bien été supprimé.

Merci.

Magic Banana

I am a member!

Hors ligne
A rejoint: 07/24/2010

Oui. C'est le comportement classique des commandes : on ne gueule que quand quelque chose ne se passe pas comme demandé.

isabellelefebre
Hors ligne
A rejoint: 10/08/2011

Je te recommanderais de contribuer aux documentations des projets respectifs plutôt que de tenter de travailler solo. C'est plus simple (tu ne pars pas de rien) et plus sympathique car collaboratif. Pour ce qui est du point central où trouver les documentations des divers logiciel, il s'appelle Wikipédia. ;-)
Il y a aussi ce site qui pourrait te plaire : http://fr.flossmanuals.net
Pour le format, j'ai tendance à penser que HTML est encore plus facile d'accès que PDF. Il y a mieux : les deux. Encore mieux si tu ajoutes EPUB (comme sur la plate-forme "Floss Manuals").
Veille à ce que tu écrives soit libre. Le logiciel libre a besoin d'une documentation libre. Il y en a plusieurs. Si tu as le choix (donc si tu pars de rien), la GNU FDL est probablement le meilleur choix.
Tu peux utiliser un PPA pour installer GIMP 2.8 :
$ sudo add-apt-repository ppa:otto-kesselgulasch/gimp
$ sudo apt-get update && sudo apt-get install gimp
__________
tashinalogue hebergement web

Mark
Hors ligne
A rejoint: 04/14/2012

Compiler moi-même risque d'être assez dur. Je n'ai aucune connaissances dans ce domaine.
Je trouve ça assez dommage que Trisquel dépende autant d'Ubuntu. Le retard (en terme de version) de GIMP et de quelques autres logiciels est assez dérangeant. surtout si l'on souhaite faire une documentation à jour.
Par exemple on a GIMP 2.6 au lieu de GIMP 2.8, Blender 2.5 au lieu du 2.63 (bientôt 2.64 en Juin), LibreOffice 3.4.4 au lieu du 3.5.5.

C'est à mon avis une des grandes faiblesses de Trisquel : Il dépend trop d'Ubuntu dans sa logitech et dans les mises à jour des logiciels. Après je ne râle pas mais je suis déçu de devoir attendre si longtemps avant d'utiliser GIMP 2.8 et d'autres logiciels à jour sur Trisquel.

D'ici là, le temps que GIMP 2.8 sorte sur Trisquel et que je puisse bien l'utiliser, la version 3.0 sera sortie... =( !
Tout ça pour dire que faire de la documentation sur une version obsolète n'est pas si génial que ça !!

oysterboy

I am a member!

I am a translator!

Hors ligne
A rejoint: 02/01/2011

Le fait que les logiciels ne soient pas tous à la toute dernière version en date est le prix à payer pour la stabilité globale du système. Et Ubuntu sort aux 6 mois, ce n'est quand même pas l'horreur ! D'autant plus qu'il y a toujours les ppa entre temps, qui servent justement à ça.

Magic Banana

I am a member!

Hors ligne
A rejoint: 07/24/2010

J'ajouterais que si tu préfères la nouveauté à la stabilité et à la facilité d'utilisation (il ne faut pas avoir peur d'éditer des fichiers de configuration), tu peux t'orienter vers Parabola GNU/Linux qui est, comme Trisquel, 100% libre. Il s'agit d'une distribution "rolling-release", basée sur Arch, c'est à dire qu'il n'y a pas de version de la distribution mais des paquets qui sont continuellement mis à jour.

Mark
Hors ligne
A rejoint: 04/14/2012

Oh! Je ne savait pas que Trisquel utilise des versions en retard pour garder la stabilité de son système. Ça se justifie. =)

Bah Trisquel me plais beaucoup ! Donc je vais prendre mon courage à deux mains et attendre !! Et puis ça ne peux pas trop me faire de mal. GIMP 2.8 aura de nombreux bug qui auront été corrigés lorsqu'il arrivera sur Trisquel !!

Et je préfère la stabilité et la rapidité de mon système donc... =)