LiveUSB creation issues

3 réponses [Dernière contribution]
Hors ligne
A rejoint: 08/18/2020

From my desktop running Trisquel 9 (Linux libre kernel 5.10), I created a liveUSB of Trisquel9:
sudo dd if=trisquel_9.0_amd64.iso of=/dev/sdb1 bs=8M ; sync

After failing several times to boot on it a number of old unused laptops (message saying isolinux.bin is missing, probably due to the computer booting on USB but still using the hard drive as primary source) I finally managed to install it on one laptop.

Before my first success to boot with that liveUSB, I thought perhaps the liveUSB was not good so I re-did it several times. What surprised me is that, although I did not launch any task in parallel, it sometimes took 10s but at other times it took 15 minutes, especially the sync operation. Sure, I have Abrowser and Evolution running but I am not doing anything with them. As I was wondering wheher I should interrupt sync, I found the following:
watch -d grep -e Dirty: -e Writeback: /proc/meminfo
It showed me a really slow progress of the sync. But on some later attempts the sync was imediate.

On another laptop, there was a message that this executable is not supported, so I tried to create another live USB with the i686 version, using another USB key. I noticed some different behaviours while doing it, I had a popup message at some point asking for password and noticed when using df that it was mounted as /dev/loop0 instead of /dev/sdb1 previously. But the dd command on /dev>/sdb1 and sync was apparently successful and when mounted on the desktop, Caja was saying it is Trisquel 9 i686.

Then, when I tried to boot a laptop with this liveUSB, to my great surprise, it proposed me to install Debian, which is what was previously on this USB key. I thought maybe I did something wrong, so I tried again and the result was the same (showing something called Trisquel 9 i686 in Caja but proposing to install Debian when booting on it). In the Debian manual, it is said that one can just use cp with the /dev/sdX as destination to copy the iso file and then sync, so I also tried that, for the same result.

As I had no clue what to try else, I decided I should use another computer, but the only other one available is running a proprietary system. I used the command line option for the system on that computer, it took about 15 minutes, but then, when booting on the USB key, it was really Trisquel.

Still, I'd like to be able to reliably make my liveUSBs from Trisquel, so that if something is not working when booting on them, I am at least sure the liveUB is correct and I am facing a different problem. Also, I'd like to try some entirely free software images for some SBCs, I am expecting there can be issues but I'd like to at least be sure that I really wrote to the micro SD card the image to boot.

Any guess on what I did wrong or advice is welcome.

Hors ligne
A rejoint: 08/18/2020

Ok, I was stupid. At some point, I probably wrote to /dev/sdb1 that did not exist, so this has created a regular file there instead of writing to the USB key. I saw that when I started searching for the /dev/sdX for my USB sd card reader.

So no need to worry about my questions now, perhaps the very different sync times are related to that mistake.

En ligne
A rejoint: 05/01/2018

Typically we write the image to the entire disk (/dev/sdx), not a partition on it (/dev/sdxn).

Magic Banana

I am a member!

Hors ligne
A rejoint: 07/24/2010