Mise à niveau de Trisquel mini vers Belenos (7.0)

4 réponses [Dernière contribution]
Julius22
Hors ligne
A rejoint: 07/02/2010

Bonjour,
Je veux mettre mon installation de Trisquel mini à niveau vers la version 7.0 depuis la version 6.0.
J'ai commencé à la faire avec l'outil de mise à jour et la commande do-release-upgrade. Mais le problème est que le paquet trisquel-recommended et toutes ses dépendances dont je ne veux pas (notamment abrowser, Cheese, des jeux et Evolution) sont marquées comme devant être installés. J'ai donc arrêté la mise à niveau.
Est-ce que quelqu'un sait pourquoi le paquet trisquel-recommended est marqué comme devant être installé alors qu'il ne l'est pas sous Trisquel mini 6.0 ? De plus, depuis une session live de Trisquel mini, j'ai regardé les paquets « installés » (dans la session live). Le paquet trisquel-recommended ne l'est pas. De plus, il n'est en dépendance d'aucun autre paquet. Je ne comprends donc pas pourquoi la mise à niveau de mon système veut l'installer.
Si quelqu'un à des réponses à mes interrogations, je suis preneur. Et n'hésitez pas à me demander des précisions si besoin est. ;)

Julius22
Hors ligne
A rejoint: 07/02/2010

J'ai continué à chercher une solution. Ce faisant, je suis tombé sur ce sujet du forum de kubuntu-fr.org. J'ai presque appliqué la méthode 5. J'ai modifié le fichier /etc/apt/sources.list, mis la liste des paquets à jour puis, au lieu de faire la mise à niveau, j'ai simplement utilisé la commande ci-dessous pour simuler la mise à niveau.
apt-get dist-upgrade -s
Cette fois, la liste des paquets à installer n'inclut pas les paquets qui me gênent.
Cependant, avant de faire la mise à niveau de cette manière, je préfère attendre de voir si quelqu'un a une méthode plus sûre. Et, si quelqu'un a utilisé la méthode que je viens de présenter, a-t-elle bien fonctionné avec Trisquel Mini ? Bref, la méthode que je souhaite utiliser est-elle fiable ?

Philomuse
Hors ligne
A rejoint: 02/01/2014

Bonjour Julius,

Comment t'en es-tu sorti ?
Si j'avais lu ton message avant... Je serai restée à la V6 aussi !
J'ai viré manuellement des paquets non désirés et ça prend pas mal de temps.
J'ai aussi l'impression d'être "surveillée" mais ce n'est pas si important :)

Julius22
Hors ligne
A rejoint: 07/02/2010

Bonjour,
Comme tu peux t'en douter à la lecture de mon dernier message, je n'ai pas encore effectué la mise à jour. J'attends une réponse à ma question d'ici à demain. Si je n'en ai pas, je poserai la même question sur la partie en anglais du forum.

Julius22
Hors ligne
A rejoint: 07/02/2010

Comme je l'avais indiqué, j'ai créé un sujet sur la partie en anglais du forum : https://trisquel.info/fr/forum/dependencies-problem-trisquel-mini-60-70-upgrade.