No puedo añadir impresora en Trisquel 7

6 réponses [Dernière contribution]
Jaume
Hors ligne
A rejoint: 11/08/2014

Bueno, ahí va:

Tengo una impresora Canon MP140 con escáner. La había usado anteriormente en Trisquel 6, e incluso la usé a través de la red conectada a otro ordenador.

Ahora no me deja instalarla.

Voy a "Preferencias del Sistema > Impresoras", y con la impresora encendida y conectada al puerto USB le doy a "Añadir impresora".

El programa detecta la impresora y la muestra como única opción en la lista para instalar, pero al darle a "Añadir" me sale el aviso "No se puede añadir una impresora nueva".

Adjunto la salida de dmesg (sólo el final) a ver si a alguien se le ocurre qué es lo que pasa.

He instalado el paquete "printcofig", así, por probar, pero no cambia nada.

Venga, gracias por adelantado.

J.

$ dmesg | tail
[ 8570.954679] usb 3-3: New USB device found, idVendor=04a9, idProduct=172b
[ 8570.954689] usb 3-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 8570.954694] usb 3-3: Product: MP140 series
[ 8570.954698] usb 3-3: Manufacturer: Canon
[ 8570.954702] usb 3-3: SerialNumber: 051092
[ 8570.957306] usblp 3-3:1.1: usblp0: USB Bidirectional printer dev 5 if 1 alt 0 proto 2 vid 0x04A9 pid 0x172B
[ 8607.678453] usblp0: removed
[ 8607.681025] usblp 3-3:1.1: usblp0: USB Bidirectional printer dev 5 if 1 alt 0 proto 2 vid 0x04A9 pid 0x172B
[ 8608.632938] type=1400 audit(1424375685.667:65): apparmor="DENIED" operation="signal" profile="/usr/sbin/cupsd" pid=17235 comm="cupsd" requested_mask="send" denied_mask="send" signal=term peer="unconfined"
[ 8608.632943] type=1400 audit(1424375685.667:66): apparmor="DENIED" operation="signal" profile="/usr/sbin/cupsd" pid=17235 comm="cupsd" requested_mask="send" denied_mask="send" signal=term peer="unconfined"

dcapeletti
Hors ligne
A rejoint: 04/03/2014

Hola,
en este hilo se trata acerca del mismo problema: http://trisquel.info/es/forum/problemas-al-instalar-driver-de-impresora-epson-cx3900
Intenta seguir los pasos y luego los cuentas.

Sds

L30N4RD0
Hors ligne
A rejoint: 12/29/2009

Prueba por medio de cups.
En el navegador pone:
Localhost:631.

Selecciona "administración" (menú superior), luego añadir impresora.

El user y passwd q te pide para eso son las de tu usuario de sesión .

Saludos.
El 19/02/2015 17:14, <name at domain> escribió:

> Bueno, ahí va:
>
> Tengo una impresora Canon MP140 con escáner. La había usado anteriormente
> en Trisquel 6, e incluso la usé a través de la red conectada a otro
> ordenador.
>
> Ahora no me deja instalarla.
>
> Voy a "Preferencias del Sistema > Impresoras", y con la impresora
> encendida y conectada al puerto USB le doy a "Añadir impresora".
>
> El programa detecta la impresora y la muestra como única opción en la
> lista para instalar, pero al darle a "Añadir" me sale el aviso "No se puede
> añadir una impresora nueva".
>
> Adjunto la salida de dmesg (sólo el final) a ver si a alguien se le ocurre
> qué es lo que pasa.
>
> He instalado el paquete "printcofig", así, por probar, pero no cambia nada.
>
> Venga, gracias por adelantado.
>
> J.
>
> $ dmesg | tail
> [ 8570.954679] usb 3-3: New USB device found, idVendor=04a9, idProduct=172b
> [ 8570.954689] usb 3-3: New USB device strings: Mfr=1, Product=2,
> SerialNumber=3
> [ 8570.954694] usb 3-3: Product: MP140 series
> [ 8570.954698] usb 3-3: Manufacturer: Canon
> [ 8570.954702] usb 3-3: SerialNumber: 051092
> [ 8570.957306] usblp 3-3:1.1: usblp0: USB Bidirectional printer dev 5 if 1
> alt 0 proto 2 vid 0x04A9 pid 0x172B
> [ 8607.678453] usblp0: removed
> [ 8607.681025] usblp 3-3:1.1: usblp0: USB Bidirectional printer dev 5 if 1
> alt 0 proto 2 vid 0x04A9 pid 0x172B
> [ 8608.632938] type=1400 audit(1424375685.667:65): apparmor="DENIED"
> operation="signal" profile="/usr/sbin/cupsd" pid=17235 comm="cupsd"
> requested_mask="send" denied_mask="send" signal=term peer="unconfined"
> [ 8608.632943] type=1400 audit(1424375685.667:66): apparmor="DENIED"
> operation="signal" profile="/usr/sbin/cupsd" pid=17235 comm="cupsd"
> requested_mask="send" denied_mask="send" signal=term peer="unconfined"
>
>

Jaume
Hors ligne
A rejoint: 11/08/2014

Casi resuelto.

Gracias por vuestra ayuda. Con el sistema CUPS he podido instalarla. El problema es que no termina de imprimir la página. Se queda colgada en la mitad.

Sabeis si esto es debido a algun error conocido? Creo que vi (no sé ni cuando ni dónde) que a alguien más le pasaba una cosa similar, pero no he podido encontrar el hilo de nuevo.

Saludos!

J

dcapeletti
Hors ligne
A rejoint: 04/03/2014

Hola,
tengo dudas acerca de esta impresora. Hay una impresora que es la Canon Inkjet MP160 en: https://h-node.org/printers/view/es/839/MP160/1/1/undef/undef/undef/undef/undef/Canon que no tiene ninguna compatibilidad con Software Libre. Por favor podrías brindar el detalle de la salida:
sudo lsusb -v

Por otra parte, te envía un error cuando ejecutas la impresión? Podrías enviar una nueva salida del comando:
dmesg | tail

Si la impresora funciona con software libre, por favor cuando dispongas de un tiempo, puedes colaborar agregando la misma a https://h-node.org/home/index/es así tenemos todos los usuarios de software libre una base de datos con el hardware que funciona correctamente ;)

Sds

Jaume
Hors ligne
A rejoint: 11/08/2014

Hola dcapeletti,

El modelo no es el mismo. Se trata de la Canon Pixma MP 140. No la vi nunca en h-node, pero funcionó alguna vez. No puedo asegurar que fuera con software 100% libre, puesto que no usaba Trisquel por entonces.

He hecho mas pruebas. La impresora funciona bien hasta media página, mas o menos. Luego se para y va soltando una línea cada minuto, o más. Después de media hora no he tenido más paciencia y he abortado la impresión.

En la página de prueba sale del driver "STP00188.PDD v5.2.10-pre2".

La salida de lsusb -v es muy larga. La pongo como archivo adjunto.

Aqui va la salida de dmesg:
--------------------------------------------------------------
$ dmesg | tail
[ 640.968294] usb 3-3: new high-speed USB device number 6 using xhci_hcd
[ 640.981384] usb 3-3: New USB device found, idVendor=04a9, idProduct=172b
[ 640.981393] usb 3-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 640.981398] usb 3-3: Product: MP140 series
[ 640.981403] usb 3-3: Manufacturer: Canon
[ 640.981406] usb 3-3: SerialNumber: 051092
[ 640.983810] usblp 3-3:1.1: usblp0: USB Bidirectional printer dev 6 if 1 alt 0 proto 2 vid 0x04A9 pid 0x172B
[ 1594.944496] type=1400 audit(1424889140.964:48): apparmor="DENIED" operation="signal" profile="/usr/sbin/cupsd" pid=2252 comm="cupsd" requested_mask="send" denied_mask="send" signal=term peer="unconfined"
[ 1594.944502] type=1400 audit(1424889140.964:49): apparmor="DENIED" operation="signal" profile="/usr/sbin/cupsd" pid=2252 comm="cupsd" requested_mask="send" denied_mask="send" signal=term peer="unconfined"
[ 1598.884741] usblp0: removed
----------------------------------------------------------------

En el momento de ejecutar la orden dmesg, el trabajo estava enviado y la impresora se había detenido. Quizas esos "DENIED" y la última línea "usblp0: removed" tengan algo que ver?

Gracias por la ayuda.

J.

Fichier attachéTaille
lsusb.txt 45.45 Ko
dcapeletti
Hors ligne
A rejoint: 04/03/2014

Hola,
es difícil ayudarte cuando no dispongo de la impresora. He visto que otros usuarios han tenido problemas similares pero con otras impresoras.
Por favor intenta lo siguiente:
1- Elimina tu impresora desde CUPS.
2- Agregala nuevamente pero esta ves usando el driver Canon PIXMA MP150, como te adjunto en la imagen. Luego intenta imprimir.
3- Si no te funciona, prueba con el driver MP145 o MP160.

Espero que tu respuesta.

Sds

Driver cups.png