Problème d'accent circonflexe et tréma

7 réponses [Dernière contribution]
Avron
Hors ligne
A rejoint: 08/18/2020

Bonjour,

J'utilise deux ordinateurs avec Trisquel 9 et Mate, un Lenovo X200 et un desktop.

Sur le X200, j'ai un problème que je n'ai pas sur le desktop: je ne peux faire aucun caractère avec accent circonflexe ou tréma, sauf dans Gajim. Ca ne marche ni dans Abrowser, ni dans Evolution, ni dans LibreOffice, ni dans un terminal, ni dans Caja.

J'ai mis le réglage clavier à Français, j'ai essayé des variantes, rien n'y fait, c'est toujours pareil. J'ai désélectionné l'option d'utiliser des claviers différents dans des fenêtres différentes. Sur le desktop, j'ai exactement les mêmes réglages, et j'utilise le même clavier avec un KVM (j'ai du utiliser le correcteur pour le mot "même" car impossible de le taper), je peux faire des accents circonflexes et des trémas absolument partout sans problème.

Je ne sais pas comment faire.

damidu
Hors ligne
A rejoint: 03/30/2021

Bonjour,

As-tu essayer

sudo dpkg-reconfigure keyboard-configuration
sudo service keyboard-setup.sh restart

https://wiki.debian.org/Keyboard

Sur le x200. C'est peut être une mauvaise variante ou un mauvais clavier qui a été selectioner (pour le clavier physique du x200). Je pense, mais je peux me tromper. Je crois que si tu branches un clavier usb ou un kvm ou autre, ca garde les paramètres du clavier physique.

Avron
Hors ligne
A rejoint: 08/18/2020

La première commande a appelé update-initramfs, donc je suppose qu'il y aura un effet au prochain démarrage, mais je ne sais pas si c'est juste pour le démarrage ou pour un effet plus permanent.

J'ai fait la deuxième aussi.

En tout cas, sans redémarrage, pas d'effet. Je le ferai un peu plus tard (je n'ai pas chronométré mais c'est vraiment long).

Avron
Hors ligne
A rejoint: 08/18/2020

Après redémarrage, pas mieux. J'ai essayé plusieurs variantes de claviers français dans le menu de Mate:
- impossible de faire un e accent circonflexe sauf avec Gajim (aucune différence suivant le choix de variante)
- dans emacs, appuyer sur la touche accent circonflexe fait un son et écrit "<dead-circumflex> is undefined".

Pour emacs, j'ai trouvé la suggestion de mettre "(require 'iso-transl)" dans le .emacs, effectivement, ça marche mais seulement pour emacs évidemment.

J'ai trouvé https://debian-facile.org/viewtopic.php?id=21109 qui parle de ibus mais je n'y comprends pas grand chose et je n'ai pas très envie de supprimer ibus comme suggéré.

J'ai vu dans Mate un menu "Préférences de ibus", il y a "Méthode d'entrée" mais beaucoup moins de choix que dans Mate et on peut supprimer toutes les méthodes d'entrée. Par ailleurs, dans l'onglet "Avancé", "Utiliser la disposition clavier système" est coché.

Pas de solution pour le moment, à part utiliser emacs systématiquement et faire des copier coller.

Magic Banana

I am a member!

I am a translator!

Hors ligne
A rejoint: 07/24/2010

As-tu jeté un œil aux « options supplémentaires d’agencement » (un bouton dans GNOME Tweak Tools s’appelle ainsi sur mon système, mais il y a certainement quelque chose d’équivalent dans l’utilitaire MATE d’agencement du clavier) ?

Avron
Hors ligne
A rejoint: 08/18/2020

Il y a un bouton "options" mais tout est aux valeurs par défaut. J'ai aussi regardé ibus, même clavier sélectionné, cela ne change rien, y compris après redémarrage.

J'ai depuis samedi dernier un "nouveau" x201i avec Libreboot acheté sur le bon coin sur lequel j'ai tout de suite installé Trisquel en utilisant l'installateur en mode texte et en suivant les instructions supposées pas à jour mais qui fonctionnent parfaitement, je n'ai pas du tout ce problème d'accent circonflexe et tréma.

Je n'est pas installé Guix dessus, mais je vais sans doute le rajouter (surtout à cause de Gajim), je regarderai après et si ça marche toujours, je comparerai les variables d’environnement, au cas où je remarque des différences.

Sasaki
Hors ligne
A rejoint: 08/11/2014

Salut j'ai le même problème depuis que j'ai installé ibus pour le japonais. Au vu du fil de discussion cité plus haut, il semble clair que le problème vient de là.

J'ai trouvé ceci ( voir commentaire #22) :

https://forum.ubuntu-fr.org/viewtopic.php?id=1580491

Problème des accents circonflexes
L'installation d'ibus vous empêchera d'utiliser "^" puis "e" pour avoir "ê". Pour remédier à ce problème, vous pouvez activer la disposition oss du clavier:
setxkbmap -layout fr -variant oss
Les touches "AltGr" et "zruip" vous donneront "âêûîô"
Si seulement certains logiciels refusent les accents et trémas tapés traditionnellement (par exemple opera ou amsn), une autre solution consiste à modifier le .bashrc. Dans votre répertoire personnel, tapez :
sudo nano .bashrc
puis rajoutez à la fin cette ligne :
export XMODIFIERS=''
Sauvegardez, puis il ne vous reste plus qu'à redémarrer les applications concernées par ce problème.

Avron
Hors ligne
A rejoint: 08/18/2020

Sur le portable, j'ai le problème (ibus est installé, à cause de trisquel-desktop-common-recommended) et j'ai:

$ env |grep ibus
CLUTTER_IM_MODULE=ibus
QT4_IM_MODULE=ibus
QT_IM_MODULE=ibus
XMODIFIERS=@im=ibus
GTK_IM_MODULE=ibus

Sur le fixe, je n'ai pas le problème (ibus est installé à cause de ibus-pinyin installé manuellement) et j'ai:

$ env |grep ibus
QT_IM_MODULE=ibus
XMODIFIERS=@im=ibus
$ echo $CLUTTER_IM_MODULE
xim
$ echo $QT4_IM_MODULE
xim
$ echo $CLUTTER_IM_MODULE
xim
$ echo $GTK_IM_MODULE
xim

J'ai essayé export XMODIFIERS='' et export XMODIFIERS='xim' sur le portable, ça ne résout rien.

Au passage, j'ai trouvé

PS4='+$BASH_SOURCE> ' BASH_XTRACEFD=7 bash -xl 7>&2

pour voir d'où vient une variable d'environnment.

Ca ne résout rien mais je vais chercher d'où viennent ces variables, au cas où ça me donne des pistes.