Problème de langue

20 réponses [Dernière contribution]
sosolal
Hors ligne
A rejoint: 02/27/2014

Tout est en anglais alors que dans "System Settings > Language Support" j'ai tout mis en français.
Pouvez-vous m'aider???

nmrk.n
Hors ligne
A rejoint: 11/01/2013

"System Setting" de KDE ?

Tout quoi, l'environnement ou les applications ou les deux ?

Tu l'as lancé comment, à partir du menu ou d'une console, entant qu'utilisateur ordinaire ou avec les droits d'administrateur ?

sosolal
Hors ligne
A rejoint: 02/27/2014

=> "System Settings" du bureau de Trisquel (je ne sais absolument pas lequel)

=> Les onglets "Language" et "Regional formats"

=> Par le menu principal

Magic Banana

I am a member!

Hors ligne
A rejoint: 07/24/2010

As-tu cliqué sur "Installer/Supprimer des langues..." et coché le français ?

sosolal
Hors ligne
A rejoint: 02/27/2014

Oui

eean
Hors ligne
A rejoint: 07/06/2011

Bonjour sosolal,

Si tu as bien installé le support de langue pour le français mais que tu es toujours en anglais alors normalement, dans l'environnement de bureau par défaut de Trisquel qui est GNOME Classic, tu dois :

- Cliquer sur le menu Trisquel puis aller dans System settings.

- Dans la fenêtre System settings, descendre dans la section System puis cliquer sur l'icône Language Support.

- Parcourir la liste des langues avec l'ascenseur et cliquer-glisser sur français pour le remonter tout en haut de la liste (au dessus de English).

- Cliquer sur le bouton Apply System-Wide puis entrer ton mot de passe et valider.

- Cliquer sur Close pour fermer la fenêtre Language Support.

- Fermer la fenêtre System Settings puis te déconnecter de la session et te reconnecter.

Chez moi cela fonctionne très bien. Je peux basculer ainsi du français à l'anglais et inversement.

Quelle est la version de Trisquel que tu utilises ?

Pour le savoir, tu peux ouvrir un terminal avec le raccourci clavier Ctrl+Alt+T et entrer la commande suivante :

cat /etc/lsb-release

sosolal
Hors ligne
A rejoint: 02/27/2014

c'est ce que j'ai fait
je suis sus toutatis 6.0.1

eean
Hors ligne
A rejoint: 07/06/2011

Est-ce que le paquet locales est bien installé ?

Même si c'est le cas, essaie quand même de le réinstaller via le gestionnaire de paquets Synaptic ou bien avec la commande suivante :

sudo apt-get --reinstall locales

Vérifie également que les paquets language-pack-fr, language-pack-gnome-fr et language-pack-gnome-fr-base sont bien installés. Éventuellement, essaie de les réinstaller aussi.

Si cela ne donne rien, essaie de voir si la commande suivante te renvoie quelque chose :

sudo dpkg -C

Tu peux aussi essayer cette commande qui tente de réparer d'éventuels problèmes de dépendances qui existeraient sur ton système :

sudo apt-get -f install

sosolal
Hors ligne
A rejoint: 02/27/2014

la réinstallation ne fonctionne pas, "dpkg -C" ne renvoie rien et "apt-get -f install" ne fonctinne pas non plus

eean
Hors ligne
A rejoint: 07/06/2011

Désolé, je me suis trompé dans la commande de réinstallation du paquet locales. C'est :

sudo apt-get install --reinstall locales

À essayer aussi pour les autres paquets (language-pack…) que j'ai indiqué.

Sinon, peux-tu s'il te plaît installer le programme aptitude puis coller ici les résultats des commandes suivantes :

sudo aptitude search locale? | grep ^i

sudo aptitude search language? | grep ^i

sosolal
Hors ligne
A rejoint: 02/27/2014

ne fonctionne toujours pas, sinon les deux commandes "aptitude search" retournet ça :

i abrowser-locale-en - English language pack for Abrowser
i abrowser-locale-es - Spanish; Castilian language pack for Abrow
i A abrowser-locale-fr - French language pack for Abrowser
i A libdatetime-locale-perl - Perl extension providing localization supp
i A libencode-locale-perl - utility to determine the locale encoding
i liblocale-gettext-perl - module using libc functions for internatio
i locales - common files for locale support
i thunderbird-locale-fr - French language pack for Thunderbird
i language-pack-fr - translation updates for language French
i A language-pack-fr-base - translations for language French
i language-pack-gnome-fr - GNOME translation updates for language Fre
i A language-pack-gnome-fr-base - GNOME translations for language French
i language-selector - Language selector for Ubuntu (transitional
i language-selector-common - Language selector for Ubuntu
i language-selector-gnome - Language selector for Ubuntu

eean
Hors ligne
A rejoint: 07/06/2011

Qu'est-ce qui ne fonctionne toujours pas ? La réinstallation de paquets ? Normalement ça devrait. As-tu un message d'erreur ?

Bon, de toute façon, je vois que tu as tout ce qu'il faut d'installé au niveau des paquets de prise en charge de langues.

Tu peux quand même peut-être tenter une reconfiguration des paquets suivants, comme ceci :

sudo dpkg-reconfigure locales language-selector-common language-selector-gnome language-pack-fr language-pack-fr-base language-pack-gnome-fr language-pack-gnome-fr-base

Ensuite, essaie à nouveau de changer la langue par le menu System.

Si ça ne fonctionne toujours pas et que tu n'as aucun message d'erreur, c'est probablement un bug.

sosolal
Hors ligne
A rejoint: 02/27/2014

Toujours en anglais.
ça doit être un bug

eean
Hors ligne
A rejoint: 07/06/2011

J'en ai bien l'impression.

Je te propose d'essayer de lancer le sélecteur de langue de GNOME depuis un terminal en y entrant simplement ceci :

gnome-language-selector

Ensuite, tu essaies à nouveau de changer la langue. Ça ne va bien sûr pas marcher, mais peut-être qu'on arrivera ainsi à obtenir dans le terminal des messages d'erreur qui nous mettront sur la voie.

Si tu obtiens de tels messages, colle-les ici.

sosolal
Hors ligne
A rejoint: 02/27/2014

Je n'obtiens AUCUN message

eean
Hors ligne
A rejoint: 07/06/2011

J'ai trouvé une possible solution sur askubuntu à cette adresse :

http://askubuntu.com/questions/167965/gnome-language-selector-refuses-to-set-language

Apparemment, il suffirait peut-être de recréer le fichier .profile de ton répertoire utilisateur via la commande suivante :

cp /etc/skel/.profile ~/

Ensuite, il faut à nouveau tenter de changer la langue via System > Language Support (autrement dit via gnome-language-selector).

À essayer. Sinon, je ne vois pas.

sosolal
Hors ligne
A rejoint: 02/27/2014

ne marche toujours pas

eean
Hors ligne
A rejoint: 07/06/2011

Je pense qu'il faut creuser du côté d'un possible bug du gnome-language-selector mais je n'ai plus trop d'idée.

Magic Banana

I am a member!

Hors ligne
A rejoint: 07/24/2010

Laissons tomber l'utilitaire GNOME. Montre-nous ce que renvoie chacune de ces deux commandes :
$ cat ~/.pam_environment
$ cat /etc/default/locale

sosolal
Hors ligne
A rejoint: 02/27/2014

LANGUAGE=en
LANG=en_US.UTF-8
LC_NUMERIC=fr_FR.UTF-8
LC_TIME=fr_FR.UTF-8
LC_MONETARY=fr_FR.UTF-8
LC_PAPER=fr_FR.UTF-8
LC_NAME=fr_FR.UTF-8
LC_ADDRESS=fr_FR.UTF-8
LC_TELEPHONE=fr_FR.UTF-8
LC_MEASUREMENT=fr_FR.UTF-8
LC_IDENTIFICATION=fr_FR.UTF-8

LANG=""
LANGUAGE="en"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"

Magic Banana

I am a member!

Hors ligne
A rejoint: 07/24/2010

Et bien il te faut modifier ces fichiers afin que :

  • LANG=fr_FR.UTF-8
  • LANGUAGE=fr_FR:en

~/.pam_environment est pour toi seulement (pas besoin de droit d'administration pour le modifier) alors que /etc/default/locale est pour le système entier. Ainsi, si tu veux utiliser l'éditeur de texte GEdit en le lançant depuis le terminal :
$ gedit ~/.pam_environment
$ gksu gedit /etc/default/locale

Je doute que les guillemets soient nécessaires dans /etc/default/locale (ce sont des définitions de variables Shell) mais laisse les donc (y compris pour les variables que tu redéfinies).

Je pense qu'il te suffit ensuite de te déconnecter de la session graphique et de t'y reconnecter.