Problema con el GRUB después de instalar Mint 17.1 y Trisquel 7

3 réponses [Dernière contribution]
Kariete
Hors ligne
A rejoint: 02/04/2014

Hola Comunidad,

Me ha surgido un problema después de la instalación de las dos distros, a ver si alguien sabe como solucionarlo.

Instalé Linux Mint 17.1 primero con la opción de formatear el disco entero y eliminar todo lo que había instalado, después he instalado Trisquel 7.

Al encender el PC y aparecer el GRUB me salen las dos opciones, iniciar Trisquel o Mint.

Si eligo Trisquel todo va bien, carga el sistema e inicia con normalidad.

Pero si eligo Mint, sin cargar el sistema ni nada, me aparece directamente que introduzca el NOMBRE DE USUARIO y la CONTRASEÑA como si estuviera en línea de comandos. Los introduzco y me vuelve al GRUB otra vez, y así continuamente.
Por lo tanto no puedo entrar en Mint. Adjuto un pantallazo.

¿Sabéis porqué ocurre esto y cómo lo puedo solucionar?

Gracias de antemano y saludos.

Fichier attachéTaille
usercon.png11.28 Ko
neovsmith
Hors ligne
A rejoint: 08/15/2008

Todo parece indicar que estas iniciando el equipo con el grub que instala Trisquel 7 y éste viene con contraseña para las opciones que no sean la configurada por defecto para el arranque. Si no recuerdo mal, ya hay un hilo con ese tema y la solución al problema. Yo no domino la configuración del grub como para darte instrucciones precisas para anular la contraseña pero creo que puedes ver la que está configurada por defecto si abres el archivo "/boot/grub/grub.cfg".
Espero haberte sido de ayuda; un saludo.

gaitapi
Hors ligne
A rejoint: 08/12/2012
Kariete
Hors ligne
A rejoint: 02/04/2014

Hola neovsmith y gaitapi,

Seguí vuestras indicaciones y entre en el archivo "/boot/grub/grub.cfg" y comenté las líneas donde venía el usuario y contraseña por defecto. Ya esta solucionado.

Muchas gracias por vuestras respuestas.
¡Saludos!