Screen resolution

22 réponses [Dernière contribution]
meydlo
Hors ligne
A rejoint: 04/18/2015

Hi,

I do have incorrect screen resolution (1024x768) while the correct one I do have even on the gNewSense by default.

lspci |grep VGA
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Robson CE [Radeon HD 6370M/7370M]

meydlo@m:~$ fgrep '(EE)' /var/log/Xorg.0.log
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 6.793] (EE) Failed to load module "fglrx" (module does not exist, 0)
[ 6.802] (EE) Failed to load module "fglrx" (module does not exist, 0)
[ 6.810] (EE) open /dev/dri/card0: No such file or directory
[ 6.810] (EE) open /dev/dri/card0: No such file or directory
[ 6.810] (EE) open /dev/dri/card0: No such file or directory
[ 6.810] (EE) open /dev/dri/card0: No such file or directory
[ 6.811] (EE) open /dev/fb0: No such file or directory
[ 6.811] (EE) open /dev/fb0: No such file or directory
[ 6.811] (EE) open /dev/fb0: No such file or directory
[ 6.811] (EE) open /dev/fb0: No such file or directory
[ 6.811] (EE) Screen 0 deleted because of no matching config section.
[ 6.811] (EE) Screen 0 deleted because of no matching config section.
[ 6.811] (EE) Screen 0 deleted because of no matching config section.
[ 6.811] (EE) Screen 0 deleted because of no matching config section.
[ 6.811] (EE) Screen 0 deleted because of no matching config section.
[ 7.047] (EE) AIGLX: reverting to software rendering

meydlo@m:~$ cvt 1366 768
# 1368x768 59.88 Hz (CVT) hsync: 47.79 kHz; pclk: 85.25 MHz
Modeline "1368x768_60.00" 85.25 1368 1440 1576 1784 768 771 781 798 -hsync +vsync

meydlo@m:~$ xrandr --newmode "1368x768_60.00" 85.25 1368 1440 1576 1784 768 771 781 798 -hsync +vsync
xrandr: Failed to get size of gamma for output default
X Error of failed request: BadName (named color or font does not exist)
Major opcode of failed request: 140 (RANDR)
Minor opcode of failed request: 16 (RRCreateMode)
Serial number of failed request: 19
Current serial number in output stream: 19

root@m:/home/meydlo# xrandr --newmode "1368x768_60.00" 85.25 1368 1440 1576 1784 768 771 781 798 -hsync +vsync
xrandr: Failed to get size of gamma for output default

While I manually setted up this which is still not working:
root@m:/home/meydlo# cat /etc/X11/xorg.conf
Section "Screen"
Identifier "Default Screen"
Subsection "Display"
Modes "1366x768"
EndSubSection
EndSection

Thank you very much for help. I hope the provided info is enough.

Best regards

meydlo
Hors ligne
A rejoint: 04/18/2015

I forgot to mention that I'm running "Trisquel 7.0 LTS Belenos" and:
root@m:/home/meydlo# uname -a
Linux m 3.19.3-gnu #1 SMP Thu Apr 2 02:34:52 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Magic Banana

I am a member!

Hors ligne
A rejoint: 07/24/2010
meydlo
Hors ligne
A rejoint: 04/18/2015

thank you very much "Magic banana"

I commented out all keywords radeon which I found under directory /etc/modprobe.d/.
found was: "blacklist radeonfb"
in /etc/modprobe.d/fbdev-blacklist.conf
/etc/modprobe.d/disable-radeon.conf
/etc/modprobe.d/blacklist-framebuffer.conf

I tryied to apply: update-initramfs -u
with result:root@m:/home/meydlo# update-initramfs -u
update-initramfs: Generating /boot/initrd.img-3.19.3-gnu
W: mdadm: /etc/mdadm/mdadm.conf defines no arrays.

then I rebooted but it didn't worked.
unless I did it wrong

lembas
Hors ligne
A rejoint: 05/13/2010

The kernel folks changed the radeon driver...

Did you remember to use the xrandr commands --addmode and --output?

meydlo
Hors ligne
A rejoint: 04/18/2015

thanks,

the
outputs look like this:


meydlo@m:~$ xrandr --addmode default "1368x768"
xrandr: Failed to get size of gamma for output default
xrandr: cannot find mode "1368x768"
meydlo@m:~$ xrandr --addmode default "1368x768_60.00"
xrandr: Failed to get size of gamma for output default

meydlo@m:~$ xrandr --output default --mode 1368x768_60.00
xrandr: Failed to get size of gamma for output default
xrandr: Configure crtc 0 failed

But new options appear in the "Displays" in "system settings"
where when I choose option 1368x768 (16:9)
I get:
I got err: "required virtual size does not fit available size:
requested=(1368, 768), minimum=(800, 600), maximum=(1024,
768)"

GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._gnome_2drr_2derror_2dquark.Code3:
required virtual size does not fit available size: requested=(1368,
768), minimum=(800, 600), maximum=(1024, 768)

thanks :)

SuperTramp83

I am a translator!

Hors ligne
A rejoint: 10/31/2014

I asked about this around and read a lot of stuff. As far as I know having native screen resolution with ati and recent kernels is not possible!
I wish someone could prove me wrong. I would really like to install Trisquel 7 or Debian 8 on this laptop.

meydlo
Hors ligne
A rejoint: 04/18/2015

I don't know howcome but when I tried before the gNewSense the resolution what I got was correct. That's why I'm assuming that it should be possible, unfortunately I don't know how.

But I hope the fact that it works on gNewSense but not on trisquel would give someone hint how to migrate it.

Magic Banana

I am a member!

Hors ligne
A rejoint: 07/24/2010

Well, you could install an older kernel. Trisquel 6's kernels will be kept updated until next year. You can find them at http://packages.trisquel.info/toutatis-updates/linux-image and you would have to consult that page regularly to see and get new updates.

You can choose any of those kernels but not versions 3.13 (it is Trisquel 7's default version) and you want to pick a kernel with the highest existing number after the hyphen (latest update). Your system being 64 bit, you need to download the amd64 .deb package of the chosen kernel. You can install it with 'sudo dpkg -i' or with GDebi, a graphical interface in the repository. I do not know if you need to go all the way back to 3.2 or if 3.5, maybe 3.11, would give you the correct resolution.

Magic Banana

I am a member!

Hors ligne
A rejoint: 07/24/2010

Something I forgot to write, when you install a kernel, the other installed kernels are not removed. You always to keep a kernel you are sure you can boot.

Because it is older, the kernel you would install following the post above would not be the default one in the bootloader, i.e., you will need to select the older kernel from the bootloader's menu. If the older kernel gives you the correct resolution, we will then see how to make it the default one.

onpon4
Hors ligne
A rejoint: 05/30/2012

It works in gNewSense because gNewSense uses a much older kernel. Recent versions of Linux stopped working at native resolution with Radeon GPUs blob-free because of some kind of code simplification that took place. I'm not familiar with Linux or the Radeon driver, so I don't know the details.

SuperTramp83

I am a translator!

Hors ligne
A rejoint: 10/31/2014

Banana Magique - I know for sure it stopped working with the pont release of Trisquel 6. Do you know what kernel used the point release 6.0.1? I guess that was the first kernel to crap out the ati cards..
cheers!

Magic Banana

I am a member!

Hors ligne
A rejoint: 07/24/2010

Trisquel 6.0.1 has linux-image-3.2.0-60-generic: http://cdimage.trisquel.info/trisquel-images/trisquel_6.0.1_amd64.manifest

However, it would be very strange that a security update (the number "60" in the version above) created the problem. Are you sure Trisquel 6 got the correct resolution, whereas Trisquel 6.0.1 did not? I am here referring to the live media (Trisquel 6.0.1 basically is Trisquel 6 + updates and Trisquel 6 lets you choose more recent kernels).

SuperTramp83

I am a translator!

Hors ligne
A rejoint: 10/31/2014

Banana Magique - I didn't try the point release personally but I have been reading a lot of posts about this topic here on the Trisquel website and several users were writing about the fact that ATI worked great with 6 but not with 6.1 and 7..

lembas
Hors ligne
A rejoint: 05/13/2010

6.1

6.0.1

:)

(I don't know when the breakage happened, just saying there's no 6.1)

SuperTramp83

I am a translator!

Hors ligne
A rejoint: 10/31/2014

0.6.1 ?
:P

lydell

I am a member!

Hors ligne
A rejoint: 04/20/2014

This sounds a lot like http://trisquel.info/en/forum/cannot-get-widescreen-resolution-and-use-multiple-monitors-trisquel-7-i-could-trisquel-6. If that thread feels too long, try reading from the bottom.

meydlo
Hors ligne
A rejoint: 04/18/2015

Thank you very much responses :)

I'm going to try solution of downgrading kernel. The problem which appeared with this solution is fact that how to tell grub (2.0.2) which kernel I would like to use?. When I select (advanced options...) or press 'e' for edit I got a prompt for username and password but it always throw me away. Of course I think I'm using systems valid username/pass.

Maybe, I'm not going the right way.
If so please to guide me. otherhow:)

Magic Banana

I am a member!

Hors ligne
A rejoint: 07/24/2010

The GRUB password is mostly useless. GRUB's documentation - https://www.gnu.org/software/grub/manual/grub.html#Security - says:

By default, the boot loader interface is accessible to anyone with physical access to the console: anyone can select and edit any menu entry, and anyone can get direct access to a GRUB shell prompt. For most systems, this is reasonable since anyone with direct physical access has a variety of other ways to gain full access, and requiring authentication at the boot loader level would only serve to make it difficult to recover broken systems.

However, in some environments, such as kiosks, it may be appropriate to lock down the boot loader to require authentication before performing certain operations.

So, just remove this useless password:

  1. comment (with a leading "#") the lines of /etc/grub.d/01_PASSWORD that are not already commented;
  2. execute 'sudo update-grub'
lembas
Hors ligne
A rejoint: 05/13/2010

The GRUB credentials for your install (randomized at install time) are in

/etc/grub.d/01_PASSWORD

meydlo
Hors ligne
A rejoint: 04/18/2015

Thank you very much especially "Magic Banana" and also "lembas" :))). Finally I got it work (yupiii) :)

The latest kernel which is working with my card was and could be installed by:
apt-get install linux-image-3.11.0-20-generic linux-headers-3.11.0-20-generic linux-tools-3.11.0-20-generic

As a summary to what is also needed in order to make it work was:(for me) to comment lines in (in order to choose manually kernel)
/etc/grub.d/01_PASSWORD

I tried to change the default kernel to be "linux-image-3.11.0-20-generic" by:
GRUB_DEFAULT="Advanced options for Trisquel GNU/Linux>Trisquel GNU/Linux, with Linux-Libre 3.11.0-20-generic"
and also I tried:
GRUB_DEFAULT="2>2"
But it was not working for me. so I removed all other kernels.(could not wait to have it setted up :)

[SOLVED]

best regards

lembas
Hors ligne
A rejoint: 05/13/2010

Glad to hear that, this might be useful to other people in the same nasty situation.

That GRUB_DEFAULT= line you tried to change is the menu entry which should be booted by default, as can be found out from https://www.gnu.org/software/grub/manual/

meydlo
Hors ligne
A rejoint: 04/18/2015

I recently reinstalled trisquel and I noted that the summary which I posted was not complete. In order to make it work was also needed to comment my graphic card (radeon) from:
/etc/modprobe.d/fbdev-blacklist.conf
/etc/modprobe.d/disable-radeon.conf
/etc/modprobe.d/blacklist-framebuffer.conf

and in order to download kernel through apt-get was needed also:
sudo echo "deb http://es.archive.trisquel.info/trisquel toutatis-updates main" >> /etc/apt/sources.list

sorry to reply to death issue, but but just to be complete