Serious problems with Trisquel 9

48 réponses [Dernière contribution]
gnudev
Hors ligne
A rejoint: 08/03/2020

Hi
I installed Trisquel 9 and have many issues.
After install and login to (Trisquel mini default) the system not came up so I rebooted my computer.
When the system came up, I saw everything is very large. The quality of the images and text is very low and I can hardly read the texts.
I didn't have these problems in version 8 at all.
please see screenshots.
thanks...

gnudev
Hors ligne
A rejoint: 08/03/2020

screenshots

Selection_001.png Selection_002.png Selection_003.png
chaosmonk

I am a member!

I am a translator!

Hors ligne
A rejoint: 07/07/2017

Can you increase your screen resolution under system settings? (I've never used Trisquel Mini so I don't know exactly where the setting is, but it should be somewhere.)

gnudev
Hors ligne
A rejoint: 08/03/2020

No it's not possible. In version 9 I only have 640 * 480 resolution. but in version 8 default is 1024 * 768 and everything is amazing. version 9 It really blinded my eyes I had to go back to version 8.

gnudev
Hors ligne
A rejoint: 08/03/2020

This setting is in Preferences/Monitor Settings...
I didn't had this issue in trisquel 6, 7, 8...

chaosmonk

I am a member!

I am a translator!

Hors ligne
A rejoint: 07/07/2017

What graphics card do you have? If you aren't sure, install mesa-utils and copy/paste the output of

$ glxinfo | grep Device

gnudev
Hors ligne
A rejoint: 08/03/2020

[AMD/ATI] Curacao PRO [Radeon R7 370 / R9 270/370 OEM]

chaosmonk

I am a member!

I am a translator!

Hors ligne
A rejoint: 07/07/2017

Yeah, AMD GPUs are not very freedom-friendly, especially the older models, which need non-free drivers to even basic functionality. If you are getting better results with Trisquel 8 though then there may be something we can do to improve it with T9.

Can you install lshw and copy/paste the output of

$ sudo lshw -c video

on your Trisquel 8 system, and then boot into a Trisquel 9 live session and do the same? I'd like to see whether Trisquel 8 is using a different driver than Trisquel 9 for your GPU.

nadebula.1984
Hors ligne
A rejoint: 05/01/2018

If possible, replace the graphics card. Either Intel integrated graphics or Nvidia recognizes correct resolution under a free/libre GNU/Linux distribution. ATI/AMD graphics cards are very hostile to free/libre software.

gnudev
Hors ligne
A rejoint: 08/03/2020

@nadebula.1984
I have a old graphic card (NVIDIA GeForce 9500 GT) too. what about this. Is it free software driver? I don't heard good things about nvidia and gnu/linux. I've seen NVIDIA F*** finger clip from Linus Torvalds!

nadebula.1984
Hors ligne
A rejoint: 05/01/2018

It should be much better than any ATI/AMD card. Until first generation of Maxwell architecture (GM1xx), any Nvidia card works perfectly with free/libre software. You can try it and see what happens.

chaosmonk

I am a member!

I am a translator!

Hors ligne
A rejoint: 07/07/2017

$ glxinfo -B

should also give you that information, if you don't want to install another program.

PublicLewdness
Hors ligne
A rejoint: 03/15/2020

This has been my experience with my HD 4350; R9 270; R7 370; RX 580 and 5700 XT. I haven't found an AMD GPU yet where it works properly on Trisquel due to having closed source microcode; blobs; etc. There is no fix to be had. Options are AMD opens things up (probably never happen); switch to an Nvidia 7xx or older GPU to use the Nouveau drivers; or switch to an Intel CPU with onboard graphics.

gnudev
Hors ligne
A rejoint: 08/03/2020

@chaosmonk
sudo lshw -c video output:
*-display UNCLAIMED
description: VGA compatible controller
product: Curacao PRO [Radeon R7 370 / R9 270/370 OEM]
vendor: Advanced Micro Devices, Inc. [AMD/ATI]
physical id: 0
bus info: pci@0000:01:00.0
version: 81
width: 64 bits
clock: 33MHz
capabilities: pm pciexpress msi vga_controller bus_master cap_list
configuration: latency=0
resources: memory:c0000000-cfffffff memory:dfe00000-dfe3ffff ioport:e000(size=256) memory:dfe40000-dfe5ffff

glxinfo -B output:
name of display: :0
display: :0 screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
Vendor: VMware, Inc. (0xffffffff)
Device: llvmpipe (LLVM 6.0, 256 bits) (0xffffffff)
Version: 18.0.5
Accelerated: no
Video memory: 15989MB
Unified memory: no
Preferred profile: core (0x1)
Max core profile version: 3.3
Max compat profile version: 3.0
Max GLES1 profile version: 1.1
Max GLES[23] profile version: 3.0
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: llvmpipe (LLVM 6.0, 256 bits)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 18.0.5
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 3.0 Mesa 18.0.5
OpenGL shading language version string: 1.30
OpenGL context flags: (none)

OpenGL ES profile version string: OpenGL ES 3.0 Mesa 18.0.5
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00

chaosmonk

I am a member!

I am a translator!

Hors ligne
A rejoint: 07/07/2017

Is this on Trisquel 8 or 9? If you can provide both it will be possible to compare.

gnudev
Hors ligne
A rejoint: 08/03/2020

It's on Trisquel 8. I will install Trisquel 9 again soon. thanks...

gnudev
Hors ligne
A rejoint: 08/03/2020

I bought this system when I didn't know what GNU/Linux and free software is.
Unfortunately, the price of all items in my country has increased incredibly. so the price of the graphics card is very, very high and I can't get it... then I have to keep working with the current hardware...

nadebula.1984
Hors ligne
A rejoint: 05/01/2018

What about a second-hand, low-end Nvidia GT720? (It costs approximately $5 in China's dark market.)

I have such a one that works perfectly on any free/libre GNU/Linux distribution. It's a fan-less silent graphics card. It also supports 4k resolution through HDMI 2.0 port.

gnudev
Hors ligne
A rejoint: 08/03/2020

@nadebula.1984
I searched on the internet for it. It wasn't available in online stores or in second-hand goods.

gnudev
Hors ligne
A rejoint: 08/03/2020

@chaosmonk
Do I have to do anything else in Trisquel 9? If so, please tell. because I want to install it and remove it quickly and back to Trisquel 8. working and staying with Trisquel 9 is not possible for me right now. grateful

gnudev
Hors ligne
A rejoint: 08/03/2020

@chaosmonk
At the moment I'm in the [Trisquel mini 9 without installing] and everything works great (resolution is 1024 *768 and refresh rate is 61) .
Trisquel 9:

sudo lshw -c video output:
*-display UNCLAIMED
description: VGA compatible controller
product: Curacao PRO [Radeon R7 370 / R9 270/370 OEM]
vendor: Advanced Micro Devices, Inc. [AMD/ATI]
physical id: 0
bus info: pci@0000:01:00.0
version: 81
width: 64 bits
clock: 33MHz
capabilities: pm pciexpress msi vga_controller bus_master cap_list
configuration: latency=0
resources: memory:c0000000-cfffffff memory:dfe00000-dfe3ffff ioport:e000(size=256) memory:c0000-dffff

glxinfo -B output:
name of display: :0
display: :0 screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
Vendor: VMware, Inc. (0xffffffff)
Device: llvmpipe (LLVM 10.0.0, 256 bits) (0xffffffff)
Version: 20.0.8
Accelerated: no
Video memory: 15982MB
Unified memory: no
Preferred profile: core (0x1)
Max core profile version: 3.3
Max compat profile version: 3.1
Max GLES1 profile version: 1.1
Max GLES[23] profile version: 3.1
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: llvmpipe (LLVM 10.0.0, 256 bits)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 20.0.8
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 3.1 Mesa 20.0.8
OpenGL shading language version string: 1.40
OpenGL context flags: (none)

OpenGL ES profile version string: OpenGL ES 3.1 Mesa 20.0.8
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10

I am now installing Trisquel 9 and announcing the result.

gnudev
Hors ligne
A rejoint: 08/03/2020

@chaosmonk
I installed Trisquel 9. I got the same problem. (resolution is 640 * 480 and refresh rate is 73)

Trisquel 9 (After install)

sudo lshw -c video output:
*-display UNCLAIMED
description: VGA compatible controller
product: Curacao PRO [Radeon R7 370 / R9 270/370 OEM]
vendor: Advanced Micro Devices, Inc. [AMD/ATI]
physical id: 0
bus info: pci@0000:01:00.0
version: 81
width: 64 bits
clock: 33MHz
capabilities: pm pciexpress msi vga_controller bus_master cap_list
configuration: latency=0
resources: memory:c0000000-cfffffff memory:dfe00000-dfe3ffff ioport:e000(size=256) memory:c0000-dffff

glxinfo -B output:
name of display: :0
display: :0 screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
Vendor: VMware, Inc. (0xffffffff)
Device: llvmpipe (LLVM 10.0.0, 256 bits) (0xffffffff)
Version: 20.0.8
Accelerated: no
Video memory: 15982MB
Unified memory: no
Preferred profile: core (0x1)
Max core profile version: 3.3
Max compat profile version: 3.1
Max GLES1 profile version: 1.1
Max GLES[23] profile version: 3.1
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: llvmpipe (LLVM 10.0.0, 256 bits)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 20.0.8
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 3.1 Mesa 20.0.8
OpenGL shading language version string: 1.40
OpenGL context flags: (none)

OpenGL ES profile version string: OpenGL ES 3.1 Mesa 20.0.8
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10

Selection_001.png
gnudev
Hors ligne
A rejoint: 08/03/2020

This is my hardware info report. I thought it maybe useful.
please see attached file.

Fichier attachéTaille
hardinfo_report.txt 47.4 Ko
chaosmonk

I am a member!

I am a translator!

Hors ligne
A rejoint: 07/07/2017

So you get a higher resolution in a Trisquel 9 live session than you do after installing Trisquel 9? That's pretty odd.

> I have a old graphic card (NVIDIA GeForce 9500 GT) too. what about this. Is it free software driver? I don't heard good things about nvidia and gnu/linux. I've seen NVIDIA F*** finger clip from Linus Torvalds!

Nvidia is obnoxious, but an Nvidia card would still be better than your AMD card. There are both free and non-free drivers for Nvidia cards. The non-free ones have better advanced functionality like 3D acceleration, but the free ones are reliable and have basic functionality like correctly detecting your screen resolution. With your AMD card there is free driver, so Trisquel falls back to the generic driver that you are currently suffering with. Since you already have an Nvidia card, I encourage you to switch. It should work much better with Trisquel.

gnudev
Hors ligne
A rejoint: 08/03/2020

@chaosmonk
Yeah exactly it's very weird.
I think I have the same problem with the Nvidia graphics card. Can I be hopeful my problem will be solved in the next update? because I didn't have such a problem until version 9. That graphics card is very weak, I watch movie and that graphic card is very bad even for watching movies!

chaosmonk

I am a member!

I am a translator!

Hors ligne
A rejoint: 07/07/2017

> I think I have the same problem with the Nvidia graphics card.

Meaning that in a Triquel 9 live session you get a higher resolution than with a Trisquel system installed to your disk?

> Can I be hopeful my problem will be solved in the next update?

No, because no one is working on your problem because no one else has it. With some troubleshooting on your end, it may be possible to identify the cause, and then fix it, whether that fix needs to be applied on your side or Trisquel's.

> because I didn't have such a problem until version 9.

I find it interesting that you do not have the problem with the Trisquel 9 live session. That means there is hope that we can get it working with an installed Trisquel 9 system, but I have to admit I'm perplexed. Especially if the Nvidia card really has the exact same issue. What does

$ glxinfo -B

look like with the Nvidia card?

> That graphics card is very weak, I watch movie and that graphic card is very bad even for watching movies!

Worse than your AMD card? I have never gotten smooth video playback with any AMD PGU.

chaosmonk

I am a member!

I am a translator!

Hors ligne
A rejoint: 07/07/2017

Something else to try is installing Trisquel 8 and upgrading to Trisquel 9, in case the problem is something that occurs while installing Trisquel 9.

gnudev
Hors ligne
A rejoint: 08/03/2020

How do I do this? (Update from version 8 to 9)

Magic Banana

I am a member!

En ligne
A rejoint: 07/24/2010

See https://trisquel.info/forum/trisquel-90-etiona-out#comment-152945 and, if that does not work, two posts below that one.

gnudev
Hors ligne
A rejoint: 08/03/2020

> Meaning that in a Triquel 9 live session you get a higher resolution than with a Trisquel system installed to your disk?
Exactly. I made a bootable usb flash for Trisquel 9 and In live session resolution was 1024 * 768 and everything works great (like my Trisquel 8) but when I install it, everything falls apart, resolution is so bad and it blinds my eyes. I do this (test in live environment and then install in hard disk) three times and I had the same problem all three times. I'm 100% sure this is a bug in Trisquel 9. I installed Trisquel 8 several times and I've never had such a problem. I wonder why resolution it works well in live session and has problems after installation in hard drive!

> ... look like with the Nvidia card?
I will report this soon...

@chaosmonk I really thank you...

Magic Banana

I am a member!

En ligne
A rejoint: 07/24/2010

If the installer updates the packages (as far as I remember a check in a box configures that), the installed kernel (where the drivers live) may be different. Executed in a terminal, 'uname -r' outputs the version of the kernel that is running. I would run that command in the properly working live system and in the improperly working installed system to see if the output versions are different.

RootFarmer
Hors ligne
A rejoint: 08/24/2020

Can you copy the driver from Trisquel 8 and paste it into Trisquel 9?

gnudev
Hors ligne
A rejoint: 08/03/2020

@RootFarmer
I don't think so...

gnudev
Hors ligne
A rejoint: 08/03/2020

@chaosmonk
I changed my graphic card but I came across a black screen, not because Trisquel has a problem I haven't used this graphics card for years and I do not even know why I left it. This graphics card is unprotected and under my equipment and is damaged :(
So now I upgrade my system and report the result.

gnudev
Hors ligne
A rejoint: 08/03/2020

@Magic Banana
Thanks I lost your message. I found it now.

gnudev
Hors ligne
A rejoint: 08/03/2020

@chaosmonk @Magic Banana
I tries upgrade system with:
sudo sed -i 's/flidas/etiona/' /etc/apt/sources.list && sudo apt update && sudo apt full-upgrade
Upgrade done but nothing happened! (I've done reboot) I still have Trisquel 8, GNU Emacs 24, ...
dear friends thanks, I still hope that Trisquel 9 improves. If the problem persists, I will continue to use Trisquel 8 until in the next 2 or 3 years I will get a free hardware laptop (like thinkpad x200).
don't know how to thank you...

Magic Banana

I am a member!

En ligne
A rejoint: 07/24/2010

Can you show us the content of /etc/apt/sources.list?

gnudev
Hors ligne
A rejoint: 08/03/2020

@Magic Banana

# deb cdrom:[Trisquel 8.0 _etiona_ - Release amd64 (20180417)]/ flidas main

# Trisquel repositories for supported software and updates
deb https://archive.trisquel.info/trisquel/ etiona main
deb-src https://archive.trisquel.info/trisquel/ etiona main
deb https://archive.trisquel.info/trisquel/ etiona-security main
deb-src https://archive.trisquel.info/trisquel/ etiona-security main
deb https://archive.trisquel.info/trisquel/ etiona-updates main
deb-src https://archive.trisquel.info/trisquel/ etiona-updates main
# deb https://archive.trisquel.info/trisquel/ etiona-backports main
# deb-src https://archive.trisquel.info/trisquel/ etiona-backports main

gnudev
Hors ligne
A rejoint: 08/03/2020

@Magic Banana
I found that some softwares like 'MPV' updated to the latest version! but not Trisquel! (Trisquel is still version 8)

Magic Banana

I am a member!

En ligne
A rejoint: 07/24/2010

What is the output of the following command?
$ sudo apt update && sudo apt full-upgrade

gnudev
Hors ligne
A rejoint: 08/03/2020

Hit:1 http://ppa.launchpad.net/deadsnakes/ppa/ubuntu xenial InRelease
Hit:2 http://ppa.launchpad.net/uget-team/ppa/ubuntu xenial InRelease
Hit:3 https://archive.trisquel.info/trisquel etiona InRelease
Get:4 https://archive.trisquel.info/trisquel etiona-security InRelease [4904 B]
Get:5 https://archive.trisquel.info/trisquel etiona-updates InRelease [6118 B]
Get:6 https://archive.trisquel.info/trisquel etiona-security/main Sources [315 kB]
Get:7 https://archive.trisquel.info/trisquel etiona-security/main amd64 Packages [968 kB]
Get:8 https://archive.trisquel.info/trisquel etiona-security/main i386 Packages [965 kB]
Get:9 https://archive.trisquel.info/trisquel etiona-updates/main Sources [645 kB]
Get:10 https://archive.trisquel.info/trisquel etiona-updates/main i386 Packages [1688 kB]
Get:11 https://archive.trisquel.info/trisquel etiona-updates/main amd64 Packages [1708 kB]
Fetched 6300 kB in 6s (1112 kB/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
1357 packages can be upgraded. Run 'apt list --upgradable' to see them.
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
debconf-i18n : Depends: debconf (= 1.5.58ubuntu2) but 1.5.66ubuntu1 is installed
dh-python : Depends: python3-distutils but it is not installed or
python3 (< 3.6.5~rc1-1) but 3.6.7-1~18.04 is installed
gir1.2-gtk-3.0 : Depends: libgtk-3-0 (>= 3.22.29) but 3.18.9-1ubuntu3.3 is installed
hplip : Depends: libhpmud0 (= 3.17.10+repack0-5+9.0trisquel1) but 3.16.3+repack0-1+8.0trisquel1 is installed
Depends: printer-driver-hpcups (= 3.17.10+repack0-5+9.0trisquel1) but 3.16.3+repack0-1+8.0trisquel1 is installed
Depends: libsane1 (>= 1.0.24) but it is not installed
Recommends: printer-driver-postscript-hp but it is not installed
Recommends: sane-utils
ibus : Depends: gir1.2-ibus-1.0 (= 1.5.11-1ubuntu2.4) but 1.5.17-3ubuntu5.3 is installed
libc-bin : Depends: libc6 (< 2.24) but 2.27-3ubuntu1.2 is installed
libc-dev-bin : Depends: libc6 (< 2.24) but 2.27-3ubuntu1.2 is installed
libc6-dev : Depends: libc6 (= 2.23-0ubuntu11.2) but 2.27-3ubuntu1.2 is installed
libreoffice : Depends: libreoffice-core (= 1:5.1.6~rc2-0ubuntu1~xenial10) but 1:6.0.7-0ubuntu0.18.04.10 is installed
libreoffice-avmedia-backend-gstreamer : Depends: libreoffice-core (= 1:5.1.6~rc2-0ubuntu1~xenial10) but 1:6.0.7-0ubuntu0.18.04.10 is installed
libreoffice-base : Depends: libreoffice-base-core (= 1:6.0.7-0ubuntu0.18.04.10) but 1:5.1.6~rc2-0ubuntu1~xenial10 is installed
Depends: libreoffice-base-drivers (= 1:6.0.7-0ubuntu0.18.04.10) but 1:5.1.6~rc2-0ubuntu1~xenial10 is installed
libreoffice-base-core : Depends: libreoffice-core (= 1:5.1.6~rc2-0ubuntu1~xenial10) but 1:6.0.7-0ubuntu0.18.04.10 is installed
libreoffice-base-drivers : Depends: libreoffice-core (= 1:5.1.6~rc2-0ubuntu1~xenial10) but 1:6.0.7-0ubuntu0.18.04.10 is installed
libreoffice-calc : Depends: libreoffice-base-core (= 1:6.0.7-0ubuntu0.18.04.10) but 1:5.1.6~rc2-0ubuntu1~xenial10 is installed
Depends: liborcus-0.13-0 (>= 0.13.3) but it is not installed
libreoffice-core : Depends: libgpgmepp6 (>= 1.10.0) but it is not installed
Depends: libhunspell-1.6-0 but it is not installed
Depends: liborcus-0.13-0 (>= 0.13.3) but it is not installed
Depends: libpoppler73 (>= 0.62.0) but it is not installed
Depends: libxmlsec1 (>= 1.2.25) but it is not installed
Depends: libxmlsec1-nss (>= 1.2.25) but it is not installed
libreoffice-gnome : Depends: libreoffice-gtk3 but it is not installed
libreoffice-gtk : Depends: libreoffice-gtk2 but it is not installed
libreoffice-math : Depends: libreoffice-core (= 1:5.1.6~rc2-0ubuntu1~xenial10) but 1:6.0.7-0ubuntu0.18.04.10 is installed
libreoffice-report-builder-bin : Depends: libreoffice-core (= 1:5.1.6~rc2-0ubuntu1~xenial10) but 1:6.0.7-0ubuntu0.18.04.10 is installed
libreoffice-sdbc-firebird : Depends: libreoffice-core (= 1:5.1.6~rc2-0ubuntu1~xenial10) but 1:6.0.7-0ubuntu0.18.04.10 is installed
libreoffice-sdbc-hsqldb : Depends: libreoffice-core (= 1:5.1.6~rc2-0ubuntu1~xenial10) but 1:6.0.7-0ubuntu0.18.04.10 is installed
libreoffice-writer : Depends: libreoffice-base-core (= 1:6.0.7-0ubuntu0.18.04.10) but 1:5.1.6~rc2-0ubuntu1~xenial10 is installed
Depends: libabw-0.1-1 but it is not installed
Depends: libepubgen-0.1-1 (>= 0.1.0) but it is not installed
libwebkitgtk-1.0-0 : Depends: libjavascriptcoregtk-1.0-0 (= 2.4.11-0ubuntu0.1) but 2.4.11-3ubuntu3 is installed
Depends: libwebkitgtk-1.0-common (>= 2.4.11) but it is not installable
locales : Depends: libc-bin (> 2.27)
mpv : Depends: libegl1 but it is not installed
software-properties-gtk : Depends: python3-software-properties (= 0.96.20.10+8.0trisquel1) but 0.96.24.32.14+9.0trisquel3 is installed
trisquel-release-upgrader-gtk : Depends: trisquel-release-upgrader-core (= 1:16.04.32+8.0trisquel3) but 1:18.04.40+9.0trisquel9 is installed
Depends: python3-distupgrade (= 1:16.04.32+8.0trisquel3) but 1:18.04.40+9.0trisquel9 is installed
update-manager : Depends: update-manager-core (= 1:16.04.17+8.0trisquel9) but 1:18.04.11.13+9.0trisquel10 is installed
update-notifier : Depends: update-notifier-common (= 3.168.10+8.0trisquel2) but 3.192.1.7+9.0trisquel2 is installed
Recommends: apport-gtk (>= 2.8-0ubuntu3) but it is not installed
update-notifier-common : Depends: python3-debconf but it is not installed or
debconf (< 1.5.64~) but 1.5.66ubuntu1 is installed
E: Unmet dependencies. Try using -f.

chaosmonk

I am a member!

I am a translator!

Hors ligne
A rejoint: 07/07/2017

> You might want to run 'apt-get -f install' to correct these.

Did you do this?

gnudev
Hors ligne
A rejoint: 08/03/2020

I tried this and my system ruined. so I reinstalled it.

avrtm
Hors ligne
A rejoint: 11/22/2019

I updated yesterday my laptop from Trisquel 8 to Trisquel 9 with «sudo do-release-upgrade -d» and it works fine. It have an AMD GPU, I think it is as old as yours.

Captura de pantalla -2020-10-22 20-44-16.png
gnudev
Hors ligne
A rejoint: 08/03/2020

I did this too. system didn't upgrade.

Ark74

I am a member!

Hors ligne
A rejoint: 07/15/2009

check that you used the "-d" switch at the end.

gnudev
Hors ligne
A rejoint: 08/03/2020

@chaosmonk, @Magic Banana
Hi If I install Trisquel (Mate desktop) or Triskel (KDE desktop) It's possible that I didn't have this problem? I thought maybe this is a bug only in Trisquel mini or there is no different between the versions?
Sorry I bother you again, because reinstalling again is hard to me. reinstalling system is takes so many time.
I have to say I had the same problem in Parabola and Hyperbola. I hate my computer...
thanks...

chaosmonk

I am a member!

I am a translator!

Hors ligne
A rejoint: 07/07/2017

The only difference with the other Trisquel flavors is the desktop environment. In order to try them out, you do not need to reinstall Trisquel. You can just install another deskop environment with apt and select it at the login screen. However, I would be surprised if this fixed your problem, especially if you have the same problem with Parabola and Hyperbola. Those AMD GPUs are a real pain in the ass.

Maybe this thread could help you?[1] You're never going to be able to get smooth video playback or 3D acceleration with that GPU, but hopefully you can get a tolerable screen resolution.

[1] https://askubuntu.com/questions/442851/how-can-i-get-my-monitors-maximum-resolution-without-the-proprietary-amd-graphi

strypey
Hors ligne
A rejoint: 05/14/2015

Hi gnudev, Sorry to hear you are having these problems trying to upgrade to Etiona.

> If I install Trisquel (Mate desktop) or Triskel (KDE desktop) It's possible that I didn't have this problem?

AFAIK Trisquel-Mini 10 still uses an obsolete LXDE desktop environment. This means it will have pretty much the same resource usage as the Mate desktop, but for a significantly degraded LXDE desktop experience. Installing the Mate or KDE flavours of Trisquel will solve this problem. If it also solves your resolution problem, that's a bonus ;)

IMHO there is no point using the Trisquel-Mini flavour of Trisquel 8 (Flidas) or 9 (Etiona). Hopefully version 10 of Trisquel-Mini will be switched to LXQT or ideally another desktop environment that's significantly more lightweight than Mate. Sorry to all the forum regulars who are probably bored of hearing me grizzle about this ;)