Trisquel 9 Graphical ISO available for testing

85 réponses [Dernière contribution]
chaosmonk

I am a member!

I am a translator!

Hors ligne
A rejoint: 07/07/2017

> 3. The program torbrowser-launcher does not work by default. I had to
> follow the steps below to get it working.

Sorry, this is a wontfix. Since it's a downloader instead of a proper
package, quidam does not want to include it in Trisquel at all.

I think I can fix the compton thing, but I don't have the energy to do
it right now. Remind me if I don't get back to you in the next few
days.

martinh
Hors ligne
A rejoint: 02/21/2014

Hi All !
Brilliant news about the 9.0 iso's, thanks to everyone involved.

Just spotted new Iso's from 17 and 18/01/2020...
One is called Triskel, the other Trisquel ?
Are these 'beta' already ?

I tried the iso from december, but the graphical install failed, however, had
no problems running it live.

Are there major changes between the Iso's ?
Thanks

calher

I am a member!

Hors ligne
A rejoint: 06/19/2015

A Triskel ISO? Wow. Triskel is Trisquel with KDE Plasma.

Malsasa
Hors ligne
A rejoint: 12/01/2016

I tried LiveCD session of Trisquel 9.0 amd64 and it works without
problem for me. MATE desktop works as I want, internet works (from a
USB mifi), browser works, file manager works & can access disk
partitions just well, installing programs also works well from
archive.trisquel.info server. My system is Intel Pentium 967 1.3GHz
4GB RAM with the bootable SanDisk usb flash drive 32GB. Thank you all
Trisquel Developers!

However, I didn't install that T9 yet.

And I am really surprised to see Triskel, the KDE edition, is
available. I have seen the manifest file and it says Plasma version
5.12 within. This is amazing.

loldier
Hors ligne
A rejoint: 02/17/2016

Triskel.

triskel_2.png
arkadiy
Hors ligne
A rejoint: 01/21/2020

Flashed the ISO using the terminal method described in the documentation. When trying to boot into the "Try Trisquel without installing" option, I am presented with a blank screen and blinking underscore. Flashed the ISO twice to check whether this was an issue the first time around, but the issue persists.

I suspect this might have something to do with section 3 here: https://askubuntu.com/questions/162075/my-computer-boots-to-a-black-screen-what-options-do-i-have-to-fix-it/162076#162076

The laptop is MacBook 2,1, so this has nothing to do with the nonexistent UEFI.

Ready to investigate with further guidance!

boba
Hors ligne
A rejoint: 08/28/2017

I cannot find the "Add/remove software" shortcut in the 'Applications' menu on Trisquel 9. Of course I can add software through the terminal or Synaptic, but that shorcut was quite helpful. Am I missing something?

EDIT: My bad, this is what I was missing:
https://trisquel.info/en/forum/addremove-applications-alternative-trisquel-9

So, no more "Add/remove Applications", but I have not managed to get what will come forth as a replacement. Trisquel-app-install and trisquel-software, forked from gnome-app-install and gnome-software?

Ark74

I am a member!

Hors ligne
A rejoint: 07/15/2009

The replacement is already developed, hopefully it will be in the next ISO.

boba
Hors ligne
A rejoint: 08/28/2017

Thank you!

Dave_Hunt

I am a member!

Hors ligne
A rejoint: 09/19/2011

I decided to give the new Trisquel 9 graphical live system a spin, and found that the orca screen reader will not start. First, I tried waiting about 10 minutes after boot, thinking it might start in the manner to which I'm accustomed in Trisquel. When nothing seemed to happen, I ticked the volume controls on my keyboard, and heard the 'opop' sounds, thereby confirming that the audio system is working. I typed the orca command "/usr/bin/orca --setup" into the 'run' dialogue, and heard nothing. Next, I tested the tts system, and found that it's working. Finally, I opened a mate terminal and gave the command, "which orca", and got "/usr/bin/orca", which showed that the binary is in the proper place. I used the ocr feature in my smart phone to learn this. Finally, I ran orca from the terminal and heard errors regarding something called canbera being missing, and something about unable to start gtk dialog without a parent. Again, using my phone's ocr features and tts. BTW, this activity was all on bare metal.

Thanks,

-Dave H.

Ark74

I am a member!

Hors ligne
A rejoint: 07/15/2009

Thanks for the report, will look into it.

Ark74

I am a member!

Hors ligne
A rejoint: 07/15/2009

Hi again, there is already a couple of changes meant to fix this issue, hopefully the next ISO will have this issue fixed.

Cheers!

lan
lan
Hors ligne
A rejoint: 02/03/2020

Will it be possible to migrate from Trisquel 8 to Trisquel 9? Without wiping disk and loosing existing data.

I am also waiting for the news about Trisquel Mini 9 32bit. I had issues with Trisquel Mini 8 with installing several languages for keyboard. i did not find way to make keyboard type in many languages.

Thank you.

boba
Hors ligne
A rejoint: 08/28/2017

I trust that you backup your home directory before any upgrade, so a fresh install does not make much difference except being faster, easier and somehow cleaner. That is what I do and I find Trisquel to be particularly fast to install.

Magic Banana

I am a member!

Hors ligne
A rejoint: 07/24/2010

Will it be possible to migrate from Trisquel 8 to Trisquel 9? Without wiping disk and loosing existing data.

Yes. In fact, if you are not afraid of alpha versions, you can already do that:
$ sudo sed -i 's/flidas/etiona/' /etc/apt/sources.list && sudo apt update && sudo apt full-upgrade

paolo
Hors ligne
A rejoint: 08/02/2017

hello,
I upgrade Trisquel Mini 8 to 9 changing the sources.list from flidas to etiona and all went well

here is my story:

https://trisquel.info/it/forum/trisquel-9-mini-my-install-and-some-doubt

boba
Hors ligne
A rejoint: 08/28/2017

The touchpad feels less precise on Trisquel 9 than on Trisquel 8 (to the same user on the same machine).

I have noticed a (slight) difference in the mouse settings: on T8 the acceleration and sensivity settings were only available on the "General" tab while on T9 the two cursors are available in both the "General" and the "Touchpad" tabs. Maybe this is the reason why the same settings in the "General" tab do not feel the same on T8 and on T9. I have not managed yet to find the correct balance.

Is there some work in progress on this configuration tool?

boba
Hors ligne
A rejoint: 08/28/2017

Following hints from an unrelated thread (1), I noticed that the output of 'xinput list-props' for the touchpad has very different entries on T8 and on T9.

I had hoped to be able to copy the settings from T8 to T9 but because of this situation I am still stuck in the middle of the touchpad settings. For now the choice is between:

1. slow and somehow accurate and

2. fast enough but quite inaccurate nearby the target.

I am not sure to find a way to strike the right balance, so I wonder if there is a possibility to tweak it and come "back" to way the touchpad used to be managed in T8.

(1) https://trisquel.info/en/forum/libreboot-t400-minifree-reduces-price-once-again#comment-116782

lan
lan
Hors ligne
A rejoint: 02/03/2020

Thanks all! I successfully upgraded.

Unfortunately riseup-vpn again does not install with the same mistake when installing from debian package as it did in trisquel 8: can't locate riseup-vpn.

Mini 9 i386 works very fine. Wine, all mate environment utilities as in standard, icecat, tor browser, SQLite and libreoffice work very well, with as little as 2GB RAM.

Thank developers for great job! Please never discontinue Mini and i386.

chaosmonk

I am a member!

I am a translator!

Hors ligne
A rejoint: 07/07/2017

Did you add Riseup's apt repository? What is the output of

$ ls /etc/apt/sources.list.d/

and

$ cat /etc/apt/sources.list

lan
lan
Hors ligne
A rejoint: 02/03/2020

$ ls /etc/apt/sources.list.d/

leap.list

$ cat /etc/apt/sources.list

deb https://archive.trisquel.info/trisquel/ etiona main
# deb-src https://archive.trisquel.info/trisquel/ etiona main
deb https://archive.trisquel.info/trisquel/ etiona-security main
# deb-src https://archive.trisquel.info/trisquel/ etiona-security main
deb https://archive.trisquel.info/trisquel/ etiona-updates main
# deb-src https://archive.trisquel.info/trisquel/ etiona-updates main
deb https://archive.trisquel.info/trisquel/ etiona-backports main
# deb-src https://archive.trisquel.info/trisquel/ etiona-backports main

chaosmonk

I am a member!

I am a translator!

Hors ligne
A rejoint: 07/07/2017

Thanks. Can you now post the contents of `/etc/apt/sources.list.d/leap.list` and see if there are any errors when you run

$ sudo apt update

?

lan
lan
Hors ligne
A rejoint: 02/03/2020

Please help. I tried to install trisquel 9 64bit on another machine the same way as I installed Mini with repositories given here https://trisquel.info/en/forum/trisquel-9-mini-my-install-and-some-doubt#comment-146000

And it did not work.

The following packages have unmet dependencies:
gnupg : Breaks: python-apt (<= 1.1.0~beta4) but 1.1.0~beta1ubuntu0.16.04.8+8.0trisquel4 is to be installed

When trying to install python-apt:

The following packages have unmet dependencies:
libreoffice-common : Breaks: libreoffice-core (< 1:6.3~) but 1:5.1.6~rc2-0ubuntu1~xenial10 is to be installed
Recommends: fonts-liberation2 but it is not going to be installed or
ttf-mscorefonts-installer but it is not installable
Recommends: python3-uno (>= 4.4.0~beta2) but it is not going to be installed
ure : Breaks: libreoffice-core (< 1:5.3.0~beta1~) but 1:5.1.6~rc2-0ubuntu1~xenial10 is to be installed

When trying to install libreoffice-core:

The following packages have unmet dependencies:
gnupg : Breaks: python-apt (<= 1.1.0~beta4) but 1.1.0~beta1ubuntu0.16.04.8+8.0trisquel4 is to be installed

Circle... When sudo apt install -f it gives nothing:

0 upgraded, 0 newly installed, 0 to remove and 1996 not upgraded.

And upgrade demands python-apt again.

__________________________

As for riseup-vpn the content of leap.list is

deb http://deb.leap.se/client release buster

I also tried

deb http://deb.leap.se/client release bionic
deb http://deb.leap.se/client release sid
deb http://deb.leap.se/client release stretch

sudo apt update runs without errors in all machines

chaosmonk

I am a member!

I am a translator!

Hors ligne
A rejoint: 07/07/2017

Try running

$ sudo apt dist-upgrade

if you have not already.

> deb http://deb.leap.se/client release bionic

This is correct. Did you run `sudo apt update` after editing `leap.list` before trying to install the package?

lan
lan
Hors ligne
A rejoint: 02/03/2020

Yes, I always use sudo apt update and it never gave any error, it says:

Hit:1 http://deb.leap.se/client release InRelease
(and other hits)

But as far as I try to install riseup:

sudo apt install riseup-vpn leap-archive-keyring

it says
E: Unable to locate package riseup-vpn

chaosmonk

I am a member!

I am a translator!

Hors ligne
A rejoint: 07/07/2017

Okay, I was wrong. The [bionic repository][1] only includes packages
for bitmask-vpn, not riseup-vpn. The [buster repository][2] does
include riseup-vpn, so that's what you need. Note however, that there
is only a 64-bit binary package for riseup-vpn. There is [no 32-bit
package][3], so if you have a 32-bit system you're out of luck, unless
you compile the program yourself.

[1]:
http://deb.leap.se/client/dists/release/bionic/binary-amd64/Packages

[2]:
http://deb.leap.se/client/dists/release/buster/binary-amd64/Packages

[3]: http://deb.leap.se/client/dists/release/buster/binary-i386/Packages

lan
lan
Hors ligne
A rejoint: 02/03/2020

I updgraded to trisquel 9 with Software Updater program. It upgraded but as I logged again I got some problems.

My beautiful custom theme went away. Trisquel button for main menu changed. And there is no more keyboard language change that I installed long ago. Appearence does not open with error that mate-settings-daemon is not running, text of the error:

Unable to start the settings manager 'mate-settings-daemon'.
Without the MATE settings manager running, some preferences may not take effect. This could indicate a problem with DBus, or a non-MATE (e.g. KDE) settings manager may already be active and conflicting with the MATE settings manager.

while when trying to run it from terminal:

$ mate-settings-daemon

(mate-settings-daemon:1992): GLib-GIO-ERROR **: 12:03:29.719: Settings schema 'org.mate.interface' does not contain a key named 'can-change-accels'
Trace/breakpoint trap

I successfully installed riseup-vpn on 64bit since you change Ubuntu 16.04 to Ubuntu 18.04 thanks a lot. But it does not run. If running from terminal:

$ riseup-vpn
riseup-vpn: symbol lookup error: riseup-vpn: undefined symbol: gtk_shortcuts_window_get_type

lan
lan
Hors ligne
A rejoint: 02/03/2020

I also noted all repos of etonia disapeared from Software Updates and I can't add them. Also all authentication keys disapeared or I can't see them (desktop is not fully running: white text on white background many times, no ability to differentiate flag on and flag off).

$ cat /etc/apt/sources.list
# deb cdrom:[Trisquel 8.0 _etiona_ - Release amd64 (20180417)]/ flidas main

# Trisquel repositories for supported software and updates
# deb-src https://deb.torproject.org/torproject.org xenial main
# deb-src https://archive.trisquel.info/trisquel/ etiona main
# deb-src https://archive.trisquel.info/trisquel/ etiona-security main
# deb-src https://archive.trisquel.info/trisquel/ etiona-backports main
# deb-src https://archive.trisquel.info/trisquel/ etiona-updates main
el@el-HP-250-G5-Notebook-PC:/usr/bin$

Trying to add anything gives nothing. Please help me.

chaosmonk

I am a member!

I am a translator!

Hors ligne
A rejoint: 07/07/2017

I see a few problems:

* All of the repositories are commented out. You need to remove the `# ` from the repositories you want to use, or they will be ignored.

* `deb-src` lines are for downloading source packages. In order to be able to download and install binary packages, you need to change `deb-src` to `deb`. If you want to be to download both binaries *and* sources, then duplicate the lines and in the copied lines change `deb-src` to `deb`.

* In the torproject line, you should probably change `xenial` to `bionic`, since Trisquel 9 is based on Ubuntu 18.04 bionic.

lan
lan
Hors ligne
A rejoint: 02/03/2020

Ok. I put with echo into sources list all repos back and it showed some possible upgrade again. I started upgrade in hope to upgrade the mate desktop so that it fully apply. And after a night of upgrade it stuck and I had to press the switch button. Now when I try to boot the comp trisquel 9 demands login and password and after I use my home directory as login and root password I get into command line in which I attempt to proceed upgrade and now it upgraded fully. But I do not know how to get away of command line and open my desktop again. I am now in tty1 command line in that comp, it awaits commands, and I wish get into my desktop environment.

calher

I am a member!

Hors ligne
A rejoint: 06/19/2015

On 2/16/20 2:07 AM, name at domain wrote:
> Trisquel GNU/Linux 9.0 [the name of PC] tty1

Your hostname is sensitive information? Perhaps you should have chosen
a better hostname. It is usually broadcasted on whatever network you
are connected to. Hostnames are intended to be known and seen by others.

cal@bender

--
Caleb Herbert
name at domain
(816) 892-9669
https://bluehome.net/csh

lan
lan
Hors ligne
A rejoint: 02/03/2020

Wow! I just typed reboot after full dist-upgrade and it rebooted back into my beautiful Mate environment with everything working again! I am happy! riseup installed fine but does not connect it close with error exit 1.

$ riseup-vpn
2020/02/16 03:45:35 firewall stop
Gtk-Message: 03:45:35.928: Failed to load module "topmenu-gtk-module"
2020/02/16 03:45:36 openvpn stop
2020/02/16 03:45:41 firewall start
2020/02/16 03:45:41 Error while running bitmask-root:
2020/02/16 03:45:41 args: [/usr/sbin/bitmask-root firewall start [***a lot of IPs*** deleted because not sure whether ok to post]]
2020/02/16 03:45:41 output: bitmask-root: ERROR: Could not determine state of iptable chain
bitmask-root: ERROR: Could not run ['/sbin/ip6tables', '--new-chain', 'bitmask']: None

2020/02/16 03:45:41 Error starting VPN: exit status 1
Gtk-Message: 03:45:41.602: GtkDialog mapped without a transient parent. This is discouraged.

calher

I am a member!

Hors ligne
A rejoint: 06/19/2015

Since there is a Triskel ISO, I hope there will be a GNOME ISO.

Magic Banana

I am a member!

Hors ligne
A rejoint: 07/24/2010

Getting your desktop environment of choice is not hard: https://trisquel.info/en/wiki/installing-gnome-shell

Connochaetes
Hors ligne
A rejoint: 12/13/2017

I haven't seen any mention of the latest ISO, so here goes:

http://jenkins.trisquel.info/makeiso-etiona/iso/

Thank you!

As earlier, Torrent doesn't seem to work.