Used correct password and still locked out !

3 réponses [Dernière contribution]
Hors ligne
A rejoint: 09/03/2017

Hello everyone .

I entered the correct password but for some reason shows the login screen again.
Because of this loop I can't access my computer. I read forums regarding this problem on internet. Pressing alt + ctrl +
F1 does show the command prompt screen and am able to use my login name and password at command prompt but I want access to GUI.So nothing worked, I'm always back to GUI login screen . Help !

Hors ligne
A rejoint: 08/17/2017

Hi LinuxDummy,

this could have one of several reasons. I'd advise you to first check which keymap is selected - if you are using e.g. a French keyboard while having the US keymap selected, many keys won't match the letters that are on your physical keyboard.
Secondly, as you can indeed login on another TTY, you can do so and type "startx" at the command line to further troubleshoot from there. My guess is that on starting the X server, a different keymap is selected for some reason (possibly something wasn't set correctly during setup or something of the sort). At the command line, however, it might be defaulting to the correct keymap, which would explain why you can login there but not using your display manager (the "GUI login screen").

Hope this helps!
- PenGNUin

Magic Banana

I am a member!

I am a translator!

Hors ligne
A rejoint: 07/24/2010

Just complementing: the package named "xinit" (not installed by default) provides the 'startx' command. To install it from the terminal:
$ sudo apt install xinit

Hors ligne
A rejoint: 08/16/2017

Here is a tutorial on this login loop problem. Maybe you can start your research from here...

I've just installed Trisquel... about a month or 2 ago... I'm totally new to linux in general. Learning it from scratch... Been having problems with this login issue quite often, had to re install the system 4 times now due to this... Had to open a few beers to cope with the stress haha

It seems that this is commonly solved by by tweaking the authorization on the Xauthority file, or reconfiguring or re installing lightdm (or uninstalling lightdm and installing another alike program responsible for login/GUI). Make sure you have internet connection before uninstalling lightdm, as the apt-get thing needs internet to download the programs it'll install. Otherwise you'll end up having to re install the system like I had to

I found out, though, when trying to set up the graphics card driver, that I fixed my problem once by uninstalling the proprietary driver for my graphics card (nvidia geforce GTX1050 ti):

$ sudo apt-get purge nvidia*

All the times i had to re install the system for getting stuck on this loop, the proprietary nvidia driver was installed (the only proprietary software on the system)... guess some bad stuff happen for a good reason after all...