wireless card not turned on in standard Trisquel

7 réponses [Dernière contribution]
Hors ligne
A rejoint: 10/20/2010

I have an HP dv9500 laptop My only operating system is Trisquel. I downloaded the iso and installed it this morning. Unfortunately I can not get a connection to the internet. I have a intel wireless controller. when I try to establish a connection the menu option for wireless networks is greyed out with the message underneth "device not turned on"

I am brand new to linux but I nosed around a bit in the package manager and found a device manager but it isn't in the normal install and requires an internet connection to download from within triquel

I need to know what packages I need to download to allow me to connect. I will need to download via a windows pc and burn cds

Thanks for your help

Hors ligne
A rejoint: 10/06/2009

Wow. Congratulations on taking the plunge! My suggestion would be to check your hardware against a database of free drivers to see if your wireless card is supported (like http://www.h-node.com/ for instance :D) and if it is not, see if you can obtain one that will restore your wireless connectivity (perhaps a USB or PC-card wireless adapter). Be careful, however -- I once bought a PCMCIA card that was advertised as working with "free software" and yet found to my chagrin that it still required proprietary firmware to work. Fortunately my current laptop does not have that problem (it "just works"). Hopefully some of the others will respond with more specific advice, but I thought I'd chime in to get you started.

p.s. If you can get access to a wired network, I would be willing to bet that that will work at least so that you can get online to look things up and troubleshoot, etc. I used to do that, as well, back before there were so many and such good wireless drivers freely available.

p.p.s. here is another such list: http://www.fsf.org/resources/hw/net/wireless/cards.html


I am a translator!

Hors ligne
A rejoint: 02/16/2009

From what has been previously said in this forum, Intel wireless cards require proprietary firmware -their graphic cards do not-. In any case, wired connection, as jakel said, will most likely work.


I am a member!

I am a translator!

Hors ligne
A rejoint: 07/27/2010


Firstly, welcome to the boards. We refer to the Trisquel distro as a "GNU/Linux" project. Not simply as "linux" like most people do. The reasons are explored here (http://www.gnu.org/gnu/linux-and-gnu.html) but in short linux is just the kernel which allows the hardware to communicate with software. But linux alone is not an operating system. Sort of like how an engine is required for an automobile but the engine is not the same thing as a car. The GNU project provides the other pieces such as a compiler (gcc), desktop environment (GNOME), among many other things to complete the operating system.

Secondly, it has already been mentioned that unfortunately intel requires proprietary drivers. Check out the links Jackel provided. I had a similar problem when I moved into a new place to live that required wireless. I ended up buying a wireless USB card for $9.99 and I had no problem with it because I feel that my freedom was worth it and that is a small price to pay for it.

Good luck :)

Hors ligne
A rejoint: 10/22/2010

It may be a shot in the dark but have you tried turning off your acpi in the grub.
edit the /boot/grub/grub.cfg file and try adding:
ro quiet splash
If this does not work make sure to change it back to what it was, and note that if it does work let me know because you have to change some other file for it to work when your computer updates the kernel.
If the above does not work:
Do a lshw and see what your network wireless interface is so we can know exactly what your working with.

Hors ligne
A rejoint: 10/20/2010

Thank you everyone for your responses. I have an intel(4) wireless/pro 4965 ag or agn wireless network controller. I have been trying for the past day and a half to get ndiswrapper to work. I think there is a good chance that my drivers can be made to work in that way. Unfortunately, I have not been successful with ndiswrapper. This is due I believe to the -dev packages not be included in the base version of Trisquel. Nor does there appear to be a package that includes all of the dependencies required. For example. when using synaptic I try to install gcc; I get some filed dependencies and yet when I go look them up in synaptic I can find them but not install usually because they need gcc, I will keep at it today, but any help would be appreciated. By the way, I was able to get a wired connection over at my sister-in-law's house. That has made checking packages and download much easier. I was doing it with a USB key.

Hors ligne
A rejoint: 12/12/2010

Hello iceMan et al,

I tried ... 'acpi=off' ... - it did not do the trick.

My standard Ubuntu installs (Lucid and Maverick) both immediately detect wireless networks and report no proprietary drivers in use (via System/ Administration/ Additional Drivers).

(Machine: Toshiba R600 10q: Intel WiFi Link 5100)


Hors ligne
A rejoint: 05/13/2010

@K, drivers no, firmware yes. Read e.g. here.