XFCE install bug

3 réponses [Dernière contribution]
Christianity
Hors ligne
A rejoint: 10/09/2012

Hey guys, I tried using synaptic to add xfce4 and xfce4-goodies and I'm having problems, specifically with installing xfce4-session. The error is as follows:

E: /var/cache/apt/archives/xfce4-session_4.10.1-3ubuntu5_amd64.deb: trying to overwrite '/etc/xdg/autostart/xscreensaver.desktop', which is also in package trisquel-desktop-common-data 7.0-15

Can someone walk me through the install?

BugRep
Hors ligne
A rejoint: 04/05/2012

Here is a script that will hopefully fix your problem.
Download it, make it executable and run it from a console.

Related issue: https://trisquel.info/en/issues/7610

Fichier attachéTaille
xfce-fix-7.txt 863 octets
Christianity
Hors ligne
A rejoint: 10/09/2012

Thank you very much, that worked like a charm. This bug has been around for years though, why hasn't it been fixed?

BugRep
Hors ligne
A rejoint: 04/05/2012

I created a bug report in hope the bug will be fixed sooner. I didn't do it earlier because xfce4 that came with Trisquel 6 worked.

#12680: Can't install xfce4 - Conflict between xfce4-session and trisquel-desktop-common-data