Your Connection is not secure -- SSL error -- unknown issuer

Projet:Web
Composant:Main
Catégorie:Rapporter un bogue
Priorité:minor
Attribué:david
Statut:active
Description

Today I tried to access https://trisquel.info from Trisquel 7 which I have installed in a virtual machine (using QEMU/KVM) but I get the following error message[1] and cannot access the website using abrowser or Firefox (which I downloaded directry from the Mozilla website).

But I have no problem with accessing the website using Firefox (45.5.1) on Debian Testing.

[1]
OS: Trisquel 7
abrowser: 50.0.2
firefox: 50.0.2

error: unknown issuer

https://trisquel.info/

Peer’s Certificate issuer is not recognized.

HTTP Strict Transport Security: false
HTTP Public Key Pinning: false

dim, 12/11/2016 - 11:14

This is a screenshot.

Fichier attachéTaille
cOUaGjZ.png 96.45 Ko
lun, 12/12/2016 - 12:35
Statut:active» fixed

We installed new certificates this weekend (the old one was about to expire) and I kind of flunked the set-up. It should be fixed now, both here and at https://devel.trisquel.info, where there was also a mistake.

lun, 12/12/2016 - 13:34

It has been solved now. Thank you.

lun, 12/12/2016 - 14:09
Statut:fixed» active

I found that https://listas.trisquel.info is also not accessible but it is showing another error:


listas.trisquel.info uses an invalid security certificate.
The certificate is only valid for the following names:
devel.trisquel.info, packages.trisquel.info, trisquel.info
Error code: SSL_ERROR_BAD_CERT_DOMAIN

Fichier attachéTaille
BGGwEus.png 60.42 Ko
lun, 12/12/2016 - 21:03
Priorité:blocking» minor
Assigné à:anonymous» david
Statut:active» fixed

The certificate was not properly covering the listas.trisquel.info subdomain, it is now. It will also work for packages.trisquel.info when we secure that service with ssl (it's by now still using standard http).

mar, 12/13/2016 - 23:39
Statut:fixed» active

https://www.trisquel.info is not accessible.


www.trisquel.info uses an invalid security certificate.
The certificate is only valid for the following names:
devel.trisquel.info, listas.trisquel.info, packages.trisquel.info, trisquel.info
Error code: SSL_ERROR_BAD_CERT_DOMAIN

jeu, 12/15/2016 - 09:05

I will no longer risk saying that it's fixed now (but it should) :). The www subdomain has been added to the certificate to avoid failing the SSL check just before the redirection. Still pending work on packages.trisquel.info