lxde and xfce4 have missing/broken dependencies.

Projet:Trisquel
Version:8.0
Composant:Packages
Catégorie:Tâche
Priorité:normal
Attribué:Non assigné
Statut:active
Description

lxde requires lxpanel.

I tried to install lxpanel from a deb file but it is missing at least lxpanel-data. I stopped there.

xfce requires libxfce4ui-1-0, libxfce4ui-2-0, and libxfce4ui-utils.

I'm confused about libxfce4ui-2-0 because it is not in Debian 8, but apt says it's a dependency of xfce4-pulseaudio-plugin, which is a dependency of xfce4.

I tried to install libxfce4ui-1-0 and libxfce4ui-utils from deb files but they are missing at least libxfce4util6. I stopped there.

Sam, 12/09/2017 - 03:59

I updated my Trisquel 7 that uses LXDE to Trisquel 8 and LXDE seems to be working fine. I have lxpanel installed; lxpanel-data does not appear to be listed as a dependency.

mer, 12/20/2017 - 21:37

Perhaps lxpanel is left over from when you installed it in Belenos.$ sudo apt update && sudo apt install lxpanelgives mePackage lxpanel is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source
E: Package 'lxpanel' has no installation candidate