sysinfo crashes when trying to view "System" section (other sections work ok)

Catégorie:Rapporter un bogue
Attribué:Non assigné

Installed sysinfo from Trisquel 8/Flidas repositories: sudo apt install sysinfo

Program starts up but will not display the "System" section - crashes and closes itself when this section is selected.

I tried this on two (very) different systems, an HP laptop with a Pentium/Atom processor and on an X79 Xeon server; same results with both.

Running "sysinfo" from the command line (in order to see its output) reveals the following when the user clicks on the "System" section:

Exception in Gtk# callback delegate
Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
System.NullReferenceException: Object reference not set to an instance of an object
at Sysinfo.SystemInfo.Gnome () <0x41980d20 + 0x000a8> in :0
at Sysinfo.Sysinfo.on_notebook1_switch_page (System.Object o, Gtk.SwitchPageArgs e) <0x4197a5c0 + 0x0011b> in :0
at Gtk.Notebook.SwitchPageSignalCallback (IntPtr arg0, IntPtr arg1, UInt32 arg2, IntPtr gch) <0x41979da0 + 0x002f7> in :0
at GLib.ExceptionManager.RaiseUnhandledException (System.Exception e, Boolean is_terminal) [0x00000] in :0
at Gtk.Notebook.SwitchPageSignalCallback (IntPtr arg0, IntPtr arg1, UInt32 arg2, IntPtr gch) [0x00000] in :0
at Gtk.Notebook.gtk_notebook_set_current_page (IntPtr , Int32 ) [0x00000] in :0
at Gtk.Notebook.set_CurrentPage (Int32 value) [0x00000] in :0
at Sysinfo.Sysinfo.on_treeview1_cursor_changed (System.Object o, System.EventArgs e) [0x00000] in :0
at System.Reflection.MonoMethod.InternalInvoke (System.Reflection.MonoMethod , System.Object , System.Object[] , System.Exception& ) [0x00000] in :0
at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] in :0
at System.Reflection.MethodBase.Invoke (System.Object obj, System.Object[] parameters) [0x00000] in :0
at System.Delegate.DynamicInvokeImpl (System.Object[] args) [0x00000] in :0
at System.MulticastDelegate.DynamicInvokeImpl (System.Object[] args) [0x00000] in :0
at System.Delegate.DynamicInvoke (System.Object[] args) [0x00000] in :0
at GLib.Signal.ClosureInvokedCB (System.Object o, GLib.ClosureInvokedArgs args) [0x00000] in :0
at GLib.SignalClosure.Invoke (GLib.ClosureInvokedArgs args) [0x00000] in :0
at GLib.SignalClosure.MarshalCallback (IntPtr raw_closure, IntPtr return_val, UInt32 n_param_vals, IntPtr param_values, IntPtr invocation_hint, IntPtr marshal_data) [0x00000] in :0
at Gtk.Application.gtk_main () [0x00000] in :0
at Gtk.Application.Run () [0x00000] in :0
at Sysinfo.Sysinfo..ctor (System.String[] args) [0x00000] in :0
at Sysinfo.Sysinfo.Main (System.String[] args) [0x00000] in :0

Upstream sysinfo bug #9 addresses this, posting a possible patch to fix the issue:

sam, 12/01/2018 - 08:20

I'm getting the same error. Alternatives, such as Hardinfo, work fine.

sam, 01/15/2022 - 00:23
Statut:active» closed

Trisquel 8.0 support ended in April 2021.
Please open a new issue in case it remains on the current supported