"apt-get build-dep network-manager" fails

Projet:Trisquel
Version:8.0
Composant:Packages
Catégorie:Rapporter un bogue
Priorité:normal
Attribué:Non assigné
Statut:active
Description

When I run "apt-get build-dep network-manager" it aborts with this:

The following packages have unmet dependencies:
builddeps:network-manager : Depends: libgnutls-dev but it is not
going to be installed

and when I run "apt-get install libgnutls-dev" it gives this error:

The following packages have unmet dependencies:
libgnutls-dev : Depends: libgnutls30 (= 3.4.10-4ubuntu1.4) but
3.5.18-1ubuntu1+8.0trisquel1 is to be installed

1) The only repository listed in /etc/apt/ here that is not
trisquel/flidas is the one for google chrome,

2) I did run "apt-get update; apt-get upgrade",

3) "aptitude search '?obsolete'" doesn't report any obsolete packages,

4) I discussed this in the #trisquel IRC channel and joepublic got the
same errors in his machine when he tried to install these
build-deps and then libgnutls-dev with apt-get.

mar, 01/22/2019 - 00:15

I'm not sure where libgnutls30 3.5.18-1ubuntu1+8.0trisquel1 came from, as I don't see a package helper for libgnutls30.

https://devel.trisquel.info/trisquel/package-helpers/tree/flidas/helpers

On my system, I have multiple versions of libgnutls30 available

$ apt policy libgnutls30
libgnutls30:
Installed: 3.5.18-1ubuntu1+8.0trisquel1
Candidate: 3.5.18-1ubuntu1+8.0trisquel1
Version table:
*** 3.5.18-1ubuntu1+8.0trisquel1 500
500 https://archive.trisquel.info/trisquel flidas-updates/main amd64 Packages
100 /var/lib/dpkg/status
3.4.10-4ubuntu1.3 500
500 https://archive.trisquel.info/trisquel flidas-security/main amd64 Packages
3.4.10-4ubuntu1 500
but none of these is 3.4.10-4ubuntu1.4, the version required by libgnutls-dev. There is the same problem with libgnutls-openssl27 and libgnutlsxx28. I'm not sure what's going on, but here's a workaround:

EDIT: You probably shouldn't do this. It caused some problems with another package on my system.

$ sudo apt install libgnutls30=3.4.10-4ubuntu1.3 libgnutls-openssl27=3.4.10-4ubuntu1.3 libgnutlsxx28=3.4.10-4ubuntu1.3
$ apt download libgnutls-dev
$ ar x libgnutls-dev_3.4.10-4ubuntu1.4_amd64.deb
$ tar -xzf control.tar.gz
$ sed 's/4ubuntu1\.4/4ubuntu1\.3/g' -i control
$ tar -czf control.tar.gz control
$ ar rcs newpackage.deb debian-binary control.tar.gz data.tar.xz
$ sudo gdebi newpackage.deb