python-pygame backport leaked to updates

Projet:Trisquel
Version:9.0
Composant:Packages
Catégorie:Rapporter un bogue
Priorité:normal
Attribué:Ark74
Statut:fixed
Description

Trisquel package "python-pygame" cannot be installed because it is version 1.9.6 (1.9.6+dfsg-2build1+9.0trisquel2) and depends on non-existing package "python2".

It looks like it is taken from Ubuntu focal package which is version 1.9.6 as well and there is a package "python2".

Please update Trisquel repository with Ubuntu bionic package which is version 1.9.1 and depends on right package "python".

dim, 09/12/2021 - 05:13

I was trying to install the tux magicor game and I encounter this issue as well. I was able to temporatly solve it by forcing 1.9.6 installation and lock the version using synaptic.

ven, 09/17/2021 - 21:04
Titre:Error installing package python-pygame» python-pygame backport leaked to updates

That seems like it has been a mistake, where the package accidentally ended up in the regular repo, when it should have ended up in backports:

apt list python-pygame -a

python-pygame/etiona-updates 1.9.6+dfsg-2build1+9.0trisquel2 amd64
python-pygame/etiona-backports 1.9.6+dfsg-2build1+9.0trisquel1 amd64
python-pygame/etiona 1.9.1release+dfsg-10build1 amd64

I'm not sure how to solve it without possibly breaking the upgrade to trisquel 10, but I'll take it to the next dev meeting.

In the meantime you can fix the issue installing it like this:

sudo apt-get install python-pygame=1.9.1release+dfsg-10build1

mer, 11/24/2021 - 12:10
Assigné à:anonymous» Ark74
Statut:active» fixed

fixed by version 1.9.6+dfsg-2build1+9.0trisquel3