Anomalies depuis une upgrade de Trisquel 6.1

7 Antworten [Letzter Beitrag]
Mimmo_D.DN

I am a translator!

Offline
Beigetreten: 02/24/2013

Bonjour à tous'tes,

Depuis une récente upgrade vers Trisquel 6.0.1 (toutatis) 32 bits, j'ai quelques soucis de comportements assez étranges.

Parfois le mulot ne répond plus aux click gauche ou droit, pourtant il répond aux mouvements, parfois c'est la barre des menus qui ne réponds plus, parfois ce sont les applications en cours qui se figent, dans ce cas je ne peux qu'utiliser les raccourcis clavier [Ctrl + Q] pour fermer les applications ou [Alt + Impr Ecran + B] pour redémarrer car plus rien ne réponds.

Cela se produit sur un noyau Linux 3.2.0-67-generic-pae / GNOME 3.4.2

Avant de déposer un ticket et faire un rapport d'état j'aimerais savoir si d'autres Trisquel Users rencontrent ce type de comportement...

Bien Librement.

Magic Banana

I am a member!

Offline
Beigetreten: 07/24/2010

Je ne fais pas face à de tels problèmes. Lorsque tu as un soucis qui est seulement lié à la session graphique, tu peux passer à un véritable terminal avec Ctrl+Alt+F1. Là, tu te connectes puis tu exécutes la commande suivante :
$ sudo service gdm restart

Tu retombes ainsi sur l'écran de connexion graphique (sans avoir redémarré le système).

Maintenant, pour comprendre l'origine du problème et y palier, il faudrait lire les logs juste après que le problème ait lieu. Les logs sont dans /var/log. Il se peut néanmoins que le problème soit matériel. As-tu testé ta mémoire vive avec memtest86+ (que tu trouves dans le dépôt Trisquel et qui se lance depuis le chargeur de démarrage) ?

Mimmo_D.DN

I am a translator!

Offline
Beigetreten: 02/24/2013

J'étais en train de répondre quand cette bizarrerie s'est reproduite :[ désolé!

Si je redémarre simplement la session le problème persiste, pour reprendre la main il faut un boot complet :?

Je n'ai pas testé la mémoire vive, mais je vais m'empresser de voir ça dès que j'ai un peu de temps à accorder au processus de test...

En parlant de mémoire en lisant un log je constate que certains processus (Abrowser, Thunderbird) s'emballent, une sorte de fuite mémoire :? pourtant je n'ai ouvert que gedit pour lire les fichiers...

Bon, verrai ça plus en détail après le memtest...

Merci pour ta réponse; ^_^

Magic Banana

I am a member!

Offline
Beigetreten: 07/24/2010

Des problèmes bizarres qui surviennent de façon aléatoire sont souvent le signe d'une RAM défaillante.

Mimmo_D.DN

I am a translator!

Offline
Beigetreten: 02/24/2013

Bon ben, après un loooong processus, le memtest86 n'a décelé aucune défectuosité sur le RAM :]

Alors si le RAM n'est pas défaillant, on peut alors considérer une certaine insuffisance du matériel, j'ai du mal à croire que cette config. (P4 3G x2 - 1G de RAM) n'est plus apte à supporter cette version de Trisquel.

Mais en même temps quand je vois la quantité de RAM utilisé par le couple d'outils clients, messagerie et fureteurs, qui à eux seuls monopolisent près de 500 Mio, alors que l'ensemble des processus système ne totalisent qu'à peine 120 Mio, je trouve que c'est outrageusement exigent :[

Magic Banana

I am a member!

Offline
Beigetreten: 07/24/2010

Il se peut qu'une page Web moisie demande toujours plus de RAM. Mais, en supposant que tu as du swap, le premier symptôme serait un net ralentissement du système (qui continue néanmoins à faire ce qu'on lui demande). De plus, tu aurais probablement compris quelle page Web crée le problème (rien d'aléatoire).

1 Gio de RAM, ce n'est bas Byzance mais cela devrait bien suffire tant que tu ne cherches pas à faire tourner LibreOffice en lisant des pages Web pleines de JavaScript sur Abrowser, en regardant un film HD sur Totem, etc.

Il te faut accéder aux logs juste après le problème et voir si quelque chose de curieux s'y trouve. Tu peux joindre ces logs à un message sur le forum.

Mimmo_D.DN

I am a translator!

Offline
Beigetreten: 02/24/2013

Il se peut qu'une page Web moisie demande toujours plus de RAM.

C'est plausible, je vais scruter les sources des différents domaines ou j'interagis, histoire de voir si on n'aurait pas volontairement omis quelques objets embarqués :?

1 Gio de RAM, ce n'est bas Byzance mais cela devrait bien suffire tant que tu ne cherches pas à faire tourner LibreOffice en lisant des pages Web pleines de JavaScript sur Abrowser, en regardant un film HD sur Totem, etc.

:/ ... :[) Oui le mélange des genres très RAMivores,

Il te faut accéder aux logs juste après le problème et voir si quelque chose de curieux s'y trouve. Tu peux joindre ces logs à un message sur le forum.

Ok! j'allons voir ça, Merci...

Mimmo_D.DN

I am a translator!

Offline
Beigetreten: 02/24/2013

Résolu!, effectivement tu as vu juste, sur ce poste je sollicitais manifestement un peu trop les ressources disponibles, surtout la mémoire physique.

Après avoir reproduit les conditions, et préalablement activé le monitoring, j'active les outils Geany (en mode projet) + Abrowser en mode édition (Framapad) + client mail, sans oublier les processus système, l'interface montre déjà des signes de sérieux ralentissements, le monitoring du secteur RAM et Swap est full, je n'ai même pas pris la peine d'activer Pidgin et Liferea...

En tout cas rien à voir avec Trisquel :]

Bien Librement.