Bulle de notifications d'abrowser

2 Antworten [Letzter Beitrag]
Ker Tris
Offline
Beigetreten: 05/27/2016

Bonjour,

Depuis quelques temps, abrowser me demande un peu trop si je veux recevoir des notifications de certains sites que je visite : à chaque page ouverte ou rechargée.

J'ai le choix entre "recevoir des notifications pour cette session" ou "plus tard" (ce dernier étant aussi utile que la petite croix pour fermer la bulle).

J'ai aussi un lien vers la page "push" pour en savoir plus, mais c'est redirigé vers une page inexistante sur trisquel.info.

Avez-vous, vous aussi cette bulle envahissante ? Je trouve que ce n'est pas très pertinent un bulle qui n'est présente que pour recevoir une réponse positive.

Magic Banana

I am a member!

Online
Beigetreten: 07/24/2010

C'est cette page de documentation que tu ne vois pas (un problème dans le remplacement automatique des liens vers les sites de Mozilla qui proposent parfois l'installation de logiciel privateur) : https://support.mozilla.org/t5/Bases-de-la-navigation/Les-notifications-Web-Push-dans-Firefox/ta-p/35987#firefox:linux:fx51

Tu peux modifier les autorisations de notifications données à un site en cliquant sur le "i" suivi du cadenas tout à gauche de la barre d'adresse. Une des permissions possibles est "Recevoir des notifications". Vois https://support.mozilla.org/t5/Protection-de-votre-vie-priv%C3%A9e/Centre-de-contr%C3%B4le-g%C3%A9rer-les-commandes-de-vie-priv%C3%A9e-et-de/ta-p/28520#firefox:linux:fx51

Sinon pour gérer toutes les permissions données à tous les sites, clique sur le bouton "menu" (avec trois traits horizontaux) puis "Préférences". Dans l'onglet "Contenu", tu peux "Choisir..." de supprimer la permission donnée à un site (ou à tous) de t'envoyer des notifications.

Pour ne plus avoir la moindre de demande de permission pour t'envoyer des notifications, tape "about:config" dans la barre d'adresse, promets de faire attention (si la page te le demande) et met les options 'dom.push.enabled" (seulement les notifications push) et "dom.webnotifications.enabled" (toutes les notifications) à "false" en double-cliquant dessus. Il y a aussi "dom.webnotifications.serviceworker.enabled" que tu peux mettre à "false" (mais je suppose que ce n'est pas nécessaire une fois "dom.webnotifications.enabled" à "false").

Ker Tris
Offline
Beigetreten: 05/27/2016

[RÉSOLU]

Merci !

1) Le temps que je revienne pour voir la réponse, les liens ne sont plus valides.

2) C'est la dernière partie de ta réponse qui m'intéressait (une règle globale par défaut). C'est "dom.webnotifications.enabled" à "false" qui m'offre le comportement souhaité (en espérant que ça ne bloque pas d'autres choses qui m'intéresse). Concernant "dom.push.enabled" et "dom.webnotifications.enabled" je ne sais pas ce que ça fait, mais les notifications dont je parlais apparaissaient toujours.

3) Je trouve dommage que la notification ne permette pas de choisir "NE PAS recevoir de notification pour cette session". Mais ce n'est pas ici qu'il faut que j'en parle... ^^