Comment installer un paquet d'une version plus récente que celui disponible sur les dépôts par défaut ?

2 Antworten [Letzter Beitrag]
Ker Tris
Offline
Beigetreten: 05/27/2016

Bonjour,

Il semble que la version de fastboot disponible dans les dépôts de Trisquel7 soit trop ancienne pour répondre à mon besoin, comment puis-je installer la version disponible dans les dépôts de Trisquel8 (ou une version plus récente que la 4.2.2), svp ?

Magic Banana

I am a member!

Offline
Beigetreten: 07/24/2010

Je prendrais le dernier binaire chez Google : https://dl.google.com/android/repository/platform-tools-latest-linux.zip

Si tu tiens à un paquet .deb non compilé par Google (qui est auteur de fastboot mais qui pourrait ajouter du malware dans le binaire), tu peux en télécharger un depuis https://packages.ubuntu.com/search?fastboot et l’installer avec 'sudo dpkg -i' ou, après avoir installé GDebi (depuis le gestionnaire de paquets), en double cliquant sur le fichier .deb. Tu risques néanmoins de rentrer pas dans l’« enfer des dépendances » (le paquets dépend d’autres paquets qui ne sont pas dans le dépôt de Trisquel 7 mais que tu peux trouver sur https://packages.ubuntu.com … ne va jamais jusqu’à mettre à jour des bibliothèques fondamentales comme libc6 !).

Ker Tris
Offline
Beigetreten: 05/27/2016

Merci, pour tes explications, j'ai tout compris. Plutôt que de pourrir mon ordi et me casser la tête, je vais essayer de voir avec deux amis qui sont sous macOS ou essayer de trouver un ordi pour installer Debian. Avec Win7, c'est la plaie aussi...

Je garde tes 2 solutions en dernier recours.