Disable middle click paste

3 Antworten [Letzter Beitrag]
IBM1130
Offline
Beigetreten: 09/24/2020

Does anyone know how to disable middle-click paste in Trisquel 9.0?

Thanks!

lanun
Online
Beigetreten: 04/01/2021

I naively thought that sending these commands should do it:

gsettings set org.gnome.desktop.interface gtk-enable-primary-paste false
gsettings set org.mate.peripherals-mouse middle-button-enabled false

We should alternatively be able to use the Dconf editor and uncheck the corresponding entries (for the second one, the actual path in the Dconf tool is /org/mate/desktop/peripherals/mouse. For some reason the gsettings path is different).

However, none of these seemed to work on my Trisquel 9 system: the middle-click will keep pasting whatever is currently selected.

This answer seems to have made many middle-click users happy, but I did not have time to try it myself yet:
https://unix.stackexchange.com/questions/24330/how-can-i-turn-off-middle-mouse-button-paste-functionality-in-all-programs/277488#277488.

IBM1130
Offline
Beigetreten: 09/24/2020

Thank you. On my end this behavior began recently- possibly after I upgraded to 9.0.

As a workaround:

Icedove-> preferences-> Config Editor-> "accept the dire risk" -> search for "middlemouse" and change the option to False.

LibreOffice: Tools-> Options ->View -> [look near the bottom] Middle Mouse Button -> No function.

lanun
Online
Beigetreten: 04/01/2021

Good to know, thanks.

I guess most users will not need to deactivate it globally anyway.

I seldom use the middle-button myself, so I cannot tell for sure, but it might indeed have come with T9 and the corresponding Gtk and MATE versions. I hear that the option to deactivate it has been made available directly in Control Center > Mouse settings in more recent versions of MATE shipping with Ubuntu 20, so it will probably make it to Trisquel 10.