Disque home saturé et absence de permissions pour modifier le dd

20 Antworten [Letzter Beitrag]
Courriernord
Offline
Beigetreten: 07/06/2018

Bonjour

ma partition home est saturée, mais elle n'est que de 20 gigas et le dd est de 460
le système occupe quant à lui 16 gigas.
reste plus de 400 gigas qui ne servent à rien
lorsque je clique sur le volume de 460 gg, j'obtiens : Impossible d'analyser le dossier « /media/guillaume/48868d5a-6c5c-4931-9cda-1e0f6e5210d9 » ou certains de ces sous-dossiers
permissions non accordées

je suis débutant en linux : comment est ce que je peux augmenter la taille de la partition home ou mettre des éléments autre parts, sur d'autres partitions ?

Courriernord
Offline
Beigetreten: 07/06/2018

voilà ce que donne gparted :
Je voudrais utiliser la partition dev/sda3 pour mettre du contenu dessus : comment faire ?

[url=http://zupimages.net/viewer.php?id=18/31/t9zq.png][img]https://zupimages.net/up/18/31/t9zq.png[/img][/url]

gpartedCapture du 2018-08-03 13:16:08.png
Magic Banana

I am a member!

Online
Beigetreten: 07/24/2010

Veux-tu sauvegarder le contenu de /dev/sda3, la détruire et étendre /dev/sda2 puis /dev/sda6 sur tout l’espace ainsi libéré ? Si c’est le cas, tu peux faire tout cela avec GParted depuis un système Live (comme celui que tu as dû utiliser pour installer Trisquel).

Maintenant si tout ce que tu veux c’est monter /dev/sda3 à l’init et que les utilisateurs puissent y lire/écrire ce qu’ils veulent (peut-être sans pouvoir modifier/supprimer ce qu’un autre utilisateur à créer), alors il n’y a qu’un répertoire de montage à créer (à moins que tu veuilles utiliser un répertoire existant) et qu’une ligne à ajouter à /etc/fstab.

nmrk.n
Offline
Beigetreten: 11/01/2013

Bienvenue,

Je ne vois pas de volume de 460 Gio.

"Impossible d'analyser le dossier « /media/guillaume/48868d5a-6c5c-4931-9cda-1e0f6e5210d9 » ou certains de ces sous-dossiers
permissions non accordées"

Pour travailler sur les partitions (suppression, déplacement, modification de taille) il faut que celles-ci soient démontées et que tu lances gparted en tant qu'administrateur.

Pour travailler sur la partition /home il faut le faire à partir d'une autre distribution, par exemple une Live sur CD/DVD/Clé_USB ou en étant connecté en simple (unique) utilisateur administrateur, /home étant démontée.

Pour seulement définir une autre partition comme partition /home :

Note les UUID des partitions sda6 et sda3

Pour cela, dans une console :

$ sudo blkid [Touche Entrée]

Dans le fichier /etc/fstab remplace l'UUID de sda6 par celui de sda3.

(si les UUID ne sont pas utilisés remplace sda6 par sda3)

Comme il n'y aura aucun utilisateur dans cette configuration il faudra alors créer un nouvel utilisateur dont le répertoire personnel sera sur la nouvelle partition /home

Il se peut que tu n'aies pas accès à l'interface graphique, il faudra le faire en console en tant que root.

Voir § "Comment devenir un super utilisateur" :

https://trisquel.info/fr/wiki/introduction-%C3%A0-linterface-en-lignes-de-commandes

Puis recopie les fichiers de l'ancien /home dans le nouveau /home sans oublier les fichiers cachés à la racine de ton répertoire personnel (tu auras, c'est indispensable, fait une sauvegarde préalable sur un autre support).

Je ne suis probablement pas très clair et je peux oublier des choses importante, profites-en pour te documenter en attendant d'autres avis sur ce forum.

@+

Courriernord
Offline
Beigetreten: 07/06/2018

Bonjour
je viens de voir vos réponses

j'ai un autre problème, je dois systématiquement demander un nouveau mot de passe pour me connecter sur ce forum...
si vous savez d'où ça peut venir ? avant que je ne poste un nouveau message pour corriger ça ...

sinon
banana, effectivement tout ce que je voudrais c'est pouvoir écrire sur ce sd3... ça me suffirait amplement
mais je ne comprends pas comment faire ce que tu dis. j'ai besoin de conseils un peu plus précis.

"il n’y a qu’un répertoire de montage à créer (à moins que tu veuilles utiliser un répertoire existant) et qu’une à ajouter à /etc/fstab."

nmrk ce que tu dis est précis... je peux essayer, mais s'il y a une procédure pour simplement pouvoir utiliser ce disque ça m'ira très bien

je n'ai jamais utilisé gparted pcque je n'ai pas installé moi meme trisquel, j'ai acheté l'ordinateur comme ça et je ne comprends pas pourquoi le fichier home n'a pas été étendu à l'ensemble du disque dur...

au pire je peux utiliser gparted, mais je ne me sens pas de faire des sauvegardes...

bref qu'est ce que je peux essayer à votre avis pour pouvoir utiliser sd3 de plus simple ?
sinon j'essaierai de définir sd3 comme home... ça me semble une bonne solution.

merci

Magic Banana

I am a member!

Online
Beigetreten: 07/24/2010

banana, effectivement tout ce que je voudrais c'est pouvoir écrire sur ce sd3... ça me suffirait amplement
mais je ne comprends pas comment faire ce que tu dis. j'ai besoin de conseils un peu plus précis.

Bien sûr. Je voulais d’abord m’assurer qu’il s’agissait bien de ce que tu souhaitais. Voilà des instructions pour que /dev/sda3 soit monté à l’init dans un dossier nommé « data », dans /home (le dossier parent des dossiers personnels des utilisateurs), où un utilisateur n’a la permission de modifier/renommer/supprimer que ce qu’il a lui-même créé :

  1. Lance le « Terminal MATE » (ou n’importe quel autre émulateur de terminal installé), par exemple en le cherchant dans le menu principal (je crois qu’il est dans la catégorie « Accessoires »);
  2. Crée le dossier /home/data avec les permissions comme expliquées ci-dessus, en exécutant la commande suivante dans le terminal ('sudo' te demandera ton mot de passe; il est normal qu’aucun caractère ne s’affiche pendant que tu le lui tapes) :$ sudo mkdir -m 1777 /home/data
  3. Ajoute la ligne à /etc/fstab qui montera, à l’init, /dev/sda3 sur /home/data :$ echo '/dev/sda3 /home/data ext4 defaults,mode=1777 0 0' | sudo tee -a /etc/fstab
  4. Redémarre le système.

Quelques précisions si tu n’as pas l’habitude des terminaux :

Attention aux commandes que tu exécutes ! 'sudo' te laisse littéralement faire tout et n’importe quoi. Y compris détruire ton système ! En particulier, oublier l’option "-a" à 'tee' (dans la seconde commande) signifierait la perte du contenu de ton /etc/fstab (remplacé par la ligne qui suit 'echo'). il est plus sûr de copier-coller les commandes. Soit en sélectionnant la commande puis en utilisant le clic milieu sur la fenêtre de l’émulateur de terminal, soit en copiant avec Ctrl+C (ou en sélectionnant puis en choisissant « Copier » dans le menu contextuel qui s’affiche d’un clic droit sur la sélection) et en collant dans l’émulateur de terminal avec Ctrl+Shift+V (ou en choisissant « Coller » dans le menu contextuel qui s’affiche d’un clic droit sur la fenêtre de l’émulateur de terminal). Le "$" qui précède chaque commande que je t’ai écrite ne fait pas parti de la commande. Il veut dire : « à taper dans un terminal ». Une commande qui n’écrit rien est une commande qui s’est exécutée sans problème.

je ne me sens pas de faire des sauvegardes...

Ce que je te propose de faire ne présente pas de risque pour tes données… mais sauvegarder est essentiel ! Les disques meurent, les portables tombent, se font voler, sont rangés dans des pièces qui peuvent être incendiées ou inondées, des fichiers sont supprimés par erreur, etc. Si tu n’en as pas encore, acquiers donc un gros disque dur externe (HDD, pas SSD), branche-le et lance « Sauvegardes » (dans le menu principal ou dans le « Centre de contrôle ») : il te suffit de choisir le disque dur externe comme « Emplacement de stockage » et de démarrer la sauvegarde : cinq clics en tout. Une sauvegarde par semaine n’est pas de trop et tu peux demander une notification avec cette fréquence dans « Planification ». Cette application est intégrée au navigateur de fichiers, dont le menu contextuel permet de « Revenir à la version précédente » d’un fichier/dossier (clic droit sur le fichier/dossier) ou la « Restauration des fichiers manquant » (clic droit dans le blanc de la fenêtre).

Courriernord
Offline
Beigetreten: 07/06/2018

Bonjour Banana
j'ai entré les deux lignes de code que tu m'as écrites puis j'ai relancé le système

à l'allumage j'obtiens :
"Appuyer sur S pour passer le montage ou sur M pour la récupération manuelle"

si j'appuie sur S ça démarre mais je n'ai pas plus accès qu'avant à Sd3

Si j'appuie sur M j'obtiens ceci :
file systme check or mount failed
A maintenance shell will now be started.
CONTROL-D will terminate this shell and continue booting after re-trying
root@guillaume-HP-Compaq-Pro-6300-SFF:~#

et j'ai réussi à m'en sortir en tapant plusieurs fois ctrl D, je crois
du coup, je suis un peu embêté

pour la sauvegarde j'ai fait comme tu m'as dit, c'est pratique, je n'avais jamais utilisé la sauvegarde automatique, je me traine des dizaines de disques durs que j'ai la flemme de trier

Magic Banana

I am a member!

Online
Beigetreten: 07/24/2010

Pourrais-tu mettre en pièce jointe ton fichier /etc/fstab (dont la dernière ligne devrait être exactement "/dev/sda3 /home/data ext4 defaults,mode=1777 0 0") ? Il s’agit du fichier nommé « fstab » qui se situe dans le dossier « etc » qui est à la racine de ton arborescence de fichiers.

Aussi, vérifions le point de montage. La commande suivante devrait écrire "1777" :
$ stat -c %a /home/data/
Est-ce le cas ? Si ce n’est pas le cas, qu’écrit-elle ?

Nous pourrions aussi jeter un œil aux lignes du journal du système qui parlent de montage de systèmes de fichiers :
$ journalctl -b | grep -i mount

Note : tu peux copier du texte sélectionné dans l’émulateur de terminal depuis le menu contextuel ou avec Ctrl+Shift+C ou simplement le sélectionner et utiliser le clic milieu pour le coller.

Courriernord
Offline
Beigetreten: 07/06/2018

je ne parviens pas à joindre le fichier dont tu parles en pièce attachée
le voici en copié collé

comment tu fais pour citer du code sur ce forum ?

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
#
# / was on /dev/sda1 during installation
UUID=9acd7ee5-5c94-43b4-afe9-fd9c0eab8866 / ext4 relatime,errors=remount-ro 0 1
# /home was on /dev/sda6 during installation
UUID=4610fb2a-7022-4d5b-b5c4-d70fba374fbc /home xfs relatime 0 2
# swap was on /dev/sda5 during installation
UUID=0e79a4bc-5efc-45d3-ac35-77c369351823 none swap sw 0 0
/dev/sda3 /home/data ext4 defaults,mode=1777 0 0

[code] stat -c %a /home/data/ [/code]

la réponse est bien 1777

journalctl -b | grep -i mount
réponse introuvable

merci

Magic Banana

I am a member!

Online
Beigetreten: 07/24/2010

Malgré l’absence de journal pour nous aider (ou est-ce parce que tu utilises Trisquel 7, sans 'journalctl', et non Trisquel 8 ?), je crois avoir trouvé mon erreur : d’après 'man mount', « mode » n’est pas une option des systèmes de fichiers de type ext4. Aussi, je me rends compte en lisant 'man fstab' que le dernier champ devrait être « 2 » (pour une vérification après le système de fichiers racine) et non « 0 » (aucune vérification) pour la ligne que je t’ai fait ajouter. Bref :

  1. Ouvre donc un éditeur de texte (ici Pluma, par défaut dans Trisquel 8) avec les droits d’administration (ici conférés par 'gksu') :$ gksu pluma /etc/fstab
  2. Modifie la dernière ligne de /etc/fstab pour qu’elle devienne :/dev/sda3 /home/data ext4 defaults 0 2
  3. Enregistre le fichier modifié.
  4. Redémarre.
Courriernord
Offline
Beigetreten: 07/06/2018

bonsoir

effectivement j'utilise Trisquel 7 lequel m'a proposé de passer à trisquel 8...
mais ça n'a pas fonctionné
j'ai voulu faire une copie d'écran pour la montrer sur le forum, mais ça s'est éteint et je ne sais plus
j'essaierai ta manip demain
je crois qu'il faudra que j'installe pluma, j'ai jamais entendu parler...

Magic Banana

I am a member!

Online
Beigetreten: 07/24/2010

J’ai choisi Pluma parce que c’est ce qui vient par défaut avec Trisquel 8. Mais puisque tu as Trisquel 7, qui a GEdit (un autre éditeur de texte) installé par défaut, remplace « pluma » par « gedit » dans la première ligne de commande : n’importe quel éditeur de texte fait l’affaire.

Courriernord
Offline
Beigetreten: 07/06/2018

coucou

on y est presque
enfin j'espère ;-)

plus de problèmes à l'allumage

lorsque je fais sur Gparted, j'observe que Sd3 est monté sur home/data
donc je vais dans l'arborescence sur home data, mais je n'y ai pas accès.
"Vous n'avez pas les permissions nécessaires pour afficher le contenu de data"
sur l'icone "data" il y a une petite croix qui indique que l'accès est interdit.

Magic Banana

I am a member!

Online
Beigetreten: 07/24/2010

Vu les permissions sur le dossier, je ne comprends pas le problème. Mettons donc les permissions « classiques » sur /home/data :
$ sudo chmod 755 /home/data
Si tu es le seul utilisateur de ce dossier, je te propose de devenir propriétaire de /home/data :
$ sudo chown $USER:$USER /home/data
S’il y a plusieurs utilisateurs, crée plutôt un sous-dossier portant ton nom et deviens son propriétaire :
$ sudo mkdir /home/data/$USER
$ sudo chown $USER:$USER /home/data/$USER

Fais de même pour les autres utilisateurs du système, en remplaçant, dans les deux lignes de commandes, $USER par le login de l’utilisateur (les noms des dossiers dans /home, que tu peux lister avec la commande 'ls /home', en ignorant « data », bien sûr). Un redémarrage plus tard, cela fonctionne-t-il ?

Courriernord
Offline
Beigetreten: 07/06/2018

EUH...
je ne veux pas me planter comme il y a sudo

$ sudo chown $USER:$USER /home/data

dans cette commande
les deux USER sont à remplacer par mon nom guillaume, c'est bien ça ?
en minuscules comme c'est inscrit là : guillaume@guillaume-HP-Compaq-Pro-6300

?

Magic Banana

I am a member!

Online
Beigetreten: 07/24/2010

« guillaume » étant l’utilisateur connecté, l’interpréteur de commande (le « shell ») remplace $USER par « guillaume ». Bref, tu pouvais littéralement écrire "$USER". C’est pour les autres utilisateurs qu’il faut substituer par leurs logins.

Courriernord
Offline
Beigetreten: 07/06/2018

Ca y est !

simplement en mettant les permissions « classiques » sur /home/data :
$ sudo chmod 755 /home/data

et en rallumant, ça fonctionne...

je n'ai pas voulu aller plus loin sans confirmation.

merci bien

j'aimerais bien arriver à comprendre ce que je tape en ligne de commande, maintenant...
et à en créer quelques unes
j'ai regardé des cours en ligne, mais comme je ne l'utilise pas j'oublie

Magic Banana

I am a member!

Online
Beigetreten: 07/24/2010

Tu peux écrire dans /home/data sans être son propriétaire (avec 'sudo chown $USER:$USER /home/data') ? Ce ne devrait pas être le cas en « 755 ».

« 755 » est une façon quelque peu obscure (mais brève) d’exprimer les permissions du propriétaire (premier chiffre, le propriétaire est avant ":", en argument de 'chown' qui signifie « change owner »), des utilisateurs du groupe (deuxième chiffre, le groupe est après ":", en argument de 'chown'; il existe aussi 'chgrp') et des autres utilisateurs (dernier chiffre). Les trois chiffres en question sont en fait les versions décimales de trois nombres binaires (c’est-à-dire avec seulement 0 et 1 comme chiffres) à trois chiffres, pour trois types de permission : lire, écrire et exécuter (mais, pour un dossier, il s’agit en fait du droit de traverser le dossier). Ainsi, comme 7 (en décimal) = 111 (en binaire), 7 donne tous les droits (au propriétaire si 7 est le premier chiffre, comme dans 755). 5 (en décimal) = 101 (en binaire) donne le droit de lire (premier 1) et de traverser le dossier (dernier 1) mais pas d’écrire. Avec 755, ce sont les droits de tous sauf du propriétaire qui a en plus le droit d’écrire. Bref, comme je l’écrivais, c’est une façon quelque peu obscure (mais brève) d’exprimer les permissions. « rwxr-xr-x » est plus parlant et on peut utiliser ces lettres avec 'chmod', qui sert à modifier les permissions.

Si tu lis l’anglais, http://flossmanuals.net/command-line/introduction/ est une bonne introduction à la ligne de commande (pratique en même temps !)… mais saute la section « STANDARD FILES » qui devrait se trouver vers la fin de la section « ADVANCED » du manuel, bien après la sous-section « PERMISSIONS » qui explique mieux que je ne viens de le faire les permissions : http://flossmanuals.net/command-line/permissions/

Courriernord
Offline
Beigetreten: 07/06/2018

> Tu peux écrire dans /home/data sans être son propriétaire (avec 'sudo chown $USER:$USER /home/data') ?

Je l'ai peut-être fait en fait, sans remplacer User... mais il n'y a rien eu en réponse dans le terminal, donc j'ai pensé que la commande était pas correcte et qu'il fallait remplacer USER.

Magic Banana

I am a member!

Online
Beigetreten: 07/24/2010

Comme je l’écrivais :

Une commande qui n’écrit rien est une commande qui s’est exécutée sans problème.
https://trisquel.info/forum/disque-home-satur%C3%A9-et-absence-de-permissions-pour-modifier-le-dd#comment-134738

Je pense donc que tu as exécuté 'sudo chown $USER:$USER /home/data', c’est-à-dire 'sudo chown guillaume:guillaume /home/data' car, avant d'exécuter 'chown', l'interpréteur de commande remplace $USER par le nom de l’utilisateur connecté. Si c’est bien le cas, la commande suivante écrira « guillaume » :
$ stat -c %U /home/data

Courriernord
Offline
Beigetreten: 07/06/2018

exact !