GeForce GTX 750 Ti - Linux Libre.

9 Antworten [Letzter Beitrag]
Dogers
Offline
Beigetreten: 12/29/2013

Salutations a tous !

Voici ma situation. Je viens de mettre la main sur un PC avec une GeForce GTX 750 Ti (GM107) et selon H-Node l’accélération 3D n'est pas supportée. Cela voudrait dire que je devrais acquérir une nouvelle carte en attendant que celle-ci soit supporté. Sur mon PC principal j'ai une GT 630 qui marche a merveille sur le simulateur de vol libre Flightgear. Alors qu'avec la 750 Ti je dois tourner autour des 5 FPS !

Donc je me demandais si il existe un moyen quelconque pour activer l’accélération 3D (hormis bien entendu le pilote propriétaire). Je ne sais pas, je me dis que peut-être que certaines info de H-Node ne sont pas a jour et qu'une mise a jour du noyau ou autre, pourrais régler le problème ...

Merci d'avances pour vos réponses !

Dogers
Offline
Beigetreten: 12/29/2013

Désolé pour le double post, c'était juste pour ajouter que j'ai effectué mes test sur un Live-CD de Trisquel 7. Je préfère tester de cette manière avant d'effectuer une installation complète et de me rendre compte du problème par la suite ...

Magic Banana

I am a member!

Offline
Beigetreten: 07/24/2010

Tu peux toujours essayer de mettre à jour le noyau : https://trisquel.info/fr/wiki/actualiser-le-kernel-linux-libre

Si l'ordinateur a un processeur Intel qui intègre un chipset graphique, alors tu peux retirer physiquement la carte nVidia et non seulement obtenir de meilleures performances (ce qu inclut une accélération 3D) mais aussi économiser de l'énergie.

Dogers
Offline
Beigetreten: 12/29/2013

Merci pour ta réponse.

C'est bien ce que je pensais ... Mais non, je vais probablement opté pour une autre carte, car de toute façon j'ai un processeur AMD et puis les chipset Intel sont très mal supporté par Flightgear. Je pense que le manque de compatibilité de la 750 est sûrement du au fait que l’architecture du GPU est assez récente (Maxwell).

J'opterais probablement pour pour un autre GT630, merci encore !

Magic Banana

I am a member!

Offline
Beigetreten: 07/24/2010

Essaie déjà d'installer un noyau plus récent. Avec https://jxself.org/linux-libre/ il est facile d'obtenir la toute dernière version (4.6). Le support pour ta carte s'est peut-être amélioré récemment.

Dogers
Offline
Beigetreten: 12/29/2013

J'ai effectuer différentes séries de test. Et après avoir installer le dernier noyau (4.6), cela a régler le soucis de résolution avec 750. Mais les performance n'ont pas bouger sur Flightgear. J'ai mis une GT 630 et la elle était déjà mieux prise en charge, je tournais autours des 30 FPS (au lieu de 5).

Je pense qu'il faudra encore attendre un peu pour voir un support de cette carte dans le monde du logiciel libre.

Merci encore !

Calinou
Offline
Beigetreten: 03/08/2014

Les cartes NVIDIA Maxwell et Pascal ont besoin d'un micrologiciel propriétaire pour fonctionner sous GNU/Linux, même avec le pilote libre Nouveau. Cependant, j'ai entendu dire que certaines cartes Maxwell (les "Maxwell 1" uniquement, pas les "Maxwell 2") pourraient fonctionner sans.

Tu peux aller demander sur IRC au pire (#nouveau sur chat.freenode.net).

Dogers
Offline
Beigetreten: 12/29/2013

Cela veux donc dire que pour les Maxwell2 il ne pourra jamais avoir de support dans linux-libre si j'ai bien compris ?

Calinou
Offline
Beigetreten: 03/08/2014

C'est très peu probable, car les cartes Maxwell 2 utilisent un micrologiciel non seulement propriétaire, mais également signé numériquement ; il est donc sans doute impossible de le remplacer.

Dogers
Offline
Beigetreten: 12/29/2013

Je ne comprendrais jamais le principe de ce genre d'action de la part des différentes entreprises.