How to boot in terminal only

12 Antworten [Letzter Beitrag]
veisong
Offline
Beigetreten: 12/25/2011

Hello everybody!

I have a question, how to boot in terminal without starting gdm, x11 on 5.5 version?

I do not want to delete gdm or X, just would like to add or change some parameters to GRUB or other place to boot only in terminal and if I need X I always can "startx".

I have tried:

sudo nano /etc/default grub

find
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

and change it to
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash text"

and of course
sudo update-grub

Unfortunately it did not work. Still booting into gdm login manager.

Thank you for your help.

lembas
Offline
Beigetreten: 05/13/2010

Hello there!

Looks like you need to edit /etc/init/gdm.conf and change the startup-on line which reads [!06] to [!026] so the default runlevel 2 is also omitted.

If you then want to start gdm use sudo service gdm start.

Dave_Hunt

I am a member!

Offline
Beigetreten: 09/19/2011

Hi,

You could move /etc/init/gdm.conf somewhere else. When you reboot, the
x display will not start.

HTH,

Dave

On 06/30/2012 10:37 AM, name at domain wrote:
> Hello everybody!
>
> I have a question, how to boot in terminal without starting gdm, x11 on
> 5.5 version?
>
> I do not want to delete gdm or X, just would like to add or change some
> parameters to GRUB or other place to boot only in terminal and if I need
> X I always can "startx".
>
> I have tried:
>
> sudo nano /etc/default grub
>
> find
> GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
>
> and change it to
> GRUB_CMDLINE_LINUX_DEFAULT="quiet splash text"
>
> and of course
> sudo update-grub
>
> Unfortunately it did not work. Still booting into gdm login manager.
>
> Thank you for your help.
>
>

sudoman
Offline
Beigetreten: 10/02/2011

You could also mess with this file:

/etc/X11/default-display-manager

It might be nicer than moving the gdm.conf file.

Magic Banana

I am a member!

Offline
Beigetreten: 07/24/2010

I vote for lembas' solution that looks far less "cow-boy" than others. After all, a init script aims to decide what service to start/stop (and how to do so).

alucardx
Offline
Beigetreten: 02/29/2012

Shouldn't you simply be able to edit /etc/default/grub and change the line that reads "GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to simply "text" then update grub?

This is what I've been able to do in Trisquel 4.0 and Trisquel 5.0.

andrew
Offline
Beigetreten: 04/19/2012

> "GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to simply "text"

I think that option only changes the way kernel messages (or lack of) are displayed, and not whether X is started. The OP didn't want X starting at all (not just during boottime).

aliasbody
Offline
Beigetreten: 09/14/2012

Try adding in front of the kernel line (on the grub file) to add the number "3" since it is the runlevel 3 (for multiuser text mode).

kneebiter
Offline
Beigetreten: 12/19/2012

Has anybody got any of these to actually work? I want to boot to terminal to install video drivers and cannot get these to work for me. I even tried to get recovery console at boot by commenting out GRUB_DISABLE_RECOVERY=true that Trisquel added and can't seem to get there. Yes I did sudo update-grub afterwords. What am I doing wrong?

lembas
Offline
Beigetreten: 05/13/2010

>to install video drivers

What kind of a video card do you have? Which drivers are you trying to install?

kneebiter
Offline
Beigetreten: 12/19/2012

Its an old TNT that Nvidia has drivers posted for. Even when I can shut down gdm, there is still that Nouveau thing running (from ramdisk?) I have about given up. I'm pretty much a linux newbie, but understand some of the basics. Was hoping to get OpenGL working to install the latest version of PCB for printed circuit board design...

lembas
Offline
Beigetreten: 05/13/2010

Nvidia only releases proprietary drivers. And Trisquel is about only using free software. So, these two are incompatible.

We GNU/Linux users don't generally worry about drivers as all drivers are included in the Linux kernel and we don't have to go hunting them on the web like on certain other operating systems.

Magic Banana

I am a member!

Offline
Beigetreten: 07/24/2010

You can switch to a real terminal by typing Ctrl+Alt+F1 (and Ctrl+Alt+F2 for another one, etc.), log in and fire sudo service gdm stop... but the free drivers already are included in the Linux-libre kernel!