Installer un jeu dont j'ai téléchargé le tar.bz2

6 Antworten [Letzter Beitrag]
shokin
Offline
Beigetreten: 03/01/2013

Salut à toutes et à tous,

Je suis récemment arrivé dans le monde de Trisquel 6.0 sur un ordinateur portable.

J'ai l'habitude d'installer des logiciels libres qui sont déjà dans le software manager (ajout/suppression de logiciels libres) ou dont le paquet est déjà sur l'ordinateur et prêt à être installé d'une simple suite de clics (et de touches pour le mot de passe admin).

Là, je viens de chercher et trouver un logiciel libre d'analyse d'échecs.

http://sourceforge.net/projects/scid/?source=dlp (SCID)

http://scid.sourceforge.net/index.html

Notamment grâce à la page instructive suivante :

http://www.abul.org/Logiciels-libres-pour-le-jeu-d.html#nb21

J'ai téléchargé la compression nommée "scid-4.3.tar.bz2" . Comme vous le savez mieux que moi, il s'agit d'un fichier à double-extension de compression (mieux que zip ou rar). Je l'ai extrait (décompressé) avec le Gestionnaire d'archives.

Il est alors apparu comme installable dans le Gestionnaire de Paquets Synaptic. Je suis prêt à cliquer. Mais avant cela :

J'ai placé les fichiers dans un dossier que j'ai nommé "SCID", lui-même placé dans le dossier "Téléchargements".

Avant d'installer ce logiciel libre d'analyse de partie d'échecs, est-il judicieux de déplacer le dossier "SCID" dans un autre dossier du disque dur ?

Est-ce que le logiciel libre SCID apparaîtra, une fois installé, dans la cathégorie/rubrique "Jeux" ?

Merci d'avance pour vos réponses !

P.S. Cool ! Pas besoin d'utiliser le logiciel d'analyse de partie d'échecs FRITZ, que beaucoup de joueurs d'échecs utilisent mais qui n'est pas un logiciel libre.

Magic Banana

I am a member!

Offline
Beigetreten: 07/24/2010

Le simple téléchargement de fichiers (même de paquets DEB) ne fait rien apparaître dans le gestionnaire de paquet. Si il est listé là, décoché, c'est qu'il est dans le dépôt Trisquel ou dans un autre dépôt que tu airais ajouté par toi même (mais en l'occurrence, il est dans le dépôt Trisquel). Prêt à être installé en trois clics. Comme la version proposée par Trisquel est la même que celle disponible depuis le site officiel, il n'y a aucun intérêt à passer par les sources (dans le tar.bz2 que tu as téléchargé)... à moins que tu ne souhaites étudier/modifier ce code source. Tu peux donc supprimer ces sources et installer Scid depuis le gestionnaire de paquets Synaptic. Il devrait alors apparaître dans le menu (je suppose : je n'ai pas essayé).

Sinon, la double extension ne rend pas l'archive compressée meilleur. Cela illustre simplement un principe d'UNIX (qui a inspiré GNU) : un outil qui fait une tâche et qui la fait bien. Le .tar n'est qu'une juxtaposition de fichiers en un seul (avec un index pour savoir comment redécouper l'archive). Elle est obtenue par la commande GNU TAR. Le .bz2 indique que cette archive a ensuite été compressée avec l'algorithme BZ2 (qui n'est pas le meilleur : XZ permet d'obtenir de meilleurs taux de compression sans nécessiter plus de temps de calcul pour la compression/décompression).

shokin
Offline
Beigetreten: 03/01/2013

Ah ! okay, j'ai supprimé le SCID que j'avais téléchargé. Et SCID est resté dans le gestionnaire de paquets synaptic. Maintenant, je viens de l'installer.

Je ne m'y connais pas en code, même si j'ai décidé de n'utiliser que des logiciels libres désormais.

Cela dit, je repose la question pour le cas où un paquet (que je trouverais utile par la suite) ne se trouverait pas dans le gestionnaire de paquets Synaptic :

Comment traiter un paquet (de logiciel(s)) qui ne se trouve pas dans le Synaptic mais sur le web ? le télécharger à un endroit spécifique ? utiliser le terminal ?

Magic Banana

I am a member!

Offline
Beigetreten: 07/24/2010

La première chose à voir est si le logiciel ne serait pas disponible dans ce que l'on appelle un PPA (en cherchant sur le web "PPA" + le nom du logiciel). Ces "Personal Package Archives" étendent l'offre disponible dans les dépôts de ta distribution. Attention, certains d'entre eux proposent des logiciels privateurs ! Comme ils sont généralement destinés à Ubuntu, il te faut connaître la version d'Ubuntu sur laquelle se base ta version de Trisquel. Par exemple, si tu utilises Trisquel 6.0 Toutatis, alors il s'agit de Ubuntu 12.04 Precise Pangolin. Il te suffit alors d'ajouter une (ou deux si tu veux aussi pouvoir télécharger les paquets sources) ligne au fichier /etc/apt/sources.list. Cela requiert les droits d'administration (et donc 'sudo' ou 'gksu'). Par exemple pour éditer le fichier avec GEdit (l'éditeur par défaut de Trisquel), tu peux obtenir une invite de commande avec Alt+F2 et exécuter:
gksu gedit /etc/apt/sources.list
La (ou les deux) ligne à ajouter (n'importe où) sont données sur la page du PPA. Par exemple, ce PPA permet l'installation de la dernière version de GIMP et, en choisissant "Precise 12.04" comme distribution, la ligne à ajouter est :
deb http://ppa.launchpad.net/otto-kesselgulasch/gimp/ubuntu precise main
Les logiciels proposés par le PPA sont alors installables comme si ils avaient été dans les dépôts Trisquel. Remarque néanmoins que l'utilisation de plusieurs PPA peut poser problème car certains vont proposer des versions récentes de certaines bibliothèques système alors que d'autres logiciels ne seront pas compatibles avec (ce n'est pas pour rien que Trisquel sort des "versions" qui figent les numéros majeurs des paquets proposés). Remarque aussi, que n'importe qui peut héberger un PPA et donc en profiter pour y inclure du code malicieux...

Si aucun PPA n'est disponible, cela se complique. Il est possible que les développeurs proposent un paquet .deb en téléchargement. Il est alors probable qu'il ne te faille que le télécharger et double-cliquer dessus pour l'installer avec GDebi (je ne suis pas certain qu'il soit toujours dans le système par défaut, auquel cas installe-le depuis le gestionnaire de paquets). Néanmoins, si il est destiné pour une version de Debian/Ubuntu différente de ta Trisquel, il est aussi probable qu'il requiert des dépendances qui ne sont pas fournies dans ton dépôt (c'est à dire que le logiciel a besoin, pour fonctionner, d'autres paquets/versions que celles que ta version de Trisquel propose). tu peux alors chercher d'autres .deb pour ces dépendances sur http://packages.debian.org ou sur http://packages.ubuntu.com ... mais ça peut vite devenir l'enfer (les dépendances qui, elles-mêmes nécessitent d'autres dépendances, etc.). En aucun cas tu ne devrais essayer de remplacer les bibliothèques systèmes les plus fondamentales (genre 'libc'). Tu risquerais alors de casser ton système.

Enfin, si il n'y a pas même de paquet .deb, il reste les sources. Compiler un logiciel peut être simple... mais pas toujours ! Il te faut tout un attirail (généralement le compilateur GNU GCC, le constructeur GNU Make, etc.) que tu trouveras dans les dépôts. Il te faut aussi, encore une fois, les dépendances. Enfin, il te faut suivre les indications généralement écrites dans un fichier nommé INSTALL (dans l'archive que tu télécharges). Ces instructions sont à effectuées depuis un terminal (dont tu dois donc connaître les bases).

shokin
Offline
Beigetreten: 03/01/2013

Bon, en fait, j'ai installé scid à l'aide du Synaptic mais je ne le trouve pas dans la catégorie Jeux ni dans la catégorie Éducation ni ailleurs à partir de la barre des tâches à gauche. Si je clique sur le scid de la page suivante :

http://doc.ubuntu-fr.org/scid

Un message me dit que le paquet est déjà installé, mais où ? S'appelle-t-il autrement ?

Si c'est une base de données, ce en quoi je ne m'y connais pas, comment l'ouvrir ? J'avais cru comprendre qu'il s'agissait d'un logiciel. Mais il semble que ça signifie : Shane's Chess Information Database .

Voici une capture d'écran :

http://ubuntuone.com/31nCbik9Nt08wSfWWmsPnF

Laërte
Offline
Beigetreten: 03/18/2013

Si il n'est pas dans le menu tu peux l'ajouter grâce à l'éditeur de menu
Pour ça tu tapes alacarte dans un terminal.

Magic Banana

I am a member!

Offline
Beigetreten: 07/24/2010

Anéfé. La commande est très probablement 'scid'. D'ailleurs, tu peux aussi exécuter cette commande depuis l'invite obtenue par Alt+F2 (ou depuis un terminal).