Installing Trisquel on EFI

3 Antworten [Letzter Beitrag]
Beigetreten: 08/11/2014


after having unsuccesfully tried several ways to install trisquel on an efi system, I come here to get some help.
I successfully booted and installed trisquel about ten times, always with the same issue : grub can't install because it "can't get the canonical path of'cow'".
I am aware that some operations must be done when booting (checking whether it is legacy boot or efi boot) and that a GPT partition table with a bios-grub partition must be created before installation in case of a legacy grub install. I tried but am not sure if it was really succesful, because my HDD still can't be selected to boot in the Bios :

The PC is an Asus R900V with an internal hard drive recognized by the BIOS under Sata devices on port 0. Works perfectly when I work with it on a live system, but can't select it on the Boot device priority option. Here is only listed the DVD drive or the USB flash drive when I put one.

Here comes the question : can the HDD absence from boot options be due to a wrong grub install ?
And also : can someone explain me the easiest and most reliable way to install trisquel on this computer (I mean EFI vs Legacy boot)?

Beigetreten: 05/01/2018

Once I had one Acer ultrabook with mSATA and SATA drives. The "legacy" mode boot list didn't contain the mSATA option, so if I wished to boot from the mSATA SSD, I had to use UEFI mode (the ESP can be on either SSD or HDD).

I believe what you described was something similar: restrictions by the firmware. (Maybe the manufacturer didn't want users to install operating systems using legacy mode.) Unfortunately, starting Haswell, Intel implemented one treacherous "feature": Boot Guard. It is impossible to fix the broken-beyond-repair non-free firmware with this anti-feature present.

What I can suggest is to try the latest Debian (testing) Installer and perform a minimalist installation. See whether you can boot it from UEFI mode. Use the "Alpha 3" release of Debian Installer. I tested it on many UEFI systems. (Note: Debian does have certain non-free firmware on its mirror servers. Avoid adding the "contrib" or "non-free" repositories and you can have a free/libre system.)

Beigetreten: 08/11/2014

Thank you for your answer. I can neither boot from legacy mode nor from efi. I think this is because there is no efi boot partition with a GPT partition table correctly installed on my hard drive.

I will try with Debian testing.

On the french forum we have found this wich is particularly suitable

It gives informations on how to recover the disabled SATA HDD. If it works I will traduce the info here.

Beigetreten: 01/04/2019

Looks like you have to save all your /home and, from instalation, click in /dev/sda (no sda1/sda2) and "create a new partition tab". I think is the only way but I'm not sure.