Le micro ne fonctionne pas.

17 Antworten [Letzter Beitrag]
thierra
Offline
Beigetreten: 02/19/2015

Bonjour à tous,

Tout nouveau sous Trisquel mais sous GNU/Linux depuis 10 ans.
J'ai un ASUS EeePC X101CH avec W7 d'origine (achat occasion, il y a 6 mois) dont je ne me sers pas, LinuxMint 16 depuis l'achat et maintenant Trisquel depuis deux jours. Donc trois OS.
Le microphone ne fonctionne pas sous Trisquel, j'ai testé avec audio-recorder, aucun son. Sous LinuxMint, je n'ai que des grésillements. Sous W7 ça fonctionne.

Que faire ?

lspci donne :
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02)

J'ai vu sur la toile que les problèmes de son était nombreux et divers.

Librement
Thierry Vedel
Membre de l'APRIL

thierra
Offline
Beigetreten: 02/19/2015

Suite des tests.

thierry@gpasdidee:~$ cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xdff00000 irq 46
thierry@gpasdidee:~$ arecord -l
**** Liste des Périphériques Matériels CAPTURE ****
carte 0: Intel [HDA Intel], périphérique 0: ALC269VB Analog [ALC269VB Analog]
Sous-périphériques: 1/1
Sous-périphérique #0: subdevice #0
thierry@gpasdidee:~$ arecord -d 10 /tmp/test-mic.wav
Capture WAVE '/tmp/test-mic.wav' : Unsigned 8 bit, Fréquence 8000 Hz, Mono
thierry@gpasdidee:~$ aplay /tmp/test-mic.wav
Lecture WAVE '/tmp/test-mic.wav' : Unsigned 8 bit, Fréquence 8000 Hz, Mono
On entends bien des grésillements mais pas la voix.

Magic Banana

I am a member!

Offline
Beigetreten: 07/24/2010

Je suppose que tu as déjà regardé du côté de l'onglet "Entrée" de l'utilitaire "Son" qui se trouve dans les "Paramètres système". Regarde donc aussi ce que donne la commande 'alsamixer'. "MM" signifie "muet" (ce que tu ne veux pas et peut changer avec la touche M) et le volume doit être élevé (tu peux utiliser la flèche vers le haut). Toujours dans 'alsamixer', il peut y avoir un "Mic Boost" avec lequel jouer.

thierra
Offline
Beigetreten: 02/19/2015

Bonsoir Magic Banana,

Voilà ce que donne la commande alsamixer, fichier joint. Là je suis perdu.

Librement

Thierry Vedel

son.png
Magic Banana

I am a member!

Offline
Beigetreten: 07/24/2010

Il n'y a pas de micro ! Je suppose que l'utilitaire "Son" ne t'en montre pas non plus, n'est-ce pas ?

Peut-être veux-tu relater ce problème sur le forum anglophone (avec cette capture d'écran). Tu as de grandes chances d'y trouver de l'aide.

thierra
Offline
Beigetreten: 02/19/2015

Voila ce que donne l'utilitaire son :
Mais je suis quasiment sûr que j'ai vu deux entrées la fois d'avant.

Thierry Vedel

SonEntree.png
Magic Banana

I am a member!

Offline
Beigetreten: 07/24/2010

Le "niveau d'entrée" indique bien que le micro reçoit du son.

thierra
Offline
Beigetreten: 02/19/2015

J'ai fait un enregistrement. Il y a un très fort grésillement mais on entends la voix. Le micro fonctionne mais très mal. C'est sûrement le matériel.

Thierry Vedel

thierra
Offline
Beigetreten: 02/19/2015

A force de chercher, j'ai oublié l'essentiel. Ca marche sous W7. Donc c'est pas le matériel. Par contre, quand j'ai changé le volume d'entrée dans l'utilitaire son, alsamixer n'a pas changé. J'ai compris la manip sous alsamixer et pu "faire apparaître le micro. Mais le résultat à l'enregistrement est le même. Conflit ?
Thierry Vedel

AlsaMixer2.png
Magic Banana

I am a member!

Offline
Beigetreten: 07/24/2010

Je n'avais pas fait attention mais, oui, les flèches à droite de l'écran signifient qu'il y a plus à voir. Et notamment le micro. As-tu tout mis au maximum dans alsamixer ?

thierra
Offline
Beigetreten: 02/19/2015

Bizarre, bizarre, j'allais tout fermer quand j'ai relancé l'utilitaire son, il y a deux entées !!!

EntreeSon3.png
thierra
Offline
Beigetreten: 02/19/2015

Il y a donc l'entrée "casque micro Audio interne" et "Microphone interne Audio interne".
Quand je règle le volume à 0 sur "casque micro Audio interne" avec l'utilitaire son, le volume reste à 0 pour "Microphone interne Audio interne", même si je le mets au maximum. Donc pas de son. Si je mets le volume de "casque micro Audio interne" à 100% par exemple, là le volume d'entrée de "Microphone interne Audio interne" peut être réglé correctement. D'où le problème des grésillements, venant de l'entrée "casque micro Audio interne", car je n'ai pas de casque. J'ai le même problème sous LinuxMint, sauf que des fois ça a marché, mais quelques rares fois en 6 mois.
Comment supprimer l'entrée "casque micro Audio interne" ?

Merci d'avance.

Thierry Vedel

Magic Banana

I am a member!

Offline
Beigetreten: 07/24/2010

Tu veux éteindre ce micro (il y a un interrupteur à droite de la barre de volume).

thierra
Offline
Beigetreten: 02/19/2015

J'étais sous LinuxMint quand j'ai lu ton message. Je redémarre sous Trisquel et étonnamment le "Casque ..." est coupé. Test d'enregistrement, aucun son. J'ai l'impression que "Casque ..." commande le niveau du volume comme je l'ai dit avant.
D'ailleurs c'est "Casque micro - Audio interne".

Mais les résultats varient et maintenant j'ai du volume sur l'entrée "Micro..." avec "Casque ..." coupé. Pas de son, seulement un bruit de fond.

Sasaki
Offline
Beigetreten: 08/11/2014

Salut, je te suggère de faire un petit essai avec audacity. A la différence d'audio recorder, il permet de bien tester toutes ses entrées les unes après les autres. Il donne aussi des messages d'erreurs intéressants des fois.

Ton micro, c'est celui du pc si j'ai bien compris ?

Si tu ne trouves pas de solution in ici ni sur le forum anglophone, je te conseille d'aller tenter ta chance sur http://www.linuxmao.org/Accueil ;)

thierra
Offline
Beigetreten: 02/19/2015

Salut Sasaki,

Je vais tester avec Audacity, mais je fais une pause, donc dans quelques jours.

Merci pour les infos.

Thierry Vedel

Sasaki
Offline
Beigetreten: 08/11/2014

Je pense à un truc. Tu pourrais faire un test avec qjackctl, encore mieux qu'audacity pour les messages d'erreur. Tu le démarre et il remplace automatiquement pulseaudio. Avant de le démarrer il y a le bouton réglages qui te permet, entre autres, de choisir les entrées/sorties.

On peut aussi se poser la question des drivers vu que ça fonctionne sous windows et pas sous linux.

La dernière fois, pour faire marcher mon micro avec audacity, je devais faire quelques clics dans les paramètres sonores, amplifier, désamplifier, changer de périphérique, etc. pour que ça marche. Il y a une manip aussi qui est de lancer audacity (sans jack), puis de commencer à enregistrer puis mettre sur pause, et passer dans les paramètres de pulseaudio où tu devrais voir audacity apparaître dans les applications utilisant du son, et de faire les réglages à ce niveau. Tu relance ensuite un nouvel enregistrement avec audacity.

thierra
Offline
Beigetreten: 02/19/2015

Bonjour,

le problème est en partie résolu.
Ajout de la ligne "options snd-hda-intel model=lenovo" dans alsa.conf
Ca marche sur le moment mais pas après redémarrage.

Il y a toujours deux entrées Casque et interne.
Je branche un kit main libre. Interne disparaît.
Je débranche le kit, Casque est remplacé par interne et ça fonctionne !!!

Malheureusement, il faut répéter la manip après chaque veille ou démarrage.

Librement
Thierry Vedel