Linphone doesn't work

9 Antworten [Letzter Beitrag]
anatom

I am a member!

Offline
Beigetreten: 09/20/2012

Hello everybody,

I need to use VoIP for keeping contact to family. I installed Linphone in Trisquel 8.0 as a libre alternative to Skype, but it doesn't work.

Searching ubuntuusers.de, I found on this page https://wiki.ubuntuusers.de/linphone/#Netzwerk (unfortunately German only) that my router ("Fritz!Box") uses the standard port 5060 for its own VoIP feature. So I switched to port 5061 in Linphone and configured my router so that my computer is allowed to use 5061.

With both 5060 and 5061, I get the following error in the debug window: "Authentication method not supported. (MD5, AKAv1-MD5, AKAv2-MD5)".

After setting the port to 5061, I tried to call sip:name at domain. It didn't work from my linphone-account nor from the "default"-SIP-Adress sip:name-of-computer@ip-address:5061. This time, I couldn't find an error message in the debug-window.

My questions are:

1.) Should I stick with Linphone for free (and libre) video calls or should I try a different software?
2.) If I should stick with Linphone, what is wrong and how can I fix it?

I've attached two files: debug-5060.txt logging my trials with port 5060, and debug-5061.txt, logging my trials with port 5061. I'm at beginner level, no experience or knowledge of network setup but I can work with the command line (which I learnt a long time ago using DOS ...)

Thank you very much in advance, your help will be appreciated!

AnhangGröße
debug-5060.txt25.45 KB
debug-5061.txt60.6 KB
chaosmonk

I am a member!

I am a translator!

Offline
Beigetreten: 07/07/2017

All of the reference I can find online to you error message are kind of old, and the version of Linphone in Trisquel 8 is kind of old. It's possible that a newer version will work better. I have backported Trisquel 9's version of Linphone to Trisquel 8.[1] At tomorrow's meeting I will ask quidam to merge my MR and build the new version of Linphone. I'll let you know when it's done. After that, if you go to Software & Updates and make sure that the backports repository is enabled, you'll be able to install this newer version of Linphone and see if that fixes the bug. If not, we'll keep trying.

[1] https://devel.trisquel.info/trisquel/package-helpers/merge_requests/284

anatom

I am a member!

Offline
Beigetreten: 09/20/2012

chaosmonk, Thank you very much. I'll be waiting for your information.

chaosmonk

I am a member!

I am a translator!

Offline
Beigetreten: 07/07/2017

Trisquel 9's version of Linphone is now available in Trisquel 8's
backports repository. Make sure that you have the backports repository
enabled (let me know if you need help with this), install the new
version, and let me know if you run into the same issue.

anatom

I am a member!

Offline
Beigetreten: 09/20/2012

Thank you! Although we have switched to Jami and Jitsi Meet now, I can try and install the most recent version just to give it a go and see if it works. How can I access the backports repository? I don't know how that works.

chaosmonk

I am a member!

I am a translator!

Offline
Beigetreten: 07/07/2017

> we have switched to Jami and Jitsi Meet now

How well do they each work? Do you have a preference for one over the
other?

> How can I access the backports repository?

Go to Control Center -> Softwre & Updates and make sure that the
backports repository is enabled. Then update your system however you
do usually.

Ark74

I am a member!

Online
Beigetreten: 07/15/2009

I use Jitsi Meet as my default meeting framework, it works pretty nice.

You can test it here: meet.jit.si

Malsasa
Offline
Beigetreten: 12/01/2016

Yes, I too am currently teaching online with Jitsi Meet. It is the
best at the moment after I was trying Nextcloud Talk, then GNU Jami,
then Riot.im (with Jitsi embedded). Jitsi Meet works pretty well.

anatom

I am a member!

Offline
Beigetreten: 09/20/2012

We both have a bandwidth of around 10 Mbit/s down, 1 MBit/s up. Jami seems to work better at that speed, especially sound transmission is much better with Jami. Video sometimes gets frozen both in Jami and Jitsi meet so we tend to switch it off after a while.

I'll give a seperate report on Linphone after re-install in a few days.

anatom

I am a member!

Offline
Beigetreten: 09/20/2012

So I tried Linphone again, Version 3.6.1 from the "backport" repositories. Linphone is set to port 5061, and I've configured port 5061 for Linphone in my router. Result: It still doesn't work. For the protocol, I've attached the debug-window. However, as I've started using Jami and Jitsi, I don't need a solution for the "Linphone problem" anymore.

THANK YOU, everybody for your support!

AnhangGröße
3.6.1-debug-5061.txt 25.05 KB