neovim

4 Antworten [Letzter Beitrag]
jpp
jpp
Offline
Beigetreten: 05/28/2018

Bonjour,

Quand pensez-vous que le paquet neovim sera dispos sous Trisquel ?

Magic Banana

I am a member!

Offline
Beigetreten: 07/24/2010

Il est dans le dépôt de Trisquel 9. Si tu veux passer à Trisquel 9, exécute dans un terminal :
$ sudo sed -i s/flidas/etiona/ /etc/apt/sources.list && sudo apt update && sudo apt full-upgrade

jpp
jpp
Offline
Beigetreten: 05/28/2018

ok merci Magic Banana

jpp
jpp
Offline
Beigetreten: 05/28/2018

Re bonjour,

Après avoir taper La commande $ sudo sed -i s/flidas/etiona/ /etc/apt/sources.list && sudo apt update && sudo apt full-upgrade

J'ai un petit message d'erreur:

root@pc53:~# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
dh-python : Depends: python3-distutils but it is not installed
hplip : Depends: libhpmud0 (= 3.17.10+repack0-5+9.0trisquel1) but 3.16.3+repack0-1+8.0trisquel1 is installed
Depends: printer-driver-hpcups (= 3.17.10+repack0-5+9.0trisquel1) but 3.16.3+repack0-1+8.0trisquel1 is installed
Depends: libsane1 (>= 1.0.24) but it is not installed
Recommends: printer-driver-postscript-hp but it is not installed
libc-bin : Depends: libc6 (< 2.24) but 2.27-3ubuntu1.2 is installed
libc-dev-bin : Depends: libc6 (< 2.24) but 2.27-3ubuntu1.2 is installed
libc6-dev : Depends: libc6 (= 2.23-0ubuntu11.2) but 2.27-3ubuntu1.2 is installed
libc6-i386 : Depends: libc6 (= 2.23-0ubuntu11.2) but 2.27-3ubuntu1.2 is installed
libcairo-perl : Depends: perlapi-5.22.1 but it is not installable
libnet-ssleay-perl : Depends: perlapi-5.22.1 but it is not installable
libperl5.22 : Depends: perl-modules-5.22 (>= 5.22.1-9ubuntu0.6) but it is not installable
locales : Depends: libc-bin (> 2.27)
software-properties-gtk : Depends: python3-software-properties (= 0.96.20.10+8.0trisquel1) but 0.96.24.32.14+9.0trisquel3 is installed
trisquel-release-upgrader-gtk : Depends: trisquel-release-upgrader-core (= 1:16.04.30+8.0trisquel3) but 1:18.04.38+9.0trisquel9 is installed
Depends: python3-distupgrade (= 1:16.04.30+8.0trisquel3) but 1:18.04.38+9.0trisquel9 is installed
update-manager : Depends: update-manager-core (= 1:16.04.17+8.0trisquel9) but 1:18.04.11.13+9.0trisquel10 is installed
update-notifier : Depends: update-notifier-common (= 3.168.10+8.0trisquel2) but 3.192.1.7+9.0trisquel2 is installed
Recommends: apport-gtk (>= 2.8-0ubuntu3) but it is not installed
update-notifier-common : Depends: python3-debconf but it is not installed or
debconf (< 1.5.64~) but 1.5.66ubuntu1 is installed
E: Unmet dependencies. Try using -f.
root@pc53:~#

Peux-tu m'aider à résoudre ce problème ?

Magic Banana

I am a member!

Offline
Beigetreten: 07/24/2010

Essaie ce que te propose le message d'erreur :
$ apt-get -f install
Note : peut-être avais-tu des PPA d'installés; je n'ai pas pensé à te dire d'exécuter un ppa-purge avant le passage à Trisquel 9.