Paquets non gérés par apt après dist-upgrade

3 Antworten [Letzter Beitrag]
jeko
Offline
Beigetreten: 12/08/2017

Salut la compagnie !

J'ai mis à jour mon système aujourd'hui. J'utilisais Emacs, installé via ce dépot :

http://ppa.launchpad.net/alexmurray/emacs/ubuntu

Suite à la mise à jour, j'ai décidé d'utiliser le paquet officiel de Trisquel mais avant ça désinstaller celui présent sur le système.

Et là problème :

$ sudo apt-get remove emacs
[sudo] Mot de passe de jeko :
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Le paquet « emacs » n'est pas installé, et ne peut donc être supprimé
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

$ emacs --version
GNU Emacs 24.5.1
Copyright (C) 2015 Free Software Foundation, Inc.
GNU Emacs comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of Emacs
under the terms of the GNU General Public License.
For more information about these matters, see the file named COPYING.

Est-ce que quelqu'un saurait comment nettoyer ce bazar ?

Magic Banana

I am a member!

Offline
Beigetreten: 07/24/2010

C’est le paquet « emacs24 » (et non « emacs ») que tu veux supprimer. Et tu veux revenir à la version de « emacsen-common » qui est dans le dépôt Trisquel (voire supprimer ce paquet). Pour « downgrader » les paquets fournis par un PPA, il y a « ppa-purge » (dans le dépôt Trisquel). Dans ton cas :
$ ppa-purge ppa:alexmurray/emacs

jeko
Offline
Beigetreten: 12/08/2017

Salut Magic Banana !

Navre du retard, j'ai pris quelques congés. Donc merci pour ton aide sur ce coup !

Je pense avoir réussi a désinstaller emacs24 même si j'ai vraisemblablement conserve quelques references.

$ apt list --installed | grep emacs24

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

emacs24-bin-common/flidas-security,flidas-updates,now 24.5+1-6ubuntu1.1 amd64 [installé, automatique]
emacs24-common/flidas-security,flidas-security,flidas-updates,flidas-updates,now 24.5+1-6ubuntu1.1 all [installé, automatique]
emacs24-common-non-dfsg/flidas-updates,flidas-updates,now 24.4+1-2+8.0trisquel2 all [installé, automatique]
emacs24-el/flidas-security,flidas-security,flidas-updates,flidas-updates,now 24.5+1-6ubuntu1.1 all [installé]
emacs24-lucid/flidas-security,flidas-updates,now 24.5+1-6ubuntu1.1 amd64 [installé, automatique]

Mais j'ai l'impression qu'elles font partie de Fildas pour le coup.

Magic Banana

I am a member!

Offline
Beigetreten: 07/24/2010

Oui.