Text Selection in abrowser 7.0 not working?

8 Antworten [Letzter Beitrag]
Dave_Hunt

I am a member!

Offline
Beigetreten: 09/19/2011

Hi,

In the latest version of the Mozilla browser, I cannot select text on
pages, using keys like shifted arrow keys, 'shift+end', or
'ctrl+shift+end', and copy it to the clipboard. Select all, 'ctrl+a'
seems to still work. Also, the 'cut', 'copy', and 'paste' options seem
not to be on the 'edit' menu. In browser preferences, I have turned on
the check box for 'navigate web pages with cursor keys'. Have I found
another bug?

Cheers,

Dave

Cyberhawk

I am a translator!

Offline
Beigetreten: 07/27/2010

Where did you get abrowser 7.0? I thought in Dagda we have 6.02. With 6.02 I don't have the issues you described, tried all of the shortcuts and they work. Can also scroll the page with "end" and "home".

Allan Javier Aguilar Castillo
Offline
Beigetreten: 04/30/2011

On 03/10/2011 15:17, Dave Hunt wrote:
> In the latest version of the Mozilla browser, I cannot select text
> on pages, using keys like shifted arrow keys, 'shift+end', or
> 'ctrl+shift+end', and copy it to the clipboard. Select all,
> 'ctrl+a' seems to still work. Also, the 'cut', 'copy', and 'paste'
> options seem not to be on the 'edit' menu. In browser preferences,
> I have turned on the check box for 'navigate web pages with cursor
> keys'. Have I found another bug?

Hello!

I have Abrowser 7.0.1 on Trisquel Dagda, but I don't have the
issues you have. I'm able to select text with all those commands.
Also, I see "Cut", "Copy" and "Paste" on the "Edit" menu.

Try upgrading Abrowser from 7.0 to 7.0.1.
--
Allan Aguilar
https://editorialhah.wordpress.com
Mail: name at domain
XMPP: name at domain

lansburyslido
Offline
Beigetreten: 08/29/2011

Edit is greyed out on my Abrowser 7.01 in the pull down menu. See attachment.

Cut, copy & paste is available in the right-click context menu though.

Magic Banana

I am a member!

Offline
Beigetreten: 07/24/2010

It is grayed out but the copy icon seems to be correctly available (it is not grayed out).

lansburyslido
Offline
Beigetreten: 08/29/2011

Issues with attaching files as well, missing text with checkboxes, doesn't seem to want to include attachments. Will link to the image attachments when I get to work.

No edit in menu

Attachment issue?

BinaryDigit
Offline
Beigetreten: 11/30/2010

I have ABrowser 7.0.1 and the commands in the Edit menu are all greyed out, exactly the same as in your image. I have "Copy" and "Select All" in the right-click context menu, but no "Cut" or "Paste". Keyboard shortcuts work, selecting "Always use the cursor keys to navigate within pages", in Preferences > Advanced > General, makes no difference, except allowing the cursor to move within the page as expected.

I've worked out how the Edit command functions. The Edit command icons become ungreyed when certain context-sensitive actions occur:

* When text is selected the copy icon becomes ungreyed and active.

* When the cursor is in a text field and text is on the clipboard, the paste icon becomes ungreyed and active.

* When copied text is pasted into a text field and then selected, all icons become ungreyed and active.

The command word "Edit" itself remains greyed out, so that might be a minor bug.

lansburyslido
Offline
Beigetreten: 08/29/2011

Dave Hunt, those key combinations work for me.

Magic Banana / BinaryDigit, yes you are correct, the Edit menu item remains greyed out but the options below still work.

Dave_Hunt

I am a member!

Offline
Beigetreten: 09/19/2011

Thanks, all, for exercising this a bit!

On further testing with html documents I made, I discovered that the
keyboard shortcuts for selection, copying, and pasting do work as they
should. The trouble seems to be specifically with headlines on this web
site. I wanted to share articles, using
the headlines as titles. Maybe this site disables the selection for its
own purposes? I notice, it has its own 'share' frame, with links for
twitter, facebook, ping.fm, etc.

Cheers,

Dave

On 10/04/2011 02:58 PM, name at domain wrote:
> Dave Hunt, those key combinations work for me.
>
> Magic Banana / BinaryDigit, yes you are correct, the Edit menu item
> remains greyed out but the options below still work.