tor process

10 Antworten [Letzter Beitrag]
Mzee
Offline
Beigetreten: 07/10/2013

Hello there,

I just noticed that there is a process "tor" running in the background even though I never installed tor. Does this now come by default with abrowser? How can I disable tor? Thanks a lot for your answers.

martinh
Offline
Beigetreten: 02/21/2014
Mzee
Offline
Beigetreten: 07/10/2013

Thanks a lot. I seem to have kinda missed that discussion. As I don't want to search the whole thread for this information: How can I disable tor?

martinh
Offline
Beigetreten: 02/21/2014

Looks like it's using the "Torbutton", should be able to disable it under add-ons ? Not sure...

Mzee
Offline
Beigetreten: 07/10/2013

Hum... unfortunately torbutton is not installed on my machine. Thus, I can't disable it. ;-)

martinh
Offline
Beigetreten: 02/21/2014

strange.... tor is normally symbolized by a little green onion in the systray or browser, if that shows you could click on it for 'options', otherwise I don't know, sorry...

Mzee
Offline
Beigetreten: 07/10/2013

There is an add-on called "Private Tor browsing" but it has been disabled already. Strangely, I still have a tor process running in the background.

Geshmy
Offline
Beigetreten: 04/23/2015

You could stop it from running by changing S20tor to K20tor in /etc/rc2.d through /etc/rc.5

$ ls /etc/rc2.d
README S20hddtemp S20speech-dispatcher S70pppd-dns
S16openvpn S20postfix S20tor S91apache2
S19mysql S20rsync S25mdadm S99ondemand
S20clamav-freshclam S20screen-cleanup S37iptables-persistent S99rc.local

$ sudo mv /etc/rc2.d/S20tor /etc/rc2.d/K20tor

and repeat for /etc/rc.3.d and so forth. On mine rc0.d, rc1.d and rc6.d all have the Kill tor K20tor but run levels 3 through 5 have the start flag S20tor.

If you make them all K20tor and reboot it shouldn't start.

This is an easier way.
...I ran this on mine
$ sudo update-rc.d tor disable
[sudo] password for geshmy:
update-rc.d: warning: start runlevel arguments (none) do not match tor Default-Start values (2 3 4 5)
update-rc.d: warning: stop runlevel arguments (none) do not match tor Default-Stop values (0 1 6)
Disabling system startup links for /etc/init.d/tor ...
Removing any system startup links for /etc/init.d/tor ...
/etc/rc0.d/K20tor
/etc/rc1.d/K20tor
/etc/rc2.d/S20tor
/etc/rc3.d/S20tor
/etc/rc4.d/S20tor
/etc/rc5.d/S20tor
/etc/rc6.d/K20tor
Adding system startup for /etc/init.d/tor ...
/etc/rc0.d/K20tor -> ../init.d/tor
/etc/rc1.d/K20tor -> ../init.d/tor
/etc/rc6.d/K20tor -> ../init.d/tor
/etc/rc2.d/K80tor -> ../init.d/tor
/etc/rc3.d/K80tor -> ../init.d/tor
/etc/rc4.d/K80tor -> ../init.d/tor
/etc/rc5.d/K80tor -> ../init.d/tor

and then
$ sudo update-rc.d tor enable
starts it back up.

Probably have to reboot for it to take effect.

SuperTramp83

I am a translator!

Offline
Beigetreten: 10/31/2014

sudo apt-get remove --purge tor

Magic Banana

I am a member!

Offline
Beigetreten: 07/24/2010

Do you really use Abrowser and not Icecat? I do not have Icecat installed and I still have "trisquel" and "trisquel-recommended" with all their dependencies. Yet:
$ ps -e | grep -i tor
5026 ? 00:00:00 indicator-bluet
5034 ? 00:00:00 indicator-power

Mzee
Offline
Beigetreten: 07/10/2013

"sudo apt-get remove --purge tor"
I think that did the trick; thank you. :-)

"Do you really use Abrowser and not Icecat?"
I had Icecat installed some time ago and removed it again afterwards. Maybe tor was just an artifact from that older installation.