Trisquel doesnt recognize static-ip through its network manager

8 Antworten [Letzter Beitrag]
goyob
Offline
Beigetreten: 03/28/2021

I have download and installed trisquel but i have static ip configuration (fixed ips for IP,Gateway,DNS) but trisquel doesnt seem to recognize the configurations cause it wont connect me to the internet.

if you want any debugs or so i can provide, but you can test that at any machine and it should give the same result (manual IPv4)

panties
Offline
Beigetreten: 02/02/2021

Are you using routers?
I also have a static IP (which alone costs 2.5 times more than basic internet usage! IPv6 is free) and Trisquel works fine by default.

edit:typo

goyob
Offline
Beigetreten: 03/28/2021

no, im using VM which require network to be entered manually for the OS installed within it.

how trisquel find out about the internet , you entered network info manually into the network manager? or trisquel detected the network info automatically?

panties
Offline
Beigetreten: 02/02/2021

> no, im using VM which require network to be entered manually for the OS installed within it.

So sorry, I cannot help you. Maybe there are other users who are familiar with this kind of things than me. I hope that they will help you.

However, are you sure if that is really VM?

Geshmy
Offline
Beigetreten: 04/23/2015

I use WiFi in house. My WiFi set up does not offer DHCP, does not broadcast its name and has a non-default network range.

An example for connecting to a hidden WiFi network
In home Class C network 192.168.200.0
Gateway 192.168.200.1
Name Server is 1.1.1.1

Since this network doesn't offer DHCP I need to assign the static IP myself.

1. Right click network manager icon in the task bar and choose edit connections.
2. Click on the + button and choose: WiFi. Here also you might want to give this connection a name, like say Bobo'sHouse. Anything is OK.
3. Click on create.

This opens up a dialog with tabs and you can enter your static IP (here 192.168.200.59 would work), Gateway IP and nameserver IPs in the IPv4 Settings tab.

For me, once I create this WiFi connection, When I click on the network manager icon and select Connect to Hidden WiFi Network a dialog opens up that has a drop down box and I find the name of my connection there and select it and I am connected.

If your case is simply hard wired to your router you can achieve what you need by right click network manager and select edit connections and put the information in the IPv4 Network Settings tab.

No two devices can have the same IP and your public IP would be assigned to your modem.

Hope that helps, if the VM situation requires something different, I don't know.

goyob
Offline
Beigetreten: 03/28/2021

> If your case is simply hard wired to your router you can achieve what you need by right click network manager and select edit connections and put the information in the IPv4 Network Settings tab.

Thats exactly what im doing and its not working.

Other distros working like debian,ubuntu,fedora except this distro and not sure where or what is the issue.

goyob
Offline
Beigetreten: 03/28/2021

even configured /etc/resolv.conf , /etc/network/interfaces manually still same thing.

btw distro-vm im trying to install in is Qubes using HVM template. (which is like standalone Xen VM)

goyob
Offline
Beigetreten: 03/28/2021

Issue fixed by removing Trisquel with MATE DE and installing Triskel which is coming with KDE DE.

(but no idea what caused the issue in Trisquel-MATE)

boi
boi
Offline
Beigetreten: 04/01/2021

In the VM settings change network adapter to Bridged.