Wi-Fi Not Connecting Automatically

1 Antwort [Letzter Beitrag]
benice
Offline
Beigetreten: 09/16/2017

Hello, this is my first post here. I have an x200 from Vikings. Here is the version of Trisquel and kernel I am running:

Linux version 3.13.0-129-generic (name at domain) (gcc version 4.8.4 (Ubuntu 4.8.4-2ubuntu1~14.04.3) ) #178+7.0trisquel2 SMP Tue Aug 29 11:57:26 UTC 2017

The issue is that my Wi-Fi is not connecting automatically after reboot or suspend. I have to manually click on the Wi-Fi symbol in the panel, select the network and click on it before it will connect. Strangely, I can see it attempting to make a connection before I do this, but it never succeeds. I have the "Automatically connect to this network when it is available" box checked.

I know this was a bug in Ubuntu 14.04 for quite a while that seemed to have gotten fixed eventually. I used Ubuntu before (not on this laptop) but never had this issue.

Is there any way to fix this? Thanks!

benice
Offline
Beigetreten: 09/16/2017

You are the man!!! Thanks a lot.

I actually had a two-part problem. The wifi wasn't connecting automatically, which you helped me solve. The following answer is what fixed it for me:

https://askubuntu.com/a/608897

But I also use a VPN, and so had to tweak the config file. Setting "password_flags=0" was the setting that worked for me instead of "Xauth password-flags=0" which wasn't present in my config file. It's all discussed below:

https://askubuntu.com/a/475667

Everything works now. My quality of life is very improved, much appreciated.