no talloc stackframe at ../source3/param/loadparm.c:4864, leaking memory


When trying to gain sudo rights e.g. using sudo bash, I got an error:

no talloc stackframe at ../source3/param/loadparm.c:4864, leaking memory

This is caused by libpam-smbpass and can be solved by removing the package (I guess it's not necessary on trisquel.)

So, 08/10/2014 - 21:30

This is an upstream bug:

So I believe this should be closed.

Di, 09/23/2014 - 13:13

This bug is solved in upstream.

As stated in the following comment,

"I checked Samba changelog, the patch was included in Samba 4.1.10. It's scheduled for release with Trusty 14.04.2"

Di, 10/14/2014 - 16:47

The bug legimet mentions above is now marked duplicate of:

I'm arranging for this issue to be assigned to 'upstream'.

Mi, 10/15/2014 - 20:20
Zugewiesen zu:anonymous» upstream
Do, 11/13/2014 - 19:38

To save users from looking it up on launchpad the upstream bug is scheduled to be fixed in 14.02.2 which is due February 2015.

So, 11/16/2014 - 00:23

Looks like it's possible to fix it without removing libpam-smbpass. Just by running "sudo pam-auth-update" and remove "SMB password synchronization".
Source :

So, 02/15/2015 - 23:18

Sasaki's suggestion solved the issue for me, thank you.

Fr, 07/10/2015 - 16:50
Status:active» fixed

The verified upstream fix is now in the repos. Please comment both on launchpad and here if this does not resolve the problem for you.

Fr, 07/24/2015 - 16:55
Status:fixed» closed

Automatically closed -- issue fixed for 2 weeks with no activity.