Can't upgrade to Trisquel 7.0

Zugewiesen:nicht zugewiesen
Status:can't reproduce

I get the following error from the upgrade tool:

An unresolvable problem occurred while calculating the upgrade.
This can be caused by:
* Upgrading to a pre-release version of Trisquel
* Running the current pre-release version of Trisquel
* Unofficial software packages not provided by Trisquel

And then the Update Manager says:

"Error: Selecting updates (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)"

I start with fully updated Trisquel 6.0.1 (64-bit) with '/etc/apt/sources.list' containing this:

deb toutatis main
deb toutatis-updates main
deb toutatis-security main

All the ppa's are ppa-purged and all the packages in 'local' section in Synaptic are uninstalled. I have no broken or locked packages. I tried with kernel & X stack updated to trusty, then downgraded to saucy, then downgraded to raw precise. No difference.
Is there anything else I can try?

Mo, 11/10/2014 - 13:20

Is your /home partition separate? If this is the case, you can easily freshly install Trisquel 7 without losing your settings or personal data.

Mo, 11/10/2014 - 18:39

Thanks for the thought. I'll probably go for fresh install in the end. Although preserving /home data might be a little tricky in my configuration (encrypted LVM). But for now I just want to try v7.0. Upgrading is convenient because I can test the system with all my software installed, then restore from snapshot if I don't like it.

Di, 11/18/2014 - 05:37

Wow... It's been a while since the last time I logged in my account through the website, but anyways...

I also have the same issue, although I tried it with do-release-upgrade (no force option) and Apper, but the first one says exactly what is in the first comment, and the second tells me that my system isn't recognized by the upgrade script...

My home folder isn't in a separated partition, but is encrypted using dmcrypt/ecryptfs.

However, I have a Mumble server running here, I have managed to ask for the other administrator to host the server temporarely until tomorrow, but perhaps I can postpone my return, no worries here.

I'll try uninstalling the Linux-libre packages from Jxself's repositories...

Best regards, ADFENO.
Have a nice day.

Fr, 11/21/2014 - 18:23

I got around the issue by making a clean install.

Best regards, ADFENO.
Have a nice day.

Mo, 11/25/2019 - 00:15
Status:active» can't reproduce

Do you still have the same issue? While there's no answer, I'll mark this as unreproducible.