[HOW TO] Install the latest Linux-Libre kernel in Trisquel

6 replies [Last post]
NickThom
Offline
Joined: 09/03/2017

If for some reason we need the latest linux-libre kernel in Trisquel, we can follow this guide to achieve our goal.

Add the Official repository.

This repository comes from FSFLA (Free Software Foundation Latin America) the part of the FSF that maintaining the linux-libre kernel.

sudo vim /etc/apt/sources.list.d/linux-libre.list
add the following line
deb http://linux-libre.fsfla.org/pub/linux-libre/freesh/ freesh main
proofread and save the file.
You can use the text editor of your choice instead of vim.

Download, check and add the signing key.

It is important to check the signing key before adding it to your system.
wget https://jxself.org/gpg.inc
gpg --with-fingerprint gpg.inc
The result of the Fingerprint should match the following
Key fingerprint = F611 A908 FFA1 65C6 9958 4ED4 9D0D B31B 545A 3198
Adding the key and removing the key file.
sudo apt-key add gpg.inc
rm gpg.inc

Updating the package manager and installing the libre kernel.
sudo apt-get update
sudo apt-get install linux-libre

As long as the repository is enabled, we will always have the latest linux-libre kernel to our system. For now is 4.13

The kernel is one of the most crucial software in our system. Nevertheless, it doesn't have much of dependencies and it is most likely it will not generate any "dependencies hell".
But we always should check what will happen to our system before hit the "Y".

This guide worked without problems in Trisquel 7.

Sources:
1) http://www.fsfla.org/ikiwiki/selibre/linux-libre/index.en.html#repo-freesh
2) https://jxself.org/linux-libre/

CalmStorm

I am a member!

Offline
Joined: 12/31/2014

It also works on debian/devuan... (devuan though works better in my experience for linux libre. not sure why.

I tried debian stretch and devuan stretch back when it was four months from being stable.

Devuan unstable which I am using now works fine with linux-libre as the kernel. :)

I am using it on my x200 libreboot.

WITHOUT, non-free software of course. or firmware! :)

I wonder if linux-libre works on eoma68-a20. though it is an arm processor... hmm...

I mean, linux libre from jxself's repository. heh my bad. for any devuan or debian based distro. or trisquel as the case may be. :)

davidnotcoulthard
Offline
Joined: 02/28/2014

The (I assume not outdated) page says x86 or AMD64 so...I don't think it's going to run on ARM.

CalmStorm

I am a member!

Offline
Joined: 12/31/2014

That is a damn shame...

By the way for anyone who installs linux-libre from jxself.org, avoid linux-libre 4.13.2 it gives me a kernel panic.

Actually though, I wonder if he would be willing once eoma68 is released, to make an arm version of linux-libre... hmm.

I would definitely be willing to donate for that.

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Was it a kernel panic or a problem with mounting an encrypted /home? Because that is the problem I faced tonight: the init never reaches the graphical login screen, I skipped mounting /home (with S) and in a terminal I access with Ctrl+Alt+F1:
$ sudo ecryptfs-mount-private
ERROR: Encrypted private directory is not set up properly

I had the good idea to keep the latest 3.13 kernel (Trisquel 7's default) and, booting it, /home is mounted without any issue. I backed up my data (to not lose a few days of work if the hardware really is at fault) and installed linux-libre-lts" (4.9.50). It mounts my encrypted /home too.

CalmStorm

I am a member!

Offline
Joined: 12/31/2014

It was a kernel panic actually. But I just reinstalled it after a fresh install and it worked. I don't really know why... either.

Magic Banana

I am a member!

Offline
Joined: 07/24/2010

Same here: today Linux-libre 4.13.2 worked OK.