Using xinput correctly

No replies
Joined: 08/31/2019

Hello everyone.

I'd avoided Trisquel 9 because of some mouse sensitivity issues, since I have a lot of time on my hands, I decided to experiment with a fresh install and see if I can't get it working.

'xinput --list --short'
I saw that my mouse was id 16, and I used
'xinput --list-props 16'
I couldn't find velocity anywhere, only "libinput Accel Speed" which could not be set to anything above '1' which it already was. So instead I changed the non-zero values of "Coordinate Transformation Matrix" from 1s to 2s. This worked and made my mouse faster.

My issue is that after a reboot, the mouse sensitivity was back to a crawl. I ran 'xinput --list --short' once more and saw that my mouse had a different id. I have not removed/replugged it at all. The id for the mouse was now 9.

How can I make a permanent fix? I thought about perhaps a script that would run at start to fix this, but the id also changes so I'm unsure. Maybe there's a better method, but I couldn't find through the MATE control center.