xserver-xorg-video-nv missing

Category:bug report

The free software Nvidia "nv" driver is missing from this release of Trisquel as it was dropped in Ubuntu:


I'm using a GeForce FX 5200 NVIDIA AGP card. The nouveau driver does not work - I reach a black screen with a mouse cursor which I can move:


I blacklisted nouveau and added nomodeset to kernel parameter as was suggested here:


As root I ran the command

echo blacklist nouveau > /etc/modprobe.d/blacklist-nouveau.conf

and I added nomodeset to the line GRUB_CMDLINE_LINUX_DEFAULT after the words "quiet splash" in /etc/default/grub after which I ran "sudo update-grub".

Adding kernel parameter "nomodeset" switches to vesa driver which does not support video playback using xv.

Since nv is missing it must be compiled from source. In order to do this one needs to add to /etc/apt/sources.list the following lines:

deb http://es.archive.trisquel.info/trisquel dagda main
deb-src http://es.archive.trisquel.info/trisquel dagda main

Then do as appears here:

sudo apt-get update

sudo apt-get install build-essential fakeroot dpkg-dev

mkdir nv-build

cd nv-build

apt-get source xserver-xorg-video-nv

cd xserver-xorg-video-nv-2.1.17

sudo apt-get build-dep xserver-xorg-video-nv

dpkg-buildpackage -rfakeroot -b

cd ..

sudo dpkg -i ./*.deb

Now you can remove the dagda lines from /etc/apt/sources.list

Now I can playback video fine :)

Tue, 09/10/2013 - 13:04

I forgot to mention that Ubuntu developers recommend using the proprietary NVIDIA driver whenever nouveau doesn't work and thus don't bother keeping an unmaintained free driver (nv). This is why I found the instructions in a PowerPC forum (where the proprietary NVIDIA drivers are not available). My suggestion is to add a compiled version of the nv driver to Trisquel's repos so that whoever has an NVIDIA card that is not supported by nouveau can still use it for simple tasks such as watching (non-HD) videos - otherwise only the vesa driver is available.