aBrowser usability or rendering issues

Category:bug report
Status:needs more info

As of the last few days or a week (after upgrading), some websites do not render properly if at all. Tried two different machines running similar installation of Trisquel.

The most common problems seem to be a lack of CSS or hanging after an onClick. Decided to try visiting top pages of several banking and email provider websites as a benchmark. Google Docs fails. Chase fails. Couldn't find any direct correction between non-free JS using LibreJS. I'd share the URL's of the pages I'm most frustrated with, but they're through work VPN and only accessible on intranets.

Not a complete show stopper for Trisquel; problems do not show up in native Epiphany, Midori, rekonq, or Firefox, or Firefox in Wine, or Firefox on a dualboot instance of another operating system on the same hardwares.

~$ uname -a
Linux $system 3.2.0-65-generic #1trisquel1 SMP Sun Jul 6 20:50:01 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Tue, 07/15/2014 - 05:48
Status:active» can't reproduce

Are you using add-ons? If so, try disabling them.

Also try with a fresh user profile by moving ~/.mozilla to a different name and then runing Abrowser.

You can also run 'abrowser -jsconsole' in the terminal to see if it shows errors.

Tue, 07/15/2014 - 06:22

How did you try to reproduce it? What is your uname -a? What version of aBrowser? Did you visit chase.com? That site doesn't help me, but it's the most obvious if you visit it.

Not using any addons, currently. I turned all of them off and slowly turned them back on. Not much in there, but if you look at the irc history from earlier today I had a few other things to say.

I moved ~/.mozilla and ran abrowser -jsconsole and got the attached console output when starting up to the new tab page. Same problems on other pages. Does any of that muck mean anything to you? I'll examining each error later.

I fired up another machine that hasn't been on since May 28th. It has no issues. Since this happened twice, it probably was a corruption during apt-get upgrade. The other two machines don't share users or browsing habits/plugins.

If the console out reveals nothing, I'll try reinstalling onto anther file system.

consoleOut.txt 1.21 KB
Sun, 07/20/2014 - 20:21
Status:can't reproduce» needs more info

Using the NetInstall 64bit version, I reinstalled on three different machines, ran an upgrade and then a dist-upgrade and came up with the same problem.

I'll try the 32bit version next. My turn around might be slow, but I'll keep this on my radar.

EDIT: A much more obvious and closer to home example that I didn't notice before is the Trisquel Issue tracker page. For example, in aBrowser I can't see most of the last three columns in the table, but even in Firefox I can see the rest.

Mon, 07/21/2014 - 21:15

Tried the NetInstall for 32bit and ran into the same issue.

Also found the USB flash the FSF sent me and had the same issue, but only after running apt-get upgrade.

Tue, 07/22/2014 - 19:06

Can you post screenshots?