Nautilus eventually rejects most keyboard input

Category:bug report

I'm running Nautilus on a Trisquel 7 install on AMD 64-bit hardware.

Every time I use Nautilus, Nautilus eventually stops accepting keyboard input for tasks like finding files and renaming files/directories. I can't come up with a reliable means of reproducing this, but it seems to happen rather quickly after I use Nautilus to rename a bunch of files.

Certain keys always work -- arrow keys, return, function keys, and ESC -- but the alphanumeric keys (and their shifted variants for !@#$, etc.) don't seem to do anything after using Nautilus for a while. I can initiate a rename action with F2 and see the highlighted file/directory name but I can't type in anything to specify the new name.

Workaround: restart Nautilus by opening a terminal window (or using the System Monitor) to kill the nautilus task, then relaunch nautilus. Obviously this is annoying and one loses whatever work they were doing in any Nautilus window.

Sat, 01/31/2015 - 12:54

I've got that same error a couple of times too while trying to rename some directories. Indeed it's very annoying. Im running Trisquel 7.0 ( 64 bit ) as well.

Tue, 10/13/2015 - 19:33
Priority:normal» critical

This behavior started only recently with my Trisquel 7 installation. I can squeeze in maybe one new and appropriately named folder and then the next one ends up as "untitled folder." Now keyboard input is allowed when attempting to rename it. Thi is a critical bug because it will eventually cause me to lose work, as I have to reboot ... and just restarting my GUI isn't a real fix, as that will also trash ongoing tasks.

My GUI is the Classic Menu Indicator ...

Tue, 10/13/2015 - 20:17

Although I'm not using neither GNOME nor Nautilus (as I'm using XFCE with Thunar as file manager), I remember that this seems to be related to the keyboard input method chosen (although I don't have references to prove my point here).

Perhaps this can be worked around by opening Nautilus for the first time after login using:

XMODIFIERS="" nautilus

Fri, 10/23/2015 - 12:39

Try doing: $ pkill ibus-daemon?

It may be the case that the bug only occurs when you have two keyboard layouts, or a language other than US english selected, or something like that.

Or, maybe try the link to the ibus ("intelligent keyboard entry bus" used for complex entry). You can disable it permanently so it doesn't start at all, meaning you don't have to kill it every time.

Go to the "System Parameters" application. Click the Languages button, then on the bottom of the window, you'll have something like "keyboard input system" with "IBus" selected. Select "None" and that's it!

Sat, 08/26/2017 - 20:35

MeNoMore's suggestion to type "pkill ibus-daemon" in the Terminal finally did the trick after his suggestion to turn off ibus in the System Settings ... language support window failed to make a difference.

What a relief ... I was reluctant to download umpteen images from a digital camera for nearly two years.

Thank you !