custom shortcuts not working

Category:bug report

I assigned "Super+d" to "wmctrl -k on" through Keyboard -> Shortcuts -> Custom Shortcuts, but it does not work while "wmctrl -k on" works from command line.

I tried to replace "wmctrl -k on" with another command, just to see, but it also does not work.

Fri, 07/31/2015 - 13:56
Sat, 08/15/2015 - 07:17

Thanks for your tip and sorry for the late answer (I was out on holidays !).
I saw that thread, but I reported that issue as it seems to be a bug that should be fixed.
Also, I read xmodmap man page but unfortunately did not find the way to assign a command to a keystroke.
Could you please give me an example if you have any ?


Tue, 08/18/2015 - 05:56

Hi! Sorry brain malfunction I meant xbindkeys and not xmodmap. There is also a xbindkeys-config package.

I agree it's a bug to be fixed.

Tue, 08/18/2015 - 07:03

Thanks for the tip !
I tried it. For some reason, Super+d is not properly recognized by xbindkeys (I checked it with xbindkeys -mk), but I could assign control+alt+d to "wmctrl -k on", that will do the job...

Tue, 08/18/2015 - 08:08

At least on my system it's called Multi_key, dunno where I got that.

Tue, 08/18/2015 - 09:49

Thanks, I'll try that.