Unable to boot into bios.

Category:bug report

Hi everyone,

I am new to GNU/Linux. I was previously running Win 7 on my Acer Aspire 4752 laptop but after it became unmanageably slow I reformatted and installed Trisquel 7.0 with full disk encryption.

Prior to installing Trisquel, upon booting up the laptop, I was able to press F2 into to enter into the bios. Similarly,I could press F12 to select which device to boot from. Both options still exist, however when I press either F-key, it goes straight to the screen to decrypt everything before presenting the login screen for Trisquel.

Any ideas as to what's going on here? As a noob, if anyone could provide the commands in order to get any relevant information out of the system, that'd be much appreciated.

Tue, 10/13/2015 - 15:38

I strongly doubt that installing GNU/Linux has somehow affected your BIOS, because the BIOS exists inside a flash chip that is separate from your storage devices. Maybe you can check the user's manual for the computer you've got or use a search engine to see if someone else has also had the problem with F keys having stopped working.

By the way, I believe that you wanted to say that you're a newbie, i.e. someone who is new but willing to learn. Being a noob, however, is not a good thing at all.

Wed, 10/14/2015 - 06:37

Thanks for your input. I thought it might be related to the installation of Trisquel as I only encountered the problem after installing it. I'll see what I can find regarding similar problems and solutions.

And yes, if being a noob is not ideal, I'll be a newbie instead.

Should I mark this "bug" as solved or something? What's the protocol for the issue I'm experiencing?

Wed, 10/14/2015 - 09:28

Try resetting the BIOS by removing

1) AC power
2) Laptop battery
3) BIOS battery

for 10 (?) minutes.

Here's is an example image of a BIOS battery on a (random) motherboard. (That shiny coin looking thing.)

While you're at it you might replace the battery with a new one.

Wed, 10/14/2015 - 23:05

Please try what lembas or I suggested (or something else) and then report back. You shouldn't mark this as solved if it hasn't been. If for some reason Trisquel installations mess with the boot firmware, we would all want to know about it!

Fri, 10/16/2015 - 00:18

I've just pulled my laptop apart to find the button cell - why they hid it right in the inaccessible center of the mobo is beyond me...

Anyway, after 15 minutes without the button cell, battery or power cord. I still received the same error. I've left the hard drive and dvd drive out as well to see if that would make a difference and it just it goes from the Phoenix bios screen straight to "Operating system not found".

Here's the information I received when I press Esc upon booting:

Phoenix SecureCore Tiano(TM)
Copyright 1985-2011 Phoenix Technologies Ltd.
All Rights Reserved
This BIOS is exclusively for Acer only
Copyright 2011 by Acer Inc.

CPU = Intel (R) Core (TM) i3-2350M CPU @ 2.30GHz
4096 MB System RAM Passed
256 KB L2 Cache
System BIOS shadowed
Video BIOS shadowed
BIOS Version: V2.19

Press any Key to Exist.


What does that mean "shadowed" ?

Perhaps 15 minutes wasn't long enough for the cmos chip to be erased?

Thanks again.

Fri, 10/16/2015 - 01:24

Ok I left the button cell out for an hour, along with the laptop battery and power cord and still am unable to enter bios. I tried a differet button cell as well but no difference.

When I press F2 or F12 to enter bios or select boot device, respectively, it just returns the screen "Operating system not found".

I'm going to put the laptop back together as I'll need it soon for work purposes.

Any other suggestions?

Fri, 10/16/2015 - 13:30

I thiiiiink, I had the same Problem. My laptop didn't boot up after I did the whole setup thing on Windows for my Trisquel, and I accidentally reset the WHOLE thing back into its default everything settings (luckily, I work from hard-drives and do not save anything on my laptop)
Anyway, it did not want to boot up into the newly installed Trisquel. I cannot remember what I did for it to boot up into Trisquel. But if that is your problem, I am happy to help talk you trough a whole how to for newbies since I am a newbie to Trisquel as well! (:

Mon, 02/29/2016 - 21:52

So after ripping the laptop apart and leaving the button cell out over night, powering the laptop up without the cell in, shorting the cell connections - every possible combination - I'm still unable to boot into bios.

I've found a few other people with acer laptops so I don't think it's a Trisquel problem (they were all running Windows). I do find it odd though that I only started experiencing the problem after installing Trisquel.

Anyway, needless to say I won't be able to use this laptop any more once I've played with Trisquel beyond repair. I can't get it to boot any other operating system on any other media.

Thanks anyway peeps.