Trisquel text mode installer not working because of broken download

Category:bug report

Trisquel text mode installer doesn't work at all. Being an online installer, it relies in network connection to download the packages it needs - until some download fails, turning it into a merely decorative object with no useful purpouse.
From at least april 1, the download of libcryptsetup4-udeb package has been consistently failing in all mirrors. Here comes a copy from output:

Apr 5 15:20:10 anna[2130]: DEBUG: retrieving libcryptsetup4-udeb 2:1.6.1-1ubuntu1
Apr 5 15:20:10 anna[2130]: Segmentation fault
Apr 5 15:20:10 kernel: [ 248.047364] wget[3185]: segfault at b777ed9d ip b7387a0d sp bfc3cf60 error 7 in[b737e000+13000]
Apr 5 15:20:10 kernel: [ 248.119977] wget[3192]: segfault at b77afd9d ip b73b8a0d sp bfe89240 error 7 in[b73af000+13000]
Apr 5 15:20:10 anna[2130]: Segmentation fault
Apr 5 15:20:10 anna[2130]: WARNING **: package retrieval failed

Wed, 04/13/2016 - 18:00

Seven days since the issue was reported and counting...

Thu, 04/21/2016 - 14:17

Issue with package libcryptsetup4-udeb 2:1.6.1-1ubuntu1 happens not only to Trisquel. The "deb" and "ubuntu" in its name refer to Debian and Ubuntu.
-The ubuntu in its address means it is supposed to be part of an Ubuntu repository. Somehow I expected Trisquel to have its own repositories, and by that I mean repositories where the packages Trisquel needs for installing itself are guaranteed to be found.
-The description of this package at Ubuntu packages is "This package is intended for the use in building debian-installer images only. Do not install it on a normal Ubuntu system.". Strange enough, I thought that Ubuntu was based on Debian and not the other way round.

Ubuntu – Details of package libcryptsetup4-udeb in trusty

The issue with this package being missing has been reported as early as february, 25, 2016:

Bug #1549644 “libc6-udeb resolver segfaults when resolving local...” : Bugs : anna package : Ubuntu

So, it is 55 days old by now, and counting. 55 days without Trisquel text installer working, and therefore, 55 days without a way to install Trisquel with full disk encryption.

Thu, 04/21/2016 - 19:45

Trisquel has its own repositories. Obviously those cannot be reached without a network connection. Ubuntu is based on Debian.

Sat, 04/23/2016 - 12:23

I tried installing Trisquel using the NetInstall image (64bit) and had no problems. The problem you are experiencing might be tied to your DNS server, although there is certainly a bug somewhere since you're seeing a segfault.

I assume you tried installing using the NetInstall image also. Have you tried using the 1.5GB Live DVD iso image? It has a text-mode installer too, so you can have full disk encryption set up. It shouldn't be downloading udeb packages since they are on the install media.

Wed, 04/27/2016 - 19:46

> Trisquel has its own repositories.

Really? Then please explain to me why they have not a package which is essential for the text mode installer to work.

> Obviously those cannot be reached without a network connection.

And with a network connection not either.

Wed, 04/27/2016 - 21:34

This is what I have tried all along april, 2016:
-Trisquel NetInstall: Libreboot fails to boot from it. Selecting the "boot from USB" option just gets no response.
-Trisquel Mini: Libreboot boots from it. Provides graphic installer only, which lacks the full-disk encryption option.
-Trisquel: Libreboot boots from it. Provides both text-mode installer, which fails to work because of the broken download, and graphic installer (both directly from the boot menu and inside the live system), which lacks the full-disk encryption option.

Definitely the problem is not from DNS trouble, as the failure happens with two different ISPs. Also, it happens always with a single package at the 19% mark - previous packages download successfully.

After the release of Ubuntu 16.04 I get the idea of Trisquel team focusing in the release of Trisquel 8, so if they did not solve this bug before, it seems not likely it will be solved now. Guess that this "active" bug report has become, in fact, "uncared for". If I want full-disk encryption I will have to wait for Trisquel 8. Hope that I can get it in the month of may, 2016, so I don't have to look for an alternative.

Fri, 04/29/2016 - 15:57

Mind you, this is with 32-bit ISO images, with 64-bit ISO images the text mode installer proceeds to download all the packages with no trouble.

Fri, 05/13/2016 - 10:50

Confirmed many trials with Qemu or other pc


segfault at b7747d ip b7350a0d sp error 7 in

this affects 32bit NetInstall & Trisquel 7 Belenos GNOME Texte-mode installer
will be testing 64bit as soon as possible.

Fri, 05/13/2016 - 22:25

Full install with Qemu 64 bit Trisquel 7 Belenos GNOME in Text-mode & Netinstall isos, worked fine.