no java is allowed to be installed

Category:bug report

I am told that i must install OPENJDK java 6 to get java (I assume this is why I cannot get youtube), however installing it via Add/remove i get: "conflicts with other installed software" and installing via synaptic i get "broken package". java 7 is also available here and I have the same problem with that.
There are six in the list of dependant packages to be installed (and in the not authenticated list), although the package i selected (openjdk-6-jre) is present as a seventh in the "not authenticated" list. After that it shows up with a red box, cannot choose apply (tells me to fix the broken packages).

Sun, 10/02/2016 - 20:55

I didn't get what you mean. Can you attach a screenshot here?

Mon, 10/03/2016 - 08:07

Why is it that i get the feeling that you do not believe me... Yes it is trisquel 7 I am using...

Image shows: Top one is after trying to check the box beside OpenJDK, bottom one shows the additional packages it wants to also install, shows Java marked red and also shows the message I get after clicking apply.

I forgot to add in the first message that if I unmark openjdk-6-jre, it does not remove all the dependant packages, it still wants to install 3 packages (icedtea-netx-common, java-common and ttf-dejavu-extra). If I click apply at this time I get "An error occured, The following details are provided:"

E: Unable to correct problems, you have held broken packages.
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
E: Unable to lock the download directory

I can close the package manager and reopen and download other packages (ie games) with no "you have held broken packages" error. I did read that I ought to try another server, I have tried refreshing from the Main, spain and india servers.

Screenshot from 2016-10-03 16:17:21.png 218.56 KB
Mon, 10/03/2016 - 11:01

I just meant that I could not understand it. I'm not in the position of believing or not believing someone. ;)

When it says 'you have held broken packages' it means that it won't do anything until you have solved this error.

try installing 'OpenJDK 7' from 'terminal' and then paste here the error message:

$ sudo apt-get install openjdk-7-jre

Tue, 10/04/2016 - 00:20

Why does it give BETTER errors if I do not use the GUI (why is a secret handshake needed?!)

E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

And no, I do not understand it (er, see EDIT). But I am used to that: I wrote a program once in microsoft VB, and it frequently got microsoft errors while playing media, I would let the program forward the error to the user and I would also give my solution to the error - which seemed to be completely unrelated to the MS error message. It would be great is something similar gets adopted in linux - give at least one thing to try before wasting people's time seeking help...

Perhaps I was very enthusiastic and installed other stuff before I noticed I needed Java (which conflicted), whereas others might install it first.

Edit: tried again after closing Disks, libreoffice, .... etc.

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
openjdk-7-jre : Depends: openjdk-7-jre-headless (= 7u51-2.4.6-1ubuntu4) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I note that the total packages installed (as reported by synaptic) is still 1919, so nothing has been installed. Im no pro but it might be a branding issue... Sorry, I can be a little irritating at (all) times :P

Tue, 10/04/2016 - 09:59

Here is the bug reporting system and if you have difficulties with using Trisquel, you are advised to use the 'forum' section of the site which is accessible from the top navbar.

anyway, run the following command and if you faced any further error please paste the error message in a new forum topic.

$ sudo apt-get install -f

Tue, 10/04/2016 - 13:24
Version:8.0» 7.0
Tue, 10/04/2016 - 23:19

BTW Java has nothing to do with Youtube.

Fri, 10/07/2016 - 05:58

No problem executing that command. No problem executing apt-get autoremove.
Java is still reported as a broken package in synaptic - problem remains (tried reboot too).

thanks, i was curious how I ought to do that, it should be placed in the GUI!

I know i need it for libreoffice. As for youtube (which is not what this post is about - could be an Abrowser discussion i guess), something prevents the videos playing, flash works i think and it works for NomNom in streaming mode (it retreives a YT URL and plays it from YT).

Sat, 10/08/2016 - 22:20

Try disabling Gnash. That should allow you to watch Youtube videos.

When you run "sudo apt-get install -f" what is the output?

Mon, 10/10/2016 - 21:09

not sure how productive that command is, but here is the output:

Reading package lists... Done
Building dependency tree
Reading state information... Done
0 to upgrade, 0 to newly install, 0 to remove and 729 not to upgrade.

Thu, 10/13/2016 - 03:01

Can you post this on the forum? More people look at that and you will get faster replies.
What happens when you try
$ sudo apt-get install openjdk-7-jre-headless

Thu, 10/13/2016 - 03:42

This has been up for a while now and since then I have been adding and removing packages. Before pressing Y on your command, I decided to check to see if the problem is actually still happening and the broken package issue seems to have cleared up in synaptic.

Here is the list of packages it now wanted to install: (I am not sure if entering your command and pressing n instead of Y had any influence)


Among the changes: I had removed libreoffice and added openoffice. And also applied the system updates. It doesn't seem reasonable that the lack of the system's update would break a package if synaptic had actually considered the java package's dependencies properly (ie, if it actually required new versions of packages).

(note that at the time I thought that the system was "up to date" but that was the message it gave because I had also told it to not update (normal programs ignore the no-update command if I manually click update - works different in linux))

If it truely is an issue with synaptic or the list of dependencies of java then this bug should remain open otherwise this same issue may happen in the future for other packages to other people, even if you ever get to trisquel 8.

Thu, 10/13/2016 - 04:05

Not sure if related to system update or the java install, but youtube does work now.

Thu, 10/13/2016 - 22:09

Youtube is not related to Java.

If the broken packages are resolved just run:
sudo apt install default-jre

Also, I would use Libreoffice instead of Openoffice. It's your choice of course, but Openoffice is dying and had a security vulnerability that they knew about but wasn't fixed for months because of lack of manpower.